1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Clutch Smell

Discussion in '2nd Gen. Tacomas (2005-2015)' started by tacoriffic, Dec 6, 2010.

  1. Dec 6, 2010 at 1:17 PM
    #1
    tacoriffic

    tacoriffic [OP] Well-Known Member

    Joined:
    Dec 6, 2010
    Member:
    #47252
    Messages:
    104
    Gender:
    Male
    First Name:
    Greg
    Rhode Island
    Clarion CX609 HU, Satoshi Grill, More to come
    Just picked up my 2011 Access SR5 4cly Manual, and I got a clutch smell when I was first driving it. Now it seemed to go away for the most part. I'm just scared that I did some permanent damage. Is there like a break in period? I currently have 250 miles on it. I did ride the clutch a little getting used to where the catch point was on take-offs, but not now.
     
  2. Dec 6, 2010 at 2:18 PM
    #2
    TACK

    TACK Well-Known Member

    Joined:
    Aug 16, 2010
    Member:
    #41804
    Messages:
    512
    Gender:
    Male
    Nevada
    Vehicle:
    10 PreRunner TRD Off-Road MGM
    Bilstein 5100s at 1.75", Level 8 Tracker wheels, Sickspeed shift knob, mud flap delete, white lithium grease mod for creaky clutch pedal
    Mine smelled when it was new, too.
     
  3. Dec 6, 2010 at 2:54 PM
    #3
    tacoriffic

    tacoriffic [OP] Well-Known Member

    Joined:
    Dec 6, 2010
    Member:
    #47252
    Messages:
    104
    Gender:
    Male
    First Name:
    Greg
    Rhode Island
    Clarion CX609 HU, Satoshi Grill, More to come
    I now have 280 miles after my ride home from work. I stuck my head under the truck and didn't get that burnt clutch smell, just the normal smell of a running engine.
     
To Top