1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Code P0441

Discussion in '1st Gen. Tacomas' started by bsandb, Apr 8, 2010.

  1. bsandb

    bsandb [OP] New Member

    Joined:
    Oct 21, 2009
    Member:
    #24688
    Messages:
    4
    Gender:
    Male
    Vehicle:
    2002 Tacoma SR5
    I am getting P0441 code and I really need some advice. I have put a new gas cap on, but when I pull my truck into the garage there is an overwhelming odor of gas fumes. If I put the old gas cap on the odor isn't as bad. The vacuum lines appear to be OK. If I clear the code it will stay off for 4-6 days and then come back on. The truck idles different when the CEL is on. Any advice will be greatly appreciated. Thanks in adance!
     
  2. Coolidge

    Coolidge Well-Known Member

    Joined:
    Mar 9, 2010
    Member:
    #32873
    Messages:
    332
    Gender:
    Male
    First Name:
    Guy
    Lancaster, Ca
    Vehicle:
    2003 Pre Runner
    King coilovers frt +3". Bilstein 5100 shocks rear w/AAL, K&N FIPK, Magnablow exhaust, Billet grill, clear corner lights, Sony stereo, JBL, Sub etc.
    Put a factory Toyota gas cap back on. Make sure it clicks a few times. Then check. Fords are notorious for CEL from gas caps. Dunno 'bout Toyota though
     
  3. bsandb

    bsandb [OP] New Member

    Joined:
    Oct 21, 2009
    Member:
    #24688
    Messages:
    4
    Gender:
    Male
    Vehicle:
    2002 Tacoma SR5
    I finally took the truck to the dealership and had them put it on the diagnostic machine. They told me that it was the vacuum valve assembly. They ordered the part and put it on, and now my check engine light is out. Hopefully the light stays out. The truck does seem to idle better.
     
  4. Digiratus

    Digiratus Adventurer

    Joined:
    Mar 26, 2010
    Member:
    #34006
    Messages:
    10,588
    Gender:
    Male
    First Name:
    Mike
    the Pacific Northwest, Exploring
    Vehicle:
    The RedHead
    King ET Coilovers Camburg Uniball UCAs Alcan 8-Leaf Rear Spring Packs Fox 2.0 Resi Rear Shocks FrankenFab Rear Shock Relocate Trail Gear U-bolt Flip Toytec 1" Extended Shackle 4.88 Nitro Gears ARB Front Locker OBA ARB Twin Comp 15x8 D Window Steelies 33" BFG KM2s Limited Edition Elite Front Bumper Smittybilt X2O 10K Winch PIAA 510 SMR Fog Lights Lightforce 170s Badland Sliders FrankenFab Tire Carrier Swingout bumper w/kitchen BudBuilt Front & Bellypan Skids BAMF Rear Diff Skid Whynter 65 qt. Fridge/Freezer CVT Mt Bachelor RTT Badland Custom Bed Rack GM 140 amp alternator Optima Yellow Top battery Magnaflow 18" Muffler Braided Steel Brake Lines K&N Drop-in air filter ScanGauge II OBDII Scanner Uniden 520xl CB radio 3’ Firestik Adjustable tip antenna Pioneer DEH-P9400BH HU Alpine Amps & Type R components (F) and coaxials (R) Wet Okole Seat Covers Weathertech Digital Liners Deck Plate Mod 1” Diff Drop Carrier Bearing Drop
    What is a vacuum valve assembly? Anyone know its primary function and where it is?
     
  5. brelandt

    brelandt Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    I'm want to know as well. After I changed my O2 Senor from the p1135 my CEL has come on twice and the codes where p0441, 442, and 446. Stays off for 3 or 4 days and comes on again. No telling how long this was going on since my CEL stayed on for 3 years due to the p1135.
     
  6. zero4

    zero4 Metal Cutter

    Joined:
    Sep 10, 2006
    Member:
    #31
    Messages:
    443
    Gender:
    Male
    First Name:
    Will
    Northridge, CA
    Vehicle:
    01' DCab 3.4L TRD
    Donahoe CO, Donahoe Rear Resi, Deaver J59, 16" Pro Comp, 33" BFG AT, Hayden Trans Oil Cooler, Oil Filter Relocator, FM 40, ES Bushings, Beefed CB Drop, Deckplate, K&N Drop-In, DO Bed Bar, Cobra 75 WXST, Firestik Firefly, Philips D1R, Clarion Remote Start, Husky Liners
    Sounds to me like they're refering the EVAP purge solenoid. It's the valve that allows the engine to suck in the gas vapors from the fuel tank. The vapors get stored in the charcol canister & the valve lets the intake suck in the vapors. On many cars the charcol canister is under the car in the rear close to the gas tank but on our trucks it's located under the hood.
     
  7. TacomaDan

    TacomaDan Don't go off ninjin

    Joined:
    Apr 27, 2009
    Member:
    #16471
    Messages:
    737
    Gender:
    Male
    First Name:
    Daniel
    Woodland, CA
    Vehicle:
    1996 Toyota Tacoma Fully Not Loaded
    Love, Cobra 29 LTD BT CB w/ A2000 Highgear antenna, FOX/Fabtech Coilovers, Magnaflow
    I dont think that is it. I threw a P0446 took it to the dealer and had them fix it. It ended up being the charcoal canister and the valve assembly/solenoid or whatever is right there on top of the charcoal canister. There are 1.5 million valve assemblies on our trucks so its hard to say which. Just look for a new part on or around your truck, take a pic and send it to us. Maybe it could help some folks out.
     
  8. brelandt

    brelandt Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    yes please. I need to register my truck here in california and I will never pass smog if I have a cel......
     
  9. 98tacoma27

    98tacoma27 :POOPCORN: Thor

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,253
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    There could be one of many different issues to cause P0441/446.
    http://www.ncttora.com/fsm/2003/Repair_Manual/03tacoma/di/eg2rzfe3/cip0441p.pdf
     
  10. 98tacoma27

    98tacoma27 :POOPCORN: Thor

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,253
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
  11. brelandt

    brelandt Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    I'm hoping in my case it was just my gas cap. The last time I put gas in it I noticed it was harder to get the cap to click. Once I put the extra effort into it I got it to click twice. Use to just click 3 times no issue.
     
  12. SargeSlapnuts

    SargeSlapnuts SargeSlapnuts 보고용의!!!!

    Joined:
    Jan 20, 2011
    Member:
    #49565
    Messages:
    1,279
    Gender:
    Male
    First Name:
    Nick
    alpharetta, GA
    Vehicle:
    2004 TRD 4x4 converted PreRunner SR5 lifted l
    255/85-16 tires, front push bar w/9000lb winch, driver and passenger windows tinted to match factory rear tint, quick at home spray on bedliner, hid's, lifted with 3"toytec rear lift kit and ome front lift, locked with powertrax, and a cb radio in place of ash tray, fog light mod, diff breather mod, greasable shackles, Home made Baja Rack, "extra" bright reverse lights. also converted to 4x4 safari snorkel
    well this has been the code im getting and already bought a brand new toyota gas cap. guess ill check the vapor pressure switch next. good thread by the way.
     
  13. rubens281

    rubens281 New Member

    Joined:
    Dec 1, 2012
    Member:
    #92229
    Messages:
    1
    Gender:
    Male
    First Name:
    auto dr
    l.a.
    Vehicle:
    Tacoma 2000
    P0441purge flow insufficient my diagnosis was the vsv with the hoses.going to the manifold and charcoal canister tried activating with solus pro scan tool would not open put a,screw driver to it to listen to it is was ticking on off but not opening at all and problem fixed with new vsv
     
To Top