1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cold in Austin - Car sliding vid

Discussion in 'Texas' started by Tidrow, Feb 4, 2011.

  1. Feb 4, 2011 at 5:25 AM
    #1
    Tidrow

    Tidrow [OP] Well-Known Member

    Joined:
    May 17, 2010
    Member:
    #37300
    Messages:
    633
    Gender:
    Male
    Austin
    Vehicle:
    PreRunnin' 08
    BHLM, All Black grill, Fog light Mod, AFE pro dry, 20% tint, Weathertechs, Kenwood deck, Bridgestone AT Revo 2
  2. Feb 4, 2011 at 12:20 PM
    #2
    J Hoss

    J Hoss Well-Known Member

    Joined:
    Jul 21, 2010
    Member:
    #40572
    Messages:
    64
    Gender:
    Male
    First Name:
    Justin
    Round Rock, Tx
    Vehicle:
    4runner Trail Edition w/ KDSS
    Duratracs
    Heh just leaving the walmart target area in Round ROck, I averted a couple of cars and trucks spinning in place. 4WD + light foot on the gas = no problem.
     
  3. Feb 4, 2011 at 12:41 PM
    #3
    Tidrow

    Tidrow [OP] Well-Known Member

    Joined:
    May 17, 2010
    Member:
    #37300
    Messages:
    633
    Gender:
    Male
    Austin
    Vehicle:
    PreRunnin' 08
    BHLM, All Black grill, Fog light Mod, AFE pro dry, 20% tint, Weathertechs, Kenwood deck, Bridgestone AT Revo 2
    It made for an interesting morning. I work at YNN so I saw alot of cool video's that our viewers send in.

    Seems like it's all melted away by now.
     
To Top