1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Coolant leak

Discussion in '1st Gen. Tacomas (1995-2004)' started by mwrohde, Dec 22, 2014.

  1. Dec 22, 2014 at 6:16 AM
    #1
    mwrohde

    mwrohde [OP] Well-Known Member

    Joined:
    Mar 12, 2014
    Member:
    #125160
    Messages:
    1,041
    Gender:
    Male
    First Name:
    Matt
    Sugar Hill, GA
    Vehicle:
    2003 Tacoma 4x4 5-speed 3.4 TRD SR5
    2003 3.4. I'm getting a consistent leak from the upper hose where it attaches to the front of the engine.

    At first I thought I had the host clamp too loose, but I've tightened it up pretty good. So, my problem is something else.

    That piece that that the hose goes over has a little metal tab sticking strait up. Is the hose supposed to go over that tab, then get clamped, or is that tab a stop of sorts and the hose should go to that point, but not beyond? Or, something else?
     
  2. Dec 22, 2014 at 6:55 AM
    #2
    QuadsBC

    QuadsBC DON'T BUY FROM ME

    Joined:
    Oct 29, 2014
    Member:
    #141277
    Messages:
    251
    Gender:
    Male
    Vehicle:
    limited 4runner
    Stops at that tab. Best bet is to remove the upper hose put a rag into the water pump and either wire brush or lightly sand the connection to take off any corrosion. Do an eyeball check to make sure it's not damaged (dented). If damage is noted, replace water pump. While the hose is off check for cracks or wear. If you find any replace. I'd also replace the hose clamp.
     
  3. Dec 22, 2014 at 8:33 AM
    #3
    keakar

    keakar Well-Known Member

    Joined:
    Oct 2, 2014
    Member:
    #139537
    Messages:
    5,259
    Gender:
    Male
    First Name:
    karl
    louisiana
    Vehicle:
    2006 4runner sport 4.7L V8 (white)
    used to have - 99 2.4L I4 5 lug & 04 prerunner v6
    also don't forget to clean inside the hose where it fits onto the pump, often corrosion will stick to the hose and literally have little buts of metal stuck to it that corroded off the pump.

    scrape the inside with a screwdriver or butter knife so you clean it well but don't gouge it, or just put on a new hose.

    if the pump is badly pitted then clean it good and coat it with silicone sealant before reattaching the hose, this will fill any corrosion voids to stop any leaks.

    but .... if you have a lot of miles on it, just buy a new pump and new hose and your done.
     
  4. Dec 22, 2014 at 8:47 AM
    #4
    mwrohde

    mwrohde [OP] Well-Known Member

    Joined:
    Mar 12, 2014
    Member:
    #125160
    Messages:
    1,041
    Gender:
    Male
    First Name:
    Matt
    Sugar Hill, GA
    Vehicle:
    2003 Tacoma 4x4 5-speed 3.4 TRD SR5
    As I recall, the pump is about half way down behind the fan. That's not where I'm talking about. I'm talking about the top center front of the engine. Right where it says 3400. Hang on, I'll find a representative picture . . .
     
  5. Dec 22, 2014 at 8:52 AM
    #5
    Dirty Pool

    Dirty Pool NEW DELHI FREIGHT TRAIN

    Joined:
    Mar 24, 2013
    Member:
    #100471
    Messages:
    2,070
    Gender:
    Male
    59.4 Miles, 56.67° NE Of Moab
    Vehicle:
    99 XCAB V6 MT TRD
    Dirty Pool rear bumper/air tank with integrated spare CV shaft storage, DP customized TJM front bumper, 8000 lb Ramsey/Technora rope, E-locked, Extended breathers with front diff catch can, PCV catch can, SAWs with DP heim joint seals, DP custom 6 leaf rear springs/Billies, DP custom skids, 2lo, Gray wire, Cap, Bed Rug, Black steelies, 01 Center console, Map lights, Disraeli gears
    What does a water pump have to do with an upper radiator hose leak?
     
  6. Dec 22, 2014 at 8:58 AM
    #6
    mwrohde

    mwrohde [OP] Well-Known Member

    Joined:
    Mar 12, 2014
    Member:
    #125160
    Messages:
    1,041
    Gender:
    Male
    First Name:
    Matt
    Sugar Hill, GA
    Vehicle:
    2003 Tacoma 4x4 5-speed 3.4 TRD SR5
    Here's the problem:

    [​IMG]
     
  7. Dec 22, 2014 at 9:04 AM
    #7
    QuadsBC

    QuadsBC DON'T BUY FROM ME

    Joined:
    Oct 29, 2014
    Member:
    #141277
    Messages:
    251
    Gender:
    Male
    Vehicle:
    limited 4runner
    Yep, that's where I'm talking about. Do what i and others suggested about cleaning and report back
     
  8. Dec 22, 2014 at 9:12 AM
    #8
    Dirty Pool

    Dirty Pool NEW DELHI FREIGHT TRAIN

    Joined:
    Mar 24, 2013
    Member:
    #100471
    Messages:
    2,070
    Gender:
    Male
    59.4 Miles, 56.67° NE Of Moab
    Vehicle:
    99 XCAB V6 MT TRD
    Dirty Pool rear bumper/air tank with integrated spare CV shaft storage, DP customized TJM front bumper, 8000 lb Ramsey/Technora rope, E-locked, Extended breathers with front diff catch can, PCV catch can, SAWs with DP heim joint seals, DP custom 6 leaf rear springs/Billies, DP custom skids, 2lo, Gray wire, Cap, Bed Rug, Black steelies, 01 Center console, Map lights, Disraeli gears
    Clean yes, just don't replace the the water pump cause that ain't it.
     

Products Discussed in

To Top