1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cranks but won’t fire

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Ole one pice, Sep 9, 2020.

  1. Sep 9, 2020 at 5:02 AM
    #1
    Ole one pice

    Ole one pice [OP] Ky Cook

    Joined:
    Nov 14, 2017
    Member:
    #235966
    Messages:
    33
    Gender:
    Male
    First Name:
    Sheldon
    Kentucky
    Vehicle:
    2nd gen tacoma
    Custom front bumper Custom spare tire mount Custom skid plate Custom roof rack Custom spare tire an jerry can mount
    I just put a new head gasket on and timing chain both or verified correct I’ve got 55 psi on the fuel rail before the regulator I’ve got spark I’ve got compression all my injectors are pumping but it will not fire just cranks if I spray starting fluid in the intake it fires right up and will run for a second any suggestions also it’s not pulling any codes
     
  2. Sep 9, 2020 at 5:51 AM
    #2
    gearcruncher

    gearcruncher Well-Known Member

    Joined:
    Nov 1, 2012
    Member:
    #90305
    Messages:
    5,330
    Gender:
    Male
    First Name:
    Canadain bumper technician
    Great white North 51.0333° N, 93.8333° W
    Vehicle:
    2010.TRD.SportDCLB4x4Limited leather package
    TRD Sport Rally -5 speed automatic Limited ,Factory heated leather seats ,chrome package,Super white with front windows tinted to 35 % Dick Cepek DC-2 wheels Summer tires - Good year silent armor P265/65R17 Winter tires - Good year P265/65R17 Ultra Ice studded Illuminated 4x4 switch TRD 3rd brake light cover ($20) TRD seat belt shoulder protectors (5). ($50) TRD ...B pillar emblems ($20) TRD rear slider sticker with devil horns ( $6) TRD summer floor matts ($60) TRD steering wheel emblem ($20) TRD floor pedals .($95) TRD shorty antenna ($14) TRD front Windshield emblems ($17) TRD head pillows .($60) TRD head rest protectors TRD door scuff protection $20 TRD floor matt emblems ($40) TRD tow plug emblem . ($40) TRD cigarette lighter with LED.($35) TRD tissue dispenser ($12) TRD front bezel emblems ($9) TRD door emblems ($6) TRD lanyards($9) TRD lisence plates with TRD bolts($50) TRD fender emblems TRD center caps Part Number:PT904-35070-CC ($80) TRD cd
    If you cleaned the throttle body , you may want to do an idle re-learn if you havnt done this yet . Pop your battery cables off for a couple minutes and then re-connect , then try starting the truck .
    Its common when servicing the intake system .
     
    wilcam47 likes this.
  3. Sep 9, 2020 at 6:05 AM
    #3
    Ole one pice

    Ole one pice [OP] Ky Cook

    Joined:
    Nov 14, 2017
    Member:
    #235966
    Messages:
    33
    Gender:
    Male
    First Name:
    Sheldon
    Kentucky
    Vehicle:
    2nd gen tacoma
    Custom front bumper Custom spare tire mount Custom skid plate Custom roof rack Custom spare tire an jerry can mount
    I tried that with no success I feel like it’s got to be something simple like that though because everything is working as it should
     
  4. Sep 9, 2020 at 7:05 AM
    #4
    gearcruncher

    gearcruncher Well-Known Member

    Joined:
    Nov 1, 2012
    Member:
    #90305
    Messages:
    5,330
    Gender:
    Male
    First Name:
    Canadain bumper technician
    Great white North 51.0333° N, 93.8333° W
    Vehicle:
    2010.TRD.SportDCLB4x4Limited leather package
    TRD Sport Rally -5 speed automatic Limited ,Factory heated leather seats ,chrome package,Super white with front windows tinted to 35 % Dick Cepek DC-2 wheels Summer tires - Good year silent armor P265/65R17 Winter tires - Good year P265/65R17 Ultra Ice studded Illuminated 4x4 switch TRD 3rd brake light cover ($20) TRD seat belt shoulder protectors (5). ($50) TRD ...B pillar emblems ($20) TRD rear slider sticker with devil horns ( $6) TRD summer floor matts ($60) TRD steering wheel emblem ($20) TRD floor pedals .($95) TRD shorty antenna ($14) TRD front Windshield emblems ($17) TRD head pillows .($60) TRD head rest protectors TRD door scuff protection $20 TRD floor matt emblems ($40) TRD tow plug emblem . ($40) TRD cigarette lighter with LED.($35) TRD tissue dispenser ($12) TRD front bezel emblems ($9) TRD door emblems ($6) TRD lanyards($9) TRD lisence plates with TRD bolts($50) TRD fender emblems TRD center caps Part Number:PT904-35070-CC ($80) TRD cd
    Does your scanner have the ability of watching parameters when you crank the engine over ?
    Go over all the values of your sensors to verify they are all working
    Do you have a value for your crank position sensor when the engine is cranking ?
    If a value is stuck on 1 number or blank , you may not be getting a value . All sensors plugged in ?
    I believe the truck may have to run for a couple minutes to get some codes .
     
    Ole one pice [OP] likes this.
  5. Sep 9, 2020 at 10:09 AM
    #5
    Ole one pice

    Ole one pice [OP] Ky Cook

    Joined:
    Nov 14, 2017
    Member:
    #235966
    Messages:
    33
    Gender:
    Male
    First Name:
    Sheldon
    Kentucky
    Vehicle:
    2nd gen tacoma
    Custom front bumper Custom spare tire mount Custom skid plate Custom roof rack Custom spare tire an jerry can mount
    I will have to see about that it’s not the greatest scanner and yeah I just triple checked connections and sensors
     
  6. Sep 9, 2020 at 10:13 AM
    #6
    tirediron

    tirediron Well-Known Member

    Joined:
    Jan 19, 2019
    Member:
    #279864
    Messages:
    432
    First Name:
    John
    Vehicle:
    2018 4x4 Sport, Auto, BBP
    Sounds like a fuel issue. Crank it for a bit and pull a plug. It it’s dry, you gots fuel issues. Since you’ve got pressure at the regulator, you have a fairly limited area to look. Injectors?
     
    SR-71A and Ole one pice [OP] like this.
  7. Sep 9, 2020 at 10:26 AM
    #7
    b_r_o

    b_r_o I always have coffee when I watch radar

    Joined:
    Nov 17, 2016
    Member:
    #202672
    Messages:
    7,010
    First Name:
    Alex
    WA
    Vehicle:
    2015 DCLB
    If it runs for a second on starting fluid and you've got fuel pressure you can pretty much rule out compression and spark

    What do you mean by "the injectors are pumping"? Did you get a noid light on one of them?

    Could an alarm issue prevent injectors from firing?
     
    RedWings44 and TnShooter like this.
  8. Sep 9, 2020 at 1:58 PM
    #8
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    11,113
    Gender:
    Male
    SC
    Vehicle:
    2012 Prerunner SR5
    If it runs on starting fluid but not when cranking and it has pressure at the rail, the injectors are not being pulsed.
    Possibly the crank position sensor.
     
  9. Sep 9, 2020 at 8:04 PM
    #9
    Ole one pice

    Ole one pice [OP] Ky Cook

    Joined:
    Nov 14, 2017
    Member:
    #235966
    Messages:
    33
    Gender:
    Male
    First Name:
    Sheldon
    Kentucky
    Vehicle:
    2nd gen tacoma
    Custom front bumper Custom spare tire mount Custom skid plate Custom roof rack Custom spare tire an jerry can mount
    I did t not have a mood light but I used a stethoscope and had someone crank while I listened to them take each one of them was pumping supposedly and I put a new crank position sensor and cam position sensor in thought they were Faulty so I exchanged them and but another set in I did a pressure test and it was running almost 60 psi before the regulator I’ve got a new one coming in the morning figured it may be clogged somehow
     
  10. Sep 9, 2020 at 8:05 PM
    #10
    Ole one pice

    Ole one pice [OP] Ky Cook

    Joined:
    Nov 14, 2017
    Member:
    #235966
    Messages:
    33
    Gender:
    Male
    First Name:
    Sheldon
    Kentucky
    Vehicle:
    2nd gen tacoma
    Custom front bumper Custom spare tire mount Custom skid plate Custom roof rack Custom spare tire an jerry can mount
    Also has all new plugs but I pulled them they were not soaked but had been fired on from using starter fluid
     
  11. Sep 9, 2020 at 8:06 PM
    #11
    Bishop84

    Bishop84 Well-Known Member

    Joined:
    Dec 17, 2015
    Member:
    #172494
    Messages:
    4,152
    Gender:
    Male
    Check grounds on the back of the head, on the p/s pump, under the battery etc.
     
    TnShooter and b_r_o like this.
  12. Sep 9, 2020 at 8:24 PM
    #12
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    11,113
    Gender:
    Male
    SC
    Vehicle:
    2012 Prerunner SR5

    Sounds like you were dead heading the pump at 60 psig. It should only read about 41 psig. Where did you tap into the fuel line?

    [​IMG]

    Measure the fuel pressure.
    Standard:
    281 to 287 kPa (2.87 to 2.93 kgf/cm2, 40.8 to 41.7 psi)

    • If the fuel pressure is greater than the standard value, replace the fuel pump.
    • If the fuel pressure is less than the standard value, check the connection between the fuel hose and fuel pump.

    Turn off Fuel Pump.
    (p) Check that the fuel pressure does not change for 5 minutes.
    Standard:

    147 kPa (1.5 kgf/cm2, 21 psi)
    If the result is not as specified, check the fuel pump and fuel injectors.
     
    SR-71A and po35042 like this.
  13. Sep 10, 2020 at 5:58 PM
    #13
    Ole one pice

    Ole one pice [OP] Ky Cook

    Joined:
    Nov 14, 2017
    Member:
    #235966
    Messages:
    33
    Gender:
    Male
    First Name:
    Sheldon
    Kentucky
    Vehicle:
    2nd gen tacoma
    Custom front bumper Custom spare tire mount Custom skid plate Custom roof rack Custom spare tire an jerry can mount
    I just tested All the injectors with a Noyd light and they are all firing I did the fuel pressure test where the if you’re in line meets the metal hose that goes to the regulator I’ve got a new crank and cam position sensor I have double checked the connection of the grounds on the back of the head and still nothingI just bought a new fuel pressure regulator from Toyota if I install it I can’t return it and it was 100 bucks think that could be the issue?
     
  14. Sep 10, 2020 at 6:19 PM
    #14
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    2,707
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    If the injectors are for sure firing, and it runs on starting fluid, then I’m going to suspect some type of timing issue?

    You can have fuel, air, spark, and compression, but if it’s not timed right. It won’t do much.

    I know you say that you have fuel and spark.

    Is there a check engine light?
    I’d look at the crank / cam correlation?

    I’d be 100% certain, before I start throwing more parts at it.
     
    SR-71A, maxtherat and po35042 like this.
  15. Sep 10, 2020 at 6:46 PM
    #15
    Bishop84

    Bishop84 Well-Known Member

    Joined:
    Dec 17, 2015
    Member:
    #172494
    Messages:
    4,152
    Gender:
    Male
    Agree, its not a parts failure, its a reassembly issue.

    Timing is the big suspect.
     
    maxtherat, 420taco and TnShooter like this.
  16. Sep 10, 2020 at 7:20 PM
    #16
    Ole one pice

    Ole one pice [OP] Ky Cook

    Joined:
    Nov 14, 2017
    Member:
    #235966
    Messages:
    33
    Gender:
    Male
    First Name:
    Sheldon
    Kentucky
    Vehicle:
    2nd gen tacoma
    Custom front bumper Custom spare tire mount Custom skid plate Custom roof rack Custom spare tire an jerry can mount
    I pulled the valve cover back off chat top dead center did another full revolution and it was The exact opposite I put my cans back in the same way they came out wind up my marks on the timing chain and had it set at top dead center when I reinstalled it I was so careful this is the first time I’ve ever been this far in an engine I was very thorough not to say I couldn’t of fucked something upBut I really don’t think it’s the timing
     
  17. Sep 10, 2020 at 7:22 PM
    #17
    Ole one pice

    Ole one pice [OP] Ky Cook

    Joined:
    Nov 14, 2017
    Member:
    #235966
    Messages:
    33
    Gender:
    Male
    First Name:
    Sheldon
    Kentucky
    Vehicle:
    2nd gen tacoma
    Custom front bumper Custom spare tire mount Custom skid plate Custom roof rack Custom spare tire an jerry can mount
    I pulled my plugs and they have gas on them
     
  18. Sep 10, 2020 at 7:25 PM
    #18
    Ole one pice

    Ole one pice [OP] Ky Cook

    Joined:
    Nov 14, 2017
    Member:
    #235966
    Messages:
    33
    Gender:
    Male
    First Name:
    Sheldon
    Kentucky
    Vehicle:
    2nd gen tacoma
    Custom front bumper Custom spare tire mount Custom skid plate Custom roof rack Custom spare tire an jerry can mount
    I made it run for about 30 seconds just now by spraying starter fluid in and it sounded pretty good
     
  19. Sep 10, 2020 at 7:29 PM
    #19
    CurtB

    CurtB Well-Known Member

    Joined:
    Dec 30, 2014
    Member:
    #145266
    Messages:
    4,907
    Gender:
    Male
    First Name:
    Curt
    Kansas
    Vehicle:
    2010 Tacoma SR5
    Doesn't that scream 'not getting fuel'? But the plugs are wet. :notsure:
     
    Ole one pice [OP] likes this.
  20. Sep 10, 2020 at 7:30 PM
    #20
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    11,113
    Gender:
    Male
    SC
    Vehicle:
    2012 Prerunner SR5
    If it starts with starting fluid it has spark and compression. That being said it should start with gasoline. Just saying.

    You do realize that the fuel regulator is at the end of the fuel rail and if you have fuel pressure which should be ~ 41PSIG if teed into the fuel line as per the service manual above.

    The biggest question I have is the gasoline supply? The starting fluid confirms the spark.

    Does it even attempt to fire when starting without starting fluid?
     
    RedWings44 and Ole one pice [OP] like this.

Products Discussed in

To Top