1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cruise Control doesnt work

Discussion in 'Technical Chat' started by s2kvtak, Jan 4, 2010.

  1. Jan 4, 2010 at 3:49 PM
    #1
    s2kvtak

    s2kvtak [OP] Well-Known Member

    Joined:
    Aug 3, 2009
    Member:
    #20598
    Messages:
    310
    Gender:
    Male
    First Name:
    Lee
    Tulsa, OK
    Vehicle:
    2004 Tacoma 4x4 SR5
    Grillecraft grill w/ TRD badge, Bilstein 5100s on all 4 corners set at 2.5" and Toytec AAL in the rear. 285/75-17 Interco TRXUS M/T
    well suddenly the cruise control on my truck just stopped working. i can turn it on and the dash light comes on, but it wont "set". i have a haynes manual and have tried to research online but cant seem to come up with any answers. the manual says that there is a motor and a cable attaching to the trottle body. at the front of the throttle body is the throttle cable but nothin else. any and all help is appreciated!!!
     
  2. Jan 4, 2010 at 3:53 PM
    #2
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    A little more info about your truck would be cool- Like year and mileage.
     
  3. Jan 4, 2010 at 3:55 PM
    #3
    toyotadude5

    toyotadude5 Breazeale- Pronounced Brazil

    Joined:
    Oct 23, 2009
    Member:
    #24812
    Messages:
    1,991
    Gender:
    Male
    First Name:
    chris
    Flagstaff, az
    Vehicle:
    2006 Subaru wrx sti (white)
    subscribed. my dad has an 01 taco and he said his cruise light comes on but does not work, Id like to see if anyone has a fix
     
  4. Jan 4, 2010 at 4:32 PM
    #4
    ccs368

    ccs368 Well-Known Member

    Joined:
    Nov 21, 2008
    Member:
    #10931
    Messages:
    46
    Gender:
    Male
    MA
    Vehicle:
    05 Access Cab SR5 4x4
    In my experience, there's a switch almost like a theaded plunger that can be adjusted in and out to make full contact with the actual clutch pedal. I'm assuming you have a manual transmission too. If it's just out of contact where upon full clutch pedal return and the switch is not engaged, you will not be able to "set". Check it out underneath.
     
    wilcam47 likes this.
  5. Jan 4, 2010 at 7:12 PM
    #5
    s2kvtak

    s2kvtak [OP] Well-Known Member

    Joined:
    Aug 3, 2009
    Member:
    #20598
    Messages:
    310
    Gender:
    Male
    First Name:
    Lee
    Tulsa, OK
    Vehicle:
    2004 Tacoma 4x4 SR5
    Grillecraft grill w/ TRD badge, Bilstein 5100s on all 4 corners set at 2.5" and Toytec AAL in the rear. 285/75-17 Interco TRXUS M/T
    damn....im sorry guys i was on my way out the door when i wrote this earlier. its an 04 xtra cab V6 auto SR5 4X4
     
  6. Jan 5, 2010 at 2:11 PM
    #6
    s2kvtak

    s2kvtak [OP] Well-Known Member

    Joined:
    Aug 3, 2009
    Member:
    #20598
    Messages:
    310
    Gender:
    Male
    First Name:
    Lee
    Tulsa, OK
    Vehicle:
    2004 Tacoma 4x4 SR5
    Grillecraft grill w/ TRD badge, Bilstein 5100s on all 4 corners set at 2.5" and Toytec AAL in the rear. 285/75-17 Interco TRXUS M/T
    bump for some help
     
  7. Jan 5, 2010 at 2:14 PM
    #7
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,769
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    check the brake light switch and its adjustment first
     
  8. Jan 5, 2010 at 2:24 PM
    #8
    s2kvtak

    s2kvtak [OP] Well-Known Member

    Joined:
    Aug 3, 2009
    Member:
    #20598
    Messages:
    310
    Gender:
    Male
    First Name:
    Lee
    Tulsa, OK
    Vehicle:
    2004 Tacoma 4x4 SR5
    Grillecraft grill w/ TRD badge, Bilstein 5100s on all 4 corners set at 2.5" and Toytec AAL in the rear. 285/75-17 Interco TRXUS M/T
    would this be inside the cab? little descriptions are nice
     
  9. Jan 5, 2010 at 2:26 PM
    #9
    s2kvtak

    s2kvtak [OP] Well-Known Member

    Joined:
    Aug 3, 2009
    Member:
    #20598
    Messages:
    310
    Gender:
    Male
    First Name:
    Lee
    Tulsa, OK
    Vehicle:
    2004 Tacoma 4x4 SR5
    Grillecraft grill w/ TRD badge, Bilstein 5100s on all 4 corners set at 2.5" and Toytec AAL in the rear. 285/75-17 Interco TRXUS M/T
    also how does it adjust?
     
  10. Jan 5, 2010 at 4:36 PM
    #10
    kevhogaz

    kevhogaz Low Speed, High Drag

    Joined:
    Sep 6, 2008
    Member:
    #9055
    Messages:
    323
    Gender:
    Male
    Queen Creek, Arizona
    Vehicle:
    SR5 PreRunner
    3" lift front & rear, Air Raid Intake System
    The brake light switch is under the dash, on the brake pedal. It's a threaded adjuster. 99% of the time, the little rubber stopper is worn out, on the brake pedal itself.

    I'm assuming you checked fuses, haven't recently had the intake off, and made sure everything is plugged in, right? It's probably something simple, as Toyota cruise systems rarely, if ever fail.
     
  11. Jan 6, 2010 at 2:48 PM
    #11
    s2kvtak

    s2kvtak [OP] Well-Known Member

    Joined:
    Aug 3, 2009
    Member:
    #20598
    Messages:
    310
    Gender:
    Male
    First Name:
    Lee
    Tulsa, OK
    Vehicle:
    2004 Tacoma 4x4 SR5
    Grillecraft grill w/ TRD badge, Bilstein 5100s on all 4 corners set at 2.5" and Toytec AAL in the rear. 285/75-17 Interco TRXUS M/T
    well i got under there and saw the treaded adjuster and it has a little plastic button coming off of the end that when the brake pedal was at "rest" the button was depressed and with the pedal pushed it was out. is this the correct adjuster or is there one im missing. it was kinda dark when i looked.

    i havent had the intake off but i did just recently clean my k&n filter. im not sure how this would have anything to do with the CC but i have done it.

    as far as fuses go i couldnt find one the was labeled cruise, but im assuming the fuse is fine since i get the dash light to come on. it just wont set at a speed.

    one thing i though of last night was the speed sensor. anyone know where that is? i did go play in the snow we got so maybe it could have come unplugged or something?? just an idea
     
  12. Jan 6, 2010 at 4:21 PM
    #12
    kevhogaz

    kevhogaz Low Speed, High Drag

    Joined:
    Sep 6, 2008
    Member:
    #9055
    Messages:
    323
    Gender:
    Male
    Queen Creek, Arizona
    Vehicle:
    SR5 PreRunner
    3" lift front & rear, Air Raid Intake System
    Here's what I found, on the basic operation of the CC system. It's extremely hard to diagnose the problem, over the internet. Check all these systems/operations first.

    AUTO CANCEL OPERATION
    If any of the following conditions are detected, the set speed is erased and the control is canceled.

    1. Disconnection and/or short in the stop light SW
    2. Malfunction in the vehicle speed signal
    3. Malfunction in the electronic throttle parts
    4. Malfunction in the stop light SW input circuit
    5. Malfunction in the cancel circuit
    6. The actual vehicle speed becomes slower than the minimum speed limit
    7. The actual vehicle speed becomes -16 km/h (10 mph) slower than the set speed
     
  13. Jan 7, 2010 at 3:52 PM
    #13
    s2kvtak

    s2kvtak [OP] Well-Known Member

    Joined:
    Aug 3, 2009
    Member:
    #20598
    Messages:
    310
    Gender:
    Male
    First Name:
    Lee
    Tulsa, OK
    Vehicle:
    2004 Tacoma 4x4 SR5
    Grillecraft grill w/ TRD badge, Bilstein 5100s on all 4 corners set at 2.5" and Toytec AAL in the rear. 285/75-17 Interco TRXUS M/T
    okay well the latest update is that i found that the cruise control system will work properly if the headlights are off. it sets and maintains speed and as soon as i flip them on, even the parking lights, it cancels. im lost...i know its probably a short, but how and where
     
  14. Jan 7, 2010 at 4:16 PM
    #14
    kevhogaz

    kevhogaz Low Speed, High Drag

    Joined:
    Sep 6, 2008
    Member:
    #9055
    Messages:
    323
    Gender:
    Male
    Queen Creek, Arizona
    Vehicle:
    SR5 PreRunner
    3" lift front & rear, Air Raid Intake System
    Holy moly, man, you got yourself in to a jam now!

    I'd look at the cruise switch, itself. The one in the steering wheel. I'd test it, and go from there. Unless you pinched a wire at some time, I'd start with the easy stuff, start.
     
  15. Jan 10, 2010 at 6:39 AM
    #15
    Twisted99

    Twisted99 Active Member

    Joined:
    Jan 10, 2010
    Member:
    #29071
    Messages:
    41
    Gender:
    Male
    I also have this problem. 01 Double cab 4x4 auto.
     
  16. Jan 19, 2016 at 7:39 AM
    #16
    neatoneto

    neatoneto Well-Known Member

    Joined:
    Jan 2, 2016
    Member:
    #173760
    Messages:
    71
    First Name:
    Neto
    Vehicle:
    04 Tacoma 4x4 Ext. Cab
    Same boat with an 04 extra cab manual 4x4
     
  17. Feb 8, 2016 at 12:04 PM
    #17
    wilcam47

    wilcam47 Well-Known Member

    Joined:
    Jan 27, 2016
    Member:
    #176243
    Messages:
    2,270
    Gender:
    Male
    North Idaho
    Vehicle:
    2000 Toyota Tacoma
    4 inch lift
    This is what was initially wrong with mine and later it turned out to be the cable that engages the CC came off the bracket. I repositioned the cable to the right spot and tightened it up CC works on mine now.
     
  18. Feb 8, 2016 at 12:09 PM
    #18
    whopper

    whopper 2016 MGM 4x4 double cab

    Joined:
    Jun 18, 2011
    Member:
    #58464
    Messages:
    1,247
    Gender:
    Male
    First Name:
    wayne
    north carolina
    Vehicle:
    2016 tacoma double cab 4x4 MGM
    On going
    Clock spring
     
To Top