1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cruise Control erratic '99 Prerunner

Discussion in '1st Gen. Tacomas' started by us271934, May 30, 2008.

  1. May 30, 2008 at 7:41 PM
    #1
    us271934

    us271934 [OP] New Member

    Joined:
    May 14, 2008
    Member:
    #6630
    Messages:
    2
    Austin, Texas
    Vehicle:
    99 Prerunner V6 Auto
    The cruise will continuously accelerate then decelerate after you set it. The rate of change isn't large but it is just like someone that pumps the gas while driving because they can't seem to hold a steady speed - yes, my wife once did this :)
    The full range of speed is probably around 5 mph.
    I hate to have the dealer charge me $100 to say "this vacuum hose was leaking" plus have my taco at the shop all day.
    Anyone have a similar issue and a solution?
     
  2. May 30, 2008 at 8:20 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Thor

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,843
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Are all your vacuume lines free of cracks? You may want to check the linkage going to the throttle body from the cruise control.
     
  3. Jun 5, 2008 at 6:27 PM
    #3
    TheOriginalTXTACO

    TheOriginalTXTACO Active Member

    Joined:
    Jun 2, 2008
    Member:
    #7061
    Messages:
    37
    Gender:
    Male
    San Antonio, TX
    Vehicle:
    Unfortunately No More
    3" lift, Extreme LineX, Extang Toolbox Tonnoe, UWS Box, MB Wheels, BFG AT's.
    My 02 has always worked like crap, same for my 96. I just don't use it unles I'm hauling ass at 80+, then it works fine.
     
  4. Jun 5, 2008 at 9:27 PM
    #4
    747

    747 function > form

    Joined:
    Jan 27, 2008
    Member:
    #4465
    Messages:
    3,027
    Gender:
    Male
    Vehicle:
    1st Gen.
    Same issue here...though inconsistent. Is it an aftermarket control?
     
  5. Jun 6, 2008 at 6:05 AM
    #5
    TheOriginalTXTACO

    TheOriginalTXTACO Active Member

    Joined:
    Jun 2, 2008
    Member:
    #7061
    Messages:
    37
    Gender:
    Male
    San Antonio, TX
    Vehicle:
    Unfortunately No More
    3" lift, Extreme LineX, Extang Toolbox Tonnoe, UWS Box, MB Wheels, BFG AT's.
    Both stock, when it hits a slight hill it surges the gas and up's the rpm, then it abruptely backs off again when back on the flat. I wonder since I lifted both trucks and put larger tires on if this didn't help cause it to be less effective.
     
  6. Jun 6, 2008 at 6:11 AM
    #6
    Charli

    Charli Stealer of Souls

    Joined:
    Nov 21, 2007
    Member:
    #3541
    Messages:
    3,287
    Gender:
    Female
    First Name:
    Chuck?
    Ohio
    Vehicle:
    '06 Black Sand 4X4 SR5 TRD Sport V6 Access Ca
    Towing pkg with Mossberg hitch cover, Toyota tube steps, 3" Toytec lift and TSB, 1" diff drop, Tacoma World sticker, sockmonkey decals
    That actually sounds normal? Mine does that on hills because it's trying to maintain the speed its set at and the hill presents a problem with maintaining that--it'll brake going down hills too in order to stay at the preset speed. Although if its over-doing the rpms that could be a problem. I find cruise control a bit freaky in general. But then I'm a control freak... :)
     
  7. Jun 6, 2008 at 9:49 AM
    #7
    TheOriginalTXTACO

    TheOriginalTXTACO Active Member

    Joined:
    Jun 2, 2008
    Member:
    #7061
    Messages:
    37
    Gender:
    Male
    San Antonio, TX
    Vehicle:
    Unfortunately No More
    3" lift, Extreme LineX, Extang Toolbox Tonnoe, UWS Box, MB Wheels, BFG AT's.
    I just don't use it anymore, after riding my wife's acura which handles perfectly with the cruise control I can't stand the flucuation with mine.
     
To Top