1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cruise Control Install

Discussion in '1st Gen. Tacomas' started by prairie_bluejay, Jun 26, 2007.

  1. Jun 26, 2007 at 6:48 AM
    #1
    prairie_bluejay

    prairie_bluejay [OP] New Member

    Joined:
    Jun 26, 2007
    Member:
    #1916
    Messages:
    2
    Hello,

    I am just buying my Tacoma today, and I love it and think I got a good deal on it, it's in great shape for the year/miles, and I'm excited to start really driving it.

    But my question is this... I do a lot of highway driving, and I'd like to install Cruise Control. Does anyone have any advice/good sources for the parts? My mechanic said it's been a while since he's installed one, but I know we could do it, I just wanted to see if anyone has experience/suggestions for me.

    Thanks!

    -Colin
     
  2. Jul 3, 2007 at 2:34 PM
    #2
    Dave

    Dave Well-Known Member

    Joined:
    Sep 9, 2006
    Member:
    #3
    Messages:
    143
    Gender:
    Male
    RI/Vt
    Vehicle:
    08 4x4 Xtra Cab
    Audiovox used to make a decent add on cruise for the Tacomas.
     
  3. Sep 3, 2007 at 4:12 PM
    #3
    krlang

    krlang NewEnglander

    Joined:
    Sep 3, 2007
    Member:
    #2592
    Messages:
    132
    Gender:
    Male
    Commonwealth of Massachusetts
    Vehicle:
    03 2WD 2.4L Tacoma Reg Cab
    Chrome Bumpers F&R, Grille & Corner Lights, Wheel Skins, Red/Clear LED taillights, Remote start, PDL, Cruise, K&N, All Kenwood, DNX-5120 6.1" NAV/TRAFFIC/DTV/DVD/XM/BLUETOOTH/USB/IPOD/SUB/rear cam, Tint, Air Band radio, Class 3 Hitch with 4/7 pin harness, Transmission Cooler, Red Top Battery, "Deck Plate" mod.
    I am in the process of installing the Rostra Global Cruise into my 03 2.4L tacoma. I have it mounted, wired and the light comes on.
    But it still doesnt work, they are closed today due to the Holiday, I will call them tomorrow.
    The VSS and the Tach wire are the culprit, I think. The directions are a little vague. I found the correct color wires in the right area but the signal is not getting to the computer.

    I will post the info when it works, K.L.
     
  4. Sep 9, 2007 at 2:27 AM
    #4
    ken peterson

    ken peterson New Member

    Joined:
    Sep 9, 2007
    Member:
    #2641
    Messages:
    1
    Vehicle:
    plain jane 4wd
    Hi Jay I found a factory cruise package online, it's been over a year so I don't know the site, think it was a dealer in texas. Found installation instructions at toyota home site, took some time and a lot of mouse clicking but it was there. Kit came with brake switch, clutch switch, harness, everything. It plugs into your oem harness, everything is now factory. Think it was about $350.00. No fabrication everything just plugs or bolts to existing brackets, oh sorry, you do have to drill a hole in steering column plastic for switch. Hope this helps.
     
  5. Sep 9, 2007 at 3:22 AM
    #5
    krlang

    krlang NewEnglander

    Joined:
    Sep 3, 2007
    Member:
    #2592
    Messages:
    132
    Gender:
    Male
    Commonwealth of Massachusetts
    Vehicle:
    03 2WD 2.4L Tacoma Reg Cab
    Chrome Bumpers F&R, Grille & Corner Lights, Wheel Skins, Red/Clear LED taillights, Remote start, PDL, Cruise, K&N, All Kenwood, DNX-5120 6.1" NAV/TRAFFIC/DTV/DVD/XM/BLUETOOTH/USB/IPOD/SUB/rear cam, Tint, Air Band radio, Class 3 Hitch with 4/7 pin harness, Transmission Cooler, Red Top Battery, "Deck Plate" mod.
    A week later and I still dont have cruise.
    I have tried three different places to pick up the VSS wire.
    Two calls to tech support have not helped, and by the time I needed them again they had gone home for the weekend.

    More info to come!
     
  6. Sep 15, 2007 at 4:09 AM
    #6
    krlang

    krlang NewEnglander

    Joined:
    Sep 3, 2007
    Member:
    #2592
    Messages:
    132
    Gender:
    Male
    Commonwealth of Massachusetts
    Vehicle:
    03 2WD 2.4L Tacoma Reg Cab
    Chrome Bumpers F&R, Grille & Corner Lights, Wheel Skins, Red/Clear LED taillights, Remote start, PDL, Cruise, K&N, All Kenwood, DNX-5120 6.1" NAV/TRAFFIC/DTV/DVD/XM/BLUETOOTH/USB/IPOD/SUB/rear cam, Tint, Air Band radio, Class 3 Hitch with 4/7 pin harness, Transmission Cooler, Red Top Battery, "Deck Plate" mod.
    Details, Details, Details!

    I have been troubleshooting a problem with the tech rep all week and I found it last night. I was looking at the wires on the ECM and what looked to be the green/orange wire was actually red. Next to that wire is a green/yellow looking wire that was the one I was looking for, although they called it green/orange. The cruise worked on the way home today, it captured and held like a champ, I accellerated and coasted but that was as much as I could do, traffic was brutal on a friday evening here in Massachusetts.

    Alright, this afternoon when the rain is gone I will reassemble everything that I have had apart, I will also shoot a few pictures of the really simple installation of this thing. Simple, but I blew it on the VSS wire!

    K.L.
    [​IMG]
    [​IMG]
    [​IMG]
     
  7. Sep 19, 2007 at 4:27 PM
    #7
    krlang

    krlang NewEnglander

    Joined:
    Sep 3, 2007
    Member:
    #2592
    Messages:
    132
    Gender:
    Male
    Commonwealth of Massachusetts
    Vehicle:
    03 2WD 2.4L Tacoma Reg Cab
    Chrome Bumpers F&R, Grille & Corner Lights, Wheel Skins, Red/Clear LED taillights, Remote start, PDL, Cruise, K&N, All Kenwood, DNX-5120 6.1" NAV/TRAFFIC/DTV/DVD/XM/BLUETOOTH/USB/IPOD/SUB/rear cam, Tint, Air Band radio, Class 3 Hitch with 4/7 pin harness, Transmission Cooler, Red Top Battery, "Deck Plate" mod.
    I found an even more interesting thing to do with the cruise today.

    When I installed the kit, one of the wires in the harness was for an external light to show when the cruise control was activated. I noticed that the legend was there in the left side of the dash, but it did not test when starting. I looked up the wiring diagram on Auto Zones website and I figured the cruise wiring would be similar in the 1996 diagrams that they had.

    I went to the RH kick panel where I figured the black/yellow wire would be. It was there in the connector that the cruise computer would be if I had factory cruise. I also went looking for the Black/orange wire which is the power feed to the dash lights, it was connected to a relay in the fwd fuse box. I grounded the wire in the kick panel and the green cruise light illuminated. I then ran a wire between that wire and the light output for the cruise computer and took it for a ride.
    So now I turn on the sruise and the LED on the control comes on, Then when I set the cruise i get the green light in the dash.

    WOOHOO! Stupid things like that amuse me!:)
     
  8. Sep 19, 2007 at 5:43 PM
    #8
    rhoppas

    rhoppas Land of Oz

    Joined:
    Aug 29, 2007
    Member:
    #2564
    Messages:
    1,309
    Gender:
    Male
    Topeka, KS
    Vehicle:
    07 Double Cab V6 TRD Sport Tow
    Earnhardt Cannons, Terra Grapplers, Viper alarm, Hunter4x4 Bull Bar, 6" Pro Comp Off-Road lights, extra set of bed D-rings, Chrome exhaust tip, Metra Ipod/MP3 adapter, Garmin GPS, CarriageWorks grill, Maglite mounted to driver seat, 9" Stubbie Antenna, WeatherTech floor liners, Saddleman Neoprene seat covers, DeeZee bed mat
    Good job! I would be pumped too if I accomplished installing my own cruise control...
     
  9. Sep 24, 2007 at 7:56 PM
    #9
    350TacoZilla

    350TacoZilla Well-Known Member

    Joined:
    Sep 22, 2007
    Member:
    #2767
    Messages:
    1,106
    Clear Spring MD
    2.7L 3RZ,K&N filter, 4" deck plate mod,flowmaster 40 series,3" body lift,3" suspension lift,35's. I also have another tacoma a 97 with a 350 small block in it on a 1972 blazer frame...
    what wsa the price for that rostra kit? looks sweet btw good job on it...i want....lol
     
  10. Sep 25, 2007 at 4:23 AM
    #10
    007Tacoma

    007Tacoma I dub thee malicious!

    Joined:
    Jan 4, 2007
    Member:
    #643
    Messages:
    6,705
    Gender:
    Male
    First Name:
    Mark
    San Antonio, TX
    Vehicle:
    2003 4Runner SE 4WD
    That's not stupid. That's awesome! I would be stoked! :D
     
  11. Sep 25, 2007 at 8:02 AM
    #11
    krlang

    krlang NewEnglander

    Joined:
    Sep 3, 2007
    Member:
    #2592
    Messages:
    132
    Gender:
    Male
    Commonwealth of Massachusetts
    Vehicle:
    03 2WD 2.4L Tacoma Reg Cab
    Chrome Bumpers F&R, Grille & Corner Lights, Wheel Skins, Red/Clear LED taillights, Remote start, PDL, Cruise, K&N, All Kenwood, DNX-5120 6.1" NAV/TRAFFIC/DTV/DVD/XM/BLUETOOTH/USB/IPOD/SUB/rear cam, Tint, Air Band radio, Class 3 Hitch with 4/7 pin harness, Transmission Cooler, Red Top Battery, "Deck Plate" mod.
    Thanks,
    Its working great, I took it to Maine last weekend and my foot was really happy. The Rostra kit came from M&R electronics, I got it off of E-bay for $219 with the correct throttle bracket and the control unit shown in the picture. It is a clean install and the tech support at both places were really helpful. (M&R/Rostra)

    K.L.
     
To Top