1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cruise Control isn't working !!!!Help!!!

Discussion in '1st Gen. Tacomas (1995-2004)' started by Gr8WhiteTaco, Nov 20, 2009.

  1. Nov 20, 2009 at 12:13 PM
    #1
    Gr8WhiteTaco

    Gr8WhiteTaco [OP] bishes love my haircut

    Joined:
    Dec 28, 2008
    Member:
    #11964
    Messages:
    2,286
    Gender:
    Male
    First Name:
    Aaron
    Knoxville, TN
    Vehicle:
    SOLD 02 Double Cab TRD 4x4
    2005 Mazda 3S hatchback
    My cruise control isn't working on my truck. The CC light comes on when I turn it on, but it doesn't hold the speed or anything. I checked the fuse blocks to see if its was a blown fuse but couldn't find a slot for CC. Any help at all would be great.
     
  2. Nov 20, 2009 at 12:19 PM
    #2
    Resmondo

    Resmondo Well-Known Member

    Joined:
    Oct 29, 2009
    Member:
    #25136
    Messages:
    64
    Gender:
    Male
    First Name:
    Cody
    Perdido Key, Fl
    Vehicle:
    98 SR5 4X4 purple, lifted, and sexy
    Arb Bull Bar, Trailmaster 6" lift with 16"weld rims wrapped in 36 tls radials, Salt life sticker, spacer lift front, 9-10" total front
    You should have a plastic peice that attaches to your throttle assembly on the motor. And the box for cruise control should be on the passenger side fender well with a cable running to your throttle. I have a 2.7 ltr and thats how it is set up. Not sure on yours though. But had the same problem and when i looked the pin had come out of the plastic peice and was dangling down. Re-attached it and it worked fine. Hope this helps.
     
  3. Nov 20, 2009 at 12:20 PM
    #3
    Gr8WhiteTaco

    Gr8WhiteTaco [OP] bishes love my haircut

    Joined:
    Dec 28, 2008
    Member:
    #11964
    Messages:
    2,286
    Gender:
    Male
    First Name:
    Aaron
    Knoxville, TN
    Vehicle:
    SOLD 02 Double Cab TRD 4x4
    2005 Mazda 3S hatchback
    Ok gonna go check that out. I've got the 3.4 so it might be different but its worth a shot.
     
  4. Nov 20, 2009 at 12:21 PM
    #4
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,769
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    check the brake switch adjustment.
     
  5. Nov 20, 2009 at 12:30 PM
    #5
    Gr8WhiteTaco

    Gr8WhiteTaco [OP] bishes love my haircut

    Joined:
    Dec 28, 2008
    Member:
    #11964
    Messages:
    2,286
    Gender:
    Male
    First Name:
    Aaron
    Knoxville, TN
    Vehicle:
    SOLD 02 Double Cab TRD 4x4
    2005 Mazda 3S hatchback
    Ok just looked at the cruise control box, the cable is attached, wires are plugged so I don't what it would be.
    wheres the brake adj switch jbob?
     
  6. Nov 20, 2009 at 12:37 PM
    #6
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,769
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    your brake switch on your brake pedal.is this automatic or manual truck?
     
  7. Nov 20, 2009 at 12:43 PM
    #7
    Gr8WhiteTaco

    Gr8WhiteTaco [OP] bishes love my haircut

    Joined:
    Dec 28, 2008
    Member:
    #11964
    Messages:
    2,286
    Gender:
    Male
    First Name:
    Aaron
    Knoxville, TN
    Vehicle:
    SOLD 02 Double Cab TRD 4x4
    2005 Mazda 3S hatchback
    its an auto. all the bulbs and turn signals work.
     
  8. Nov 20, 2009 at 12:48 PM
    #8
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,769
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    get down where you can see the brake pedal and the brake switch.notice when you push the pedal how the switch works ,make sure the switch is contacting the brake pedal fully when released.
     
  9. Nov 20, 2009 at 12:55 PM
    #9
    Gr8WhiteTaco

    Gr8WhiteTaco [OP] bishes love my haircut

    Joined:
    Dec 28, 2008
    Member:
    #11964
    Messages:
    2,286
    Gender:
    Male
    First Name:
    Aaron
    Knoxville, TN
    Vehicle:
    SOLD 02 Double Cab TRD 4x4
    2005 Mazda 3S hatchback
    alrighty just checked the brake switch. it touching it but if i push the it doesn't contact it anymore. Which I'm guessing that is what its supposed to do
     
  10. Nov 20, 2009 at 12:55 PM
    #10
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,839
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
  11. Nov 20, 2009 at 12:57 PM
    #11
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,839
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
  12. Nov 20, 2009 at 12:59 PM
    #12
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,769
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    yes ,when the pedal is released you want the switch to be contacting completely,if there is any slack adjust it down.
     
  13. Nov 20, 2009 at 1:03 PM
    #13
    Gr8WhiteTaco

    Gr8WhiteTaco [OP] bishes love my haircut

    Joined:
    Dec 28, 2008
    Member:
    #11964
    Messages:
    2,286
    Gender:
    Male
    First Name:
    Aaron
    Knoxville, TN
    Vehicle:
    SOLD 02 Double Cab TRD 4x4
    2005 Mazda 3S hatchback
    Thank you so much Ben!! I been looking for that stuff!
    Ok so jbob i think i can mark that off the list for possible problems.
     
  14. Nov 20, 2009 at 1:05 PM
    #14
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,839
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
  15. Dec 4, 2009 at 10:04 AM
    #15
    K-K-K-Kommando

    K-K-K-Kommando Active Member

    Joined:
    Oct 29, 2009
    Member:
    #25145
    Messages:
    34
    Gender:
    Male
    Is your caps lock on?
     
  16. Dec 4, 2009 at 10:06 AM
    #16
    Gr8WhiteTaco

    Gr8WhiteTaco [OP] bishes love my haircut

    Joined:
    Dec 28, 2008
    Member:
    #11964
    Messages:
    2,286
    Gender:
    Male
    First Name:
    Aaron
    Knoxville, TN
    Vehicle:
    SOLD 02 Double Cab TRD 4x4
    2005 Mazda 3S hatchback
  17. Mar 29, 2012 at 6:07 PM
    #17
    pou4518

    pou4518 Member

    Joined:
    Feb 16, 2012
    Member:
    #72944
    Messages:
    17
    Gender:
    Male
    Natchez, Ms
    Vehicle:
    2000 Tacoma, extended cab, 4wd, 177K+
    None Yet!!
    Did you ever figure out your issue mine is doing something very similar..
     
To Top