1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cruise control quit working after trailer wire harness installed

Discussion in 'Technical Chat' started by approach, Oct 17, 2011.

  1. Oct 17, 2011 at 10:57 AM
    #1
    approach

    approach [OP] Active Member

    Joined:
    Nov 13, 2009
    Member:
    #25912
    Messages:
    31
    Gender:
    Male
    First Name:
    jason
    oklahoma city
    Vehicle:
    05 tacoma
    I installed a trailer wiring harness yesterday for my trailer and now the cruise control quit working! Has anyone had this problem, and what can I do to fix it?
     
  2. Oct 17, 2011 at 11:02 AM
    #2
    Evil Monkey

    Evil Monkey There's an evil monkey in my truck

    Joined:
    Aug 8, 2007
    Member:
    #2352
    Messages:
    8,383
    Gender:
    Male
    First Name:
    Robert
    Escondido, CA
    Vehicle:
    07 4x4 DC SR5 TRD Off-road
    Weathertech front & rear mats, rear suspension TSB, Toytec AAL for TSB, Hi-Lift Jack, Bilstein 5100 & Toytec Adjustable coilovers, Built Right UCAs, KMC XD 795 Hoss Wheels, Definity Dakota MTs 285/75R16, Leer XR, Thule Tracker II & Thule MOAB basket
    Did it quit when the trailer is plugged in or does it not work at all? Cruise control is deactivated when the brake is applied. Perhaps electronically, it thinks the brakes are on.
     
  3. Oct 17, 2011 at 11:40 AM
    #3
    approach

    approach [OP] Active Member

    Joined:
    Nov 13, 2009
    Member:
    #25912
    Messages:
    31
    Gender:
    Male
    First Name:
    jason
    oklahoma city
    Vehicle:
    05 tacoma
    It dosent work either way! It's a four prong wire harness, it said one wire is to the left turn, one for the right turn, ground and the other to b hooked up to the tag light to run the running lights and this one also is to attach to the brakes! All the light worked on the trailer and truck! I messed up somewhere with that last wire, the truck thinking the brakes are one would make since! The cruise light comes on, it just won't engage!
     
  4. Oct 21, 2011 at 8:28 PM
    #4
    Krusey1011

    Krusey1011 Well-Known Member

    Joined:
    Jul 27, 2009
    Member:
    #20239
    Messages:
    209
    Gender:
    Male
    First Name:
    Kyle
    SW Washington
    Vehicle:
    Taco of Terror!!!
    K&N high performance intake, billet grill, bhlm, T-Rex eyelids, debadged/blacked, behind grill Hella Black Magic's, Fog light anytime, DTLT headers, Interior/Exterior LED's
    That sucks! Mine just came apart one day (right after my warranty expired of course). The little push button just popped out and I can't figure out how to put it back together to make it operate right. Nothing works now, the cruise light wont come on or anything. Laaaame!!! Sorry, I don't know why yours would up and quit on ya though. Unless you have the same issue as me but you were saying it happened as soon as you connected the trailer.
     
  5. Oct 21, 2011 at 8:46 PM
    #5
    joes06tacoma

    joes06tacoma Well-Known Member

    Joined:
    Jan 1, 2010
    Member:
    #28588
    Messages:
    3,066
    Gender:
    Male
    First Name:
    Joe
    Central Coast, CA
    Vehicle:
    06 4x4 Off Road Access Cab v6 6spd
    LEER Shell with dome lights operated with 3 way switches, aux backup lights with relay and 3 position switch, modified wiring to compass/temp display and clock to include switch that disables dimming function (poor man's DRL solution), Scan Gauge 2
    Is it just a wiring harness or did it come with a convertor box? These trucks have separate signals and need a convertor box. One wire for left turn, one for right turn, a ground wire, a brake light wire, and a tail light wire.

    If you hooked the brake and tail both up to the same wire, then I know for sure you can't set your cruise with the headlights on because it will see that as brakes being on too and cancel the cruise. If it does that with the lights off, then I don't understand why that is.

    Put it back to stock and make sure everything works as it did before. If so, you know it's something to do with the trailer wiring.

    http://www.amazon.com/Reese-Towpower-74209-Trailer-Converter/dp/B0008G1NNY

    Should look something like that.
     
  6. Oct 22, 2011 at 8:14 AM
    #6
    approach

    approach [OP] Active Member

    Joined:
    Nov 13, 2009
    Member:
    #25912
    Messages:
    31
    Gender:
    Male
    First Name:
    jason
    oklahoma city
    Vehicle:
    05 tacoma
    thx for the response. i will get that converter and try that out.
     
To Top