1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cruise control racing the engine

Discussion in 'Technical Chat' started by Chomag, Jun 23, 2008.

  1. Jun 23, 2008 at 9:40 PM
    #1
    Chomag

    Chomag [OP] Well-Known Member

    Joined:
    Jun 9, 2008
    Member:
    #7201
    Messages:
    111
    San Antonio TX.
    Vehicle:
    05 4X4 TRD sport
    Flowmaster Org. 40
    I live in an area that has a few hills, and on the highway when I'm on a climb even though the hill isn't all that steep but may have a long slop.My control cruse control throws me into a very low causing my rpms to jump into the 5k+ rpms. It's so dramatic that it feels like I'm drag racing someone up the hill.

    All of my other vehicles will of course downshift sometimes but never near as drastic as the cruse control is doing on my Taco. I often find myself laughing thinking to myself while I'm driving it up the same hills without the cruse engaged and it barely ever needs to even downshift to keep the speed going up the hill.

    Anyways, I was wondering if this is just a common charactoristic of the cruse control for the Tacoma or that I might have a faulty one?
     
  2. Jun 24, 2008 at 6:40 AM
    #2
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,686
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    Pardon for this question - but ...I've heard of stranger things happening...

    Do you have an auto or a manual?

    What gear are you in at the time the rpm's go up to 5,000?

    I'm gonna assume you have an Auto.... are you in "D" and not "4"?
     
  3. Jun 24, 2008 at 6:47 AM
    #3
    Khaos

    Khaos Well-Known Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,517
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    The cruise control in these Toyota's likes to do that. My Dad's '07 Camry likes to downshift and redline doing 80MPH when the cruise is on, even though Florida is completely flat.
     
  4. Jun 24, 2008 at 7:08 AM
    #4
    wiscdave

    wiscdave Lets Do It!

    Joined:
    Mar 20, 2008
    Member:
    #5392
    Messages:
    2,550
    Gender:
    Male
    Northern Wisconsin
    Vehicle:
    Tundra Rock Warrior
    Past ride - 3" OME 885s&Shocks/ TSB 1.5AAL/ AX184 Rims 285 Firestone destination ATs/ 2 Shallow mount P310s in Supercrew Box - Punch 601s, Beefed up Hunter Brush guard, Tint, Fog light mod, AFE Drop in, AC and Fog light mods, scangauge
    Yep, makes you NOT want to use the cruise control due to the gas that you thought you were saving by using the cruise control going out the window when the fricken engine redlines for 30 seconds.
     
  5. Jun 24, 2008 at 8:55 AM
    #5
    VinnyBob

    VinnyBob Member

    Joined:
    Jun 7, 2008
    Member:
    #7151
    Messages:
    9
    South Burlington VT
    Vehicle:
    2.7L base
    Aftermarket sound system with single 12" alpine subwoofer w/ amp, Roll and Bull bar(currently under fabrication)
    I had the same problem on my 95 camry I guess its just one of those things I just turned it off when I came to a hill
     
  6. Jun 24, 2008 at 1:01 PM
    #6
    tacoskim

    tacoskim Tuned By Gadget

    Joined:
    Mar 13, 2008
    Member:
    #5252
    Messages:
    2,396
    Gender:
    Male
    Los Angeles, CA
    Vehicle:
    09 TRD 4x4 Pyrite Mica
    Stock
    gas goes to shit when the cruise control is used on these trucks
     
  7. Jun 24, 2008 at 1:13 PM
    #7
    Chomag

    Chomag [OP] Well-Known Member

    Joined:
    Jun 9, 2008
    Member:
    #7201
    Messages:
    111
    San Antonio TX.
    Vehicle:
    05 4X4 TRD sport
    Flowmaster Org. 40
    Heh, looks like its just something I'll have to get used to. Thanks all for the replies though.
     
  8. Jun 24, 2008 at 9:09 PM
    #8
    MikeS.

    MikeS. Well-Known Member

    Joined:
    Jun 10, 2008
    Member:
    #7207
    Messages:
    288
    Far Eastern WVa
    Vehicle:
    2008 DC LB 4x4 in Speedway Blue.
    Undercover bed topper, Nerf style step bars, Python alarm, Ham radio with 250 watt amp and chrome wheel well bling.
    The cruise on my 96 Avalon was great, it didn't act this way. My 97 Tacoma, my 05 Avalon and my new 2008 Tacoma do. It's a PIA.
     
To Top