1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cylinder 6 misfire

Discussion in '2nd Gen. Tacomas (2005-2015)' started by eastonK, Sep 16, 2019.

  1. Sep 16, 2019 at 6:34 AM
    #1
    eastonK

    eastonK [OP] New Member

    Joined:
    Sep 16, 2019
    Member:
    #305425
    Messages:
    2
    Gender:
    Male
    Vehicle:
    2005 Tacoma TRD Off-road
    I’m having issues with my 2005 Tacoma 4.0. I had engine shake at startup so I changed plugs. It was due anyway. Ran fine for 4 months. Filled the tank one day and came out the next time to start it and it was shaking and threw a cylinder 6 misfire code. Changed plug in cylinder 6 and it was good for 2 days then it threw the same code again. Changed plug again and this time I switched coil packs. Ran ok for day or two and yep you guessed it. Cylinder 6 misfire again. This time I got new plug and changed oil because it was due. Put a can of Seafoam in it and filled it with 93 octane. Ran for a day and threw code 306 again. I’m running out of ideas. Any suggestions would be great.
     
  2. Sep 16, 2019 at 7:00 AM
    #2
    Fullboogie

    Fullboogie Well-Known Member

    Joined:
    May 8, 2017
    Member:
    #218539
    Messages:
    905
    Gender:
    Male
    First Name:
    Dave
    Houston
    Vehicle:
    2007 Prerunner & 2008 4Runner
    Who wants to say it? I'm not going to...
     
    Plain Jane Taco, PzTank and Torspd like this.
  3. Sep 16, 2019 at 7:02 AM
    #3
    JaCado

    JaCado I make bad choices

    Joined:
    Aug 29, 2016
    Member:
    #195947
    Messages:
    38,239
    Welcome to TW :notsure:
    Or clean the maf and throttle body?
     
  4. Sep 16, 2019 at 7:11 AM
    #4
    BassAckwards

    BassAckwards Well-Known Member

    Joined:
    May 3, 2016
    Member:
    #186002
    Messages:
    24,981
    Gender:
    Male
    First Name:
    Robert
    Run a compression test on all cylinders. It's likely cylinder 6 will show the issue. My guess is headgaskets

    How many miles on the truck
     
    Larzzzz, mojojojo78 and Torspd like this.
  5. Sep 16, 2019 at 7:27 AM
    #5
    Torspd

    Torspd Tor-nication

    Joined:
    Sep 18, 2009
    Member:
    #22958
    Messages:
    21,864
    Gender:
    Male
    First Name:
    Tor
    The Great America!
    Vehicle:
    MMVI 4.4L 4x4 Access Cab
    Torspd Custom Turbo kit [] Borg Warner 9180EFR Turbo [] Haltech Elite 2500 [] TiAL Q BOV [] TiAL V44 Wastegate @ 15psi [] CP Pistons [] CP Carrillo Rods [] ARP Head studs [] ARP Main Studs [] ARP Header - Head Studs [] Ported Heads w/ 1mm oversized valves intake/exhaust [] Brian Crower Forged Stroker Crank [] Darton M.I.D. Sleeved Block [] Kelford Camshafts [] Torspd 160* T-stat mod [] APR Large Fuel Rail [] Walbro 460 LPH E85 Fuel Pump [] FueLab FPR [] APR T56 Conversion Kit [] KP RACING Built T56 [] McLeod Racing Custom Twin Disk Clutch [] One Piece Aluminum Driveshaft [] MGW Shifter [] Custom lowering kit [] Ohlins Front Coilovers [] QA1rear shocks [] Custom Ron Davis Radiator [] Dual SPAL Electric Fans []
    Hmm. Blowing coolant or no?

    If no, swap that coil pack with another coil pack, and see if the misfire follows that coil pack.
     
    BassAckwards likes this.
  6. Sep 16, 2019 at 7:31 AM
    #6
    Sharpish

    Sharpish Well-Known Member

    Joined:
    Jan 4, 2016
    Member:
    #173981
    Messages:
    2,609
    Gender:
    Male
    First Name:
    Brian
    Victoria, British Columbia, Canada
    Vehicle:
    2012 Tacoma TRD OR 4x4
    Head gasket?
     
  7. Sep 16, 2019 at 8:20 AM
    #7
    Fullboogie

    Fullboogie Well-Known Member

    Joined:
    May 8, 2017
    Member:
    #218539
    Messages:
    905
    Gender:
    Male
    First Name:
    Dave
    Houston
    Vehicle:
    2007 Prerunner & 2008 4Runner
    I hate seeing these posts. Hard starting, misfiring that doesn't follow a swapped coil - kinda points to one thing. I hope it's not the case, though.
     
  8. Sep 16, 2019 at 8:34 AM
    #8
    PzTank

    PzTank Stuck In The Well

    Joined:
    Sep 14, 2010
    Member:
    #43250
    Messages:
    2,966
    Gender:
    Male
    First Name:
    Jim
    New England
    Vehicle:
    ‘15 AC SR5 4X4 4.0 Auto
    ‘07 OR leather shift knob.
    Patience grasshopper...

    At some point, there won’t be any ‘05s and early ‘06es left.
     
    Lester Lugnut and Torspd like this.
  9. Sep 16, 2019 at 1:26 PM
    #9
    eastonK

    eastonK [OP] New Member

    Joined:
    Sep 16, 2019
    Member:
    #305425
    Messages:
    2
    Gender:
    Male
    Vehicle:
    2005 Tacoma TRD Off-road
    The truck has 145,000 on it. Plug hasn’t been wet any of the times I swapped it. Head gasket is what I was thinking but not what I wanted to hear. $$$$$$
     
    BassAckwards likes this.
  10. Sep 16, 2019 at 1:57 PM
    #10
    BassAckwards

    BassAckwards Well-Known Member

    Joined:
    May 3, 2016
    Member:
    #186002
    Messages:
    24,981
    Gender:
    Male
    First Name:
    Robert
  11. Dec 4, 2020 at 11:37 AM
    #11
    msimons99

    msimons99 New Member

    Joined:
    Dec 4, 2020
    Member:
    #348638
    Messages:
    2
    Gender:
    Male
    Did you ever get the answer here?
     
  12. Dec 4, 2020 at 11:44 AM
    #12
    Torspd

    Torspd Tor-nication

    Joined:
    Sep 18, 2009
    Member:
    #22958
    Messages:
    21,864
    Gender:
    Male
    First Name:
    Tor
    The Great America!
    Vehicle:
    MMVI 4.4L 4x4 Access Cab
    Torspd Custom Turbo kit [] Borg Warner 9180EFR Turbo [] Haltech Elite 2500 [] TiAL Q BOV [] TiAL V44 Wastegate @ 15psi [] CP Pistons [] CP Carrillo Rods [] ARP Head studs [] ARP Main Studs [] ARP Header - Head Studs [] Ported Heads w/ 1mm oversized valves intake/exhaust [] Brian Crower Forged Stroker Crank [] Darton M.I.D. Sleeved Block [] Kelford Camshafts [] Torspd 160* T-stat mod [] APR Large Fuel Rail [] Walbro 460 LPH E85 Fuel Pump [] FueLab FPR [] APR T56 Conversion Kit [] KP RACING Built T56 [] McLeod Racing Custom Twin Disk Clutch [] One Piece Aluminum Driveshaft [] MGW Shifter [] Custom lowering kit [] Ohlins Front Coilovers [] QA1rear shocks [] Custom Ron Davis Radiator [] Dual SPAL Electric Fans []
    Having a similar issue here?
     
  13. Dec 4, 2020 at 1:25 PM
    #13
    msimons99

    msimons99 New Member

    Joined:
    Dec 4, 2020
    Member:
    #348638
    Messages:
    2
    Gender:
    Male
    Yep - frustrating
     
  14. Dec 4, 2020 at 1:31 PM
    #14
    Lastplace

    Lastplace Well-Known Member

    Joined:
    Jun 29, 2013
    Member:
    #107250
    Messages:
    537
    Gender:
    Male
    Southeast VA
    I almost bought an 06, yikes
     
    PzTank likes this.
  15. Dec 4, 2020 at 2:24 PM
    #15
    PzTank

    PzTank Stuck In The Well

    Joined:
    Sep 14, 2010
    Member:
    #43250
    Messages:
    2,966
    Gender:
    Male
    First Name:
    Jim
    New England
    Vehicle:
    ‘15 AC SR5 4X4 4.0 Auto
    ‘07 OR leather shift knob.
    Depends on the month.

    IIRC, November 2005 was the change over date to the improved version of the HG.

    Someone more knowledgeable should verify.

    Edit: quote below has my senior moment 2015 date....
     
    Last edited: Dec 4, 2020
  16. Dec 4, 2020 at 3:02 PM
    #16
    Fullboogie

    Fullboogie Well-Known Member

    Joined:
    May 8, 2017
    Member:
    #218539
    Messages:
    905
    Gender:
    Male
    First Name:
    Dave
    Houston
    Vehicle:
    2007 Prerunner & 2008 4Runner
    You are right. I've bought two '06's in the last two years and made sure both were well beyond that build date.
     
    PzTank likes this.
  17. Dec 4, 2020 at 3:23 PM
    #17
    Torspd

    Torspd Tor-nication

    Joined:
    Sep 18, 2009
    Member:
    #22958
    Messages:
    21,864
    Gender:
    Male
    First Name:
    Tor
    The Great America!
    Vehicle:
    MMVI 4.4L 4x4 Access Cab
    Torspd Custom Turbo kit [] Borg Warner 9180EFR Turbo [] Haltech Elite 2500 [] TiAL Q BOV [] TiAL V44 Wastegate @ 15psi [] CP Pistons [] CP Carrillo Rods [] ARP Head studs [] ARP Main Studs [] ARP Header - Head Studs [] Ported Heads w/ 1mm oversized valves intake/exhaust [] Brian Crower Forged Stroker Crank [] Darton M.I.D. Sleeved Block [] Kelford Camshafts [] Torspd 160* T-stat mod [] APR Large Fuel Rail [] Walbro 460 LPH E85 Fuel Pump [] FueLab FPR [] APR T56 Conversion Kit [] KP RACING Built T56 [] McLeod Racing Custom Twin Disk Clutch [] One Piece Aluminum Driveshaft [] MGW Shifter [] Custom lowering kit [] Ohlins Front Coilovers [] QA1rear shocks [] Custom Ron Davis Radiator [] Dual SPAL Electric Fans []
    Checked for continual bubbling in your overflow tank? More so when mashing the skinny pedal?

    Checked for hydrocarbons in the coolant system?
     
  18. Dec 4, 2020 at 3:51 PM
    #18
    2WD

    2WD Well-Known Member

    Joined:
    Jun 11, 2018
    Member:
    #256160
    Messages:
    142
    First Name:
    Pete
    Vehicle:
    2013 DCSB TRD Off-Road Pre-Runner Taco
    King 25001-119A, JBA HC and superbumps, EL095 leafs with longer overload leaf removed and 2 degree shim, Bilstein 5160 rears with fox roost shield on passenger side, King 2'' bump stops, B&M 70264 trans cooler, CSF FJ radiator, Leer Trilogy X2T bed cover, Scangauge, 34R AGM battery, weathertech floormats, Gold plug on the differential, fancy engine and diff oils, UNI air injection filter mod, Factory antenna chopped 4'', De-badged, Ram mount on A pillar, Cooper ST Maxx 265/75 R16.
    If by some miracle HG is OK, could the problem be due to bad #6 injector?
     
  19. Dec 4, 2020 at 4:07 PM
    #19
    Torspd

    Torspd Tor-nication

    Joined:
    Sep 18, 2009
    Member:
    #22958
    Messages:
    21,864
    Gender:
    Male
    First Name:
    Tor
    The Great America!
    Vehicle:
    MMVI 4.4L 4x4 Access Cab
    Torspd Custom Turbo kit [] Borg Warner 9180EFR Turbo [] Haltech Elite 2500 [] TiAL Q BOV [] TiAL V44 Wastegate @ 15psi [] CP Pistons [] CP Carrillo Rods [] ARP Head studs [] ARP Main Studs [] ARP Header - Head Studs [] Ported Heads w/ 1mm oversized valves intake/exhaust [] Brian Crower Forged Stroker Crank [] Darton M.I.D. Sleeved Block [] Kelford Camshafts [] Torspd 160* T-stat mod [] APR Large Fuel Rail [] Walbro 460 LPH E85 Fuel Pump [] FueLab FPR [] APR T56 Conversion Kit [] KP RACING Built T56 [] McLeod Racing Custom Twin Disk Clutch [] One Piece Aluminum Driveshaft [] MGW Shifter [] Custom lowering kit [] Ohlins Front Coilovers [] QA1rear shocks [] Custom Ron Davis Radiator [] Dual SPAL Electric Fans []
    Could be that as well.
     
  20. Dec 5, 2020 at 9:32 AM
    #20
    rphillips

    rphillips Well-Known Member

    Joined:
    Sep 14, 2016
    Member:
    #197271
    Messages:
    990
    Gender:
    Male
    First Name:
    Rick
    Norene TN.
    Vehicle:
    2013 Reg. cab 4x4
    none
    You should have bought a 4 cyl..... you wouldn't (couldn't) have this problem
     

Products Discussed in

To Top