1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Defective Dick Cepek DC1

Discussion in 'Wheels & Tires' started by RedskinRedTaco, Aug 16, 2011.

  1. Aug 16, 2011 at 11:47 AM
    #1
    RedskinRedTaco

    RedskinRedTaco [OP] Well-Known Member

    Joined:
    Aug 16, 2009
    Member:
    #21263
    Messages:
    122
    Gender:
    Male
    First Name:
    Paul
    Virginia Beach, VA
    Vehicle:
    07 TRD 4x4 Offroad Crewcab
    Trifecta folding Touneau Cover, 275/70/16 LTX M/S, Running Boards, Dynamat, tint, Alpine W404 Video system w/ backup cam, Sirius Sat, Polk Audio Component Speakers frt and back, Alpine 4x50 amp. Billy's 5100's set @ 1 3/4, 1" rear blocks, Rear TSB, trimmed frt mud flaps 4", TRD Exhuast, K&N filter. Electric Brake.
    Dont know if anyone else is having the same problem. I have a set of Black Cepek DC1's that the claer coat is peeling. Luck for me it is within the 2 years waranty period. The guy at 4 wheel parts told me this is why the DC1's were discontinued and the DC2's replaced they. Has anyone had this problem with the DC2's? i'm thinking about switching to the Cepek Torque instead. Anyone running the Torque with a 275/70/16 or bigger tire. The back spacing is 1/2" more on the Torque. I am running 5100's with a 1" block and TSB in the rear

    [​IMG]
     
To Top