1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Did aux mod now the airbag light came on

Discussion in '2nd Gen. Tacomas' started by Boogyman, Jan 2, 2013.

  1. Jan 2, 2013 at 8:42 PM
    #1
    Boogyman

    Boogyman [OP] SOS concepts shop bitch

    Joined:
    Aug 17, 2012
    Member:
    #84975
    Messages:
    6,157
    Gender:
    Male
    First Name:
    Phoenix
    Charleston, South Carolina
    Vehicle:
    BSP 06 4x4 SR5
    Fox 2.0 IFPs, superbumps, LR UCA, "king" 5100s and Dakars
    I finally got around to doing the auxiliary input mod in my 06. Once I installed everything back into the dash a cranked up my truck to test it my airbag light came on and won't turn off. Is this just a coincidence or did I screw something up?
     
  2. Jan 2, 2013 at 8:49 PM
    #2
    97lt1ta

    97lt1ta Well-Known Member

    Joined:
    Dec 29, 2012
    Member:
    #93985
    Messages:
    76
    Gender:
    Male
    Las Vegas
    Vehicle:
    07 prerunner
    Try unhooking the battery for 15 min resetting the ecu if it comes back on there is a problem. If it comes back on start checking your connections make sure everything is hooked up properly. If that's still doesn't work could be a sensor , clock spring, ect either way pain in the ass
     
  3. Jan 2, 2013 at 8:52 PM
    #3
    Boogyman

    Boogyman [OP] SOS concepts shop bitch

    Joined:
    Aug 17, 2012
    Member:
    #84975
    Messages:
    6,157
    Gender:
    Male
    First Name:
    Phoenix
    Charleston, South Carolina
    Vehicle:
    BSP 06 4x4 SR5
    Fox 2.0 IFPs, superbumps, LR UCA, "king" 5100s and Dakars
    I was searching around and my truck falls under the clock spring recall. Is there a way I can check and see if it was ever replaced? I got the truck somewhat recently and I never got any of its history on what got done on it.
     
  4. Jan 2, 2013 at 9:02 PM
    #4
    97lt1ta

    97lt1ta Well-Known Member

    Joined:
    Dec 29, 2012
    Member:
    #93985
    Messages:
    76
    Gender:
    Male
    Las Vegas
    Vehicle:
    07 prerunner
    Hmm would have to call your local dealer give them your vin and see if it had the replacement for the recall is the only way I know. Try the battery disconnect if that doesn't help take it down to your dealer see if its caused by the recall. If its not they might be able to tell you what it could be if not air bags are not as complicated as some people make them out to be. It can only be about 4 different things which 2 are a big pain in the ass but the main one is making sure you do it safely
     
  5. Jan 2, 2013 at 9:03 PM
    #5
    DoorDing

    DoorDing Thank you, Nancy Roman

    Joined:
    Sep 7, 2012
    Member:
    #86445
    Messages:
    24,652
    Gender:
    Male
    Vehicle:
    2012 DCSB Off-Road 4WD
    Any Toyota shop can run the VIN to see if recall work has been performed, or needs to be.
     
  6. Jan 2, 2013 at 9:06 PM
    #6
    Boogyman

    Boogyman [OP] SOS concepts shop bitch

    Joined:
    Aug 17, 2012
    Member:
    #84975
    Messages:
    6,157
    Gender:
    Male
    First Name:
    Phoenix
    Charleston, South Carolina
    Vehicle:
    BSP 06 4x4 SR5
    Fox 2.0 IFPs, superbumps, LR UCA, "king" 5100s and Dakars
    Thanks for getting back to me so quickly. I'm gonna try the battery thing in the morning and see if that helps
     
  7. Jan 3, 2013 at 5:19 AM
    #7
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    3,586
    Gender:
    Male
    SC
    Vehicle:
    Prerunner SR5
    It appears that either the plug for the airbag module got screwed when you had it out OR it isn't plugged in correctly OR You turned on the ignition with the module unplugged during your mod and it will require a dealer to reset.

    The bolded happens more often than you would think.
     
  8. Jan 3, 2013 at 7:54 AM
    #8
    Boogyman

    Boogyman [OP] SOS concepts shop bitch

    Joined:
    Aug 17, 2012
    Member:
    #84975
    Messages:
    6,157
    Gender:
    Male
    First Name:
    Phoenix
    Charleston, South Carolina
    Vehicle:
    BSP 06 4x4 SR5
    Fox 2.0 IFPs, superbumps, LR UCA, "king" 5100s and Dakars
    i didnt have time to unplug the battery this morning before school but while i was driving i remembered it was on last night and it was off while i was driving. does it cut off when in gear? or could it be fine now?
     
  9. Jan 3, 2013 at 8:39 PM
    #9
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    3,586
    Gender:
    Male
    SC
    Vehicle:
    Prerunner SR5
    It should be fine. How long did you drive it? It does a self test every time you turn on the truck.
     
To Top