1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Disassemble 07 fuse box? PLs help

Discussion in 'Technical Chat' started by wfletcher3, Dec 4, 2010.

  1. Dec 4, 2010 at 4:53 PM
    #1
    wfletcher3

    wfletcher3 [OP] Member

    Joined:
    Dec 4, 2010
    Member:
    #47158
    Messages:
    15
    Gender:
    Male
    First Name:
    Wayne
    Ridley Park
    Vehicle:
    07 TRD 4L $WD
    I blew the 140 amp Alt fuse. How do you take the box apart pls!.. 07, 4WD, $L V6 TRD Sport, Double cab.

    Many thanx up front

    downsized_1204001428.jpg
    downsized_1204001429.jpg
     
  2. Dec 4, 2010 at 4:54 PM
    #2
    brutalguyracing

    brutalguyracing BIG DADDY

    Joined:
    Jun 28, 2009
    Member:
    #19000
    Messages:
    24,038
    Gender:
    Male
    F.U> GUYZ
    broken mods
    :popcorn:i didnt even know they had a 140amp fuse
    good luck a pro will chime in soon im sure
     
  3. Feb 26, 2011 at 1:52 PM
    #3
    Burgman

    Burgman I KEEEEEL YOU

    Joined:
    Apr 16, 2009
    Member:
    #16072
    Messages:
    26,682
    Gender:
    Male
    First Name:
    Stephen
    Ric VA
    Vehicle:
    08 PreRunner TRD sport Silver
    K&N intake, Boston Acoustic SL 60 6.5 components up front, Rockford Power T16 6.5 in rear, Pioneer P4100 HU, Soon to be Pioneer Prs 4200f
    just did this to my truck made a crappy paint image to show how to take the fuse box apart to change the 140 amp Alt fuse
    [​IMG]
     
  4. Feb 27, 2011 at 3:51 AM
    #4
    wfletcher3

    wfletcher3 [OP] Member

    Joined:
    Dec 4, 2010
    Member:
    #47158
    Messages:
    15
    Gender:
    Male
    First Name:
    Wayne
    Ridley Park
    Vehicle:
    07 TRD 4L $WD
    Thanx, I need to do some rewiring. I just put in a second battery and isolator. Ended up taking it to a garage to get it fixed. Going to try again when it gets warmer.

    How did you get the clips to release? I tried a screw driver, but couldn't get anything to release.
     
  5. Feb 27, 2011 at 10:46 AM
    #5
    Burgman

    Burgman I KEEEEEL YOU

    Joined:
    Apr 16, 2009
    Member:
    #16072
    Messages:
    26,682
    Gender:
    Male
    First Name:
    Stephen
    Ric VA
    Vehicle:
    08 PreRunner TRD sport Silver
    K&N intake, Boston Acoustic SL 60 6.5 components up front, Rockford Power T16 6.5 in rear, Pioneer P4100 HU, Soon to be Pioneer Prs 4200f
    I pulled on the two wire looms closest to the fender up while unclipping the clips with a flathead... getting the two pieces seperated to get to the inside bolt for the Alt fuse was a pain and only got it half of where I highlighted it but it was enough to get a socket in there
     
To Top