1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Dome Light Timer??

Discussion in '1st Gen. Tacomas (1995-2004)' started by CutnShootTaco, Sep 3, 2007.

  1. Sep 3, 2007 at 6:30 PM
    #1
    CutnShootTaco

    CutnShootTaco [OP] Member

    Joined:
    Sep 3, 2007
    Member:
    #2594
    Messages:
    7
    Vehicle:
    2004 Tacoma Texas Edition
    My dome light is out. Bulb is good. No power up there. Thinking it may be the auto timer. Anyone know where this is???

    Thanks
     
  2. Sep 3, 2007 at 8:20 PM
    #2
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    There's an auto time on those things? First I've heard of that.
     
  3. Sep 3, 2007 at 8:26 PM
    #3
    coreyredken

    coreyredken Well-Known Member

    Joined:
    Feb 20, 2007
    Member:
    #947
    Messages:
    365
    North Georgia, Mount Airy
    Vehicle:
    07 Prerunner SR5
    Westin Stainless Steel Oval Side Bars!
    If you notice that when you close the doors the light stays on in the cab for about 10 sec. or so and then slowly dims until turns off.. so I would say it had a timer on it of some sort..
     
  4. Sep 3, 2007 at 9:38 PM
    #4
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    Hmmm, don't have that sort of thing on my '99. I guess they had them on the '01+.
     
  5. Sep 4, 2007 at 6:19 AM
    #5
    CutnShootTaco

    CutnShootTaco [OP] Member

    Joined:
    Sep 3, 2007
    Member:
    #2594
    Messages:
    7
    Vehicle:
    2004 Tacoma Texas Edition
    Exactly what I have. This is a 2004.
     
  6. Jan 30, 2009 at 5:11 PM
    #6
    senor taco

    senor taco ROLLIN ON RUST

    Joined:
    Jan 7, 2009
    Member:
    #12330
    Messages:
    2,335
    Gender:
    Male
    First Name:
    Steve
    Monterey Bay, Ca
    Vehicle:
    O7 Tacoma PreRunner SR5
    17in fj cruiser wheels satoshi grille with devil horns emblem Single in double out 50 series flowmaster with stainless tips Kenwod ddx512 double din touch screen DVD reciver with a single Rockford fosgate 12 in sub with an alpine amp tinted tail and third break light silverstar head and fog lights k&n drop in Billy 5100's on all 4 corners with a 2"AAL
    It might be the switch
     
  7. Jan 30, 2009 at 6:26 PM
    #7
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,254
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    I wouldn't call it a timer either...

    My dome light did some weird stuff a while back. It'd go on when I turned a corner....weird... so I'm wondering if its related somehow. ??

    I'll keep watching this thread for updates.
     
  8. Jan 30, 2009 at 7:21 PM
    #8
    2004Taco

    2004Taco Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    check the fuse.
     
  9. Jan 30, 2009 at 7:44 PM
    #9
    Ry1984

    Ry1984 Well-Known Member

    Joined:
    Dec 1, 2008
    Member:
    #11203
    Messages:
    825
    Gender:
    Male
    From Texas, Now Miami FL
    Vehicle:
    01' ExtCab SR5 2.7 4x4
    K&N FIPK, Billy 5100 all around, 881's in the front, Toytec AAL
    x2 if its completely not working and you say the bulb is good, first thing to check is fuse
     
  10. Jan 30, 2009 at 8:21 PM
    #10
    jps76

    jps76 Member

    Joined:
    Nov 20, 2008
    Member:
    #10913
    Messages:
    24
    Gender:
    Male
    pemberton, bc, canada
    Vehicle:
    02 trd xtra cab
    3" revtek lift, 33" bfgs, piaa fog lights, more to come...
    i had the same thing happen on my 02 and it ended up being corrosion in the switch on the light, a little sand paper on the contacts and it works great now. hope that helps
     
  11. Jan 31, 2009 at 10:49 AM
    #11
    EnolaGaia

    EnolaGaia Well-Known Member

    Joined:
    Sep 9, 2006
    Member:
    #9
    Messages:
    1,129
    Gender:
    Male
    Midwest USA
    Vehicle:
    '01 & '04 S-Runners
    01 SR: Double Cab conversion, S/C, lowered.
    The interior light wiring diagrams for all years from 2001 through 2004 are identical.

    However, the 2002 owners manual is the last one that says the lights simply 'go off' after 15 seconds with all doors closed and the dome light in the 'DOOR' position.

    The 2003 and 2004 owners manuals clearly state the light 'fades out' in this condition.

    In any case - there's no separate 'timer' component in the circuit. My best guess would be that they added an 'auto-dim-to-off' circuit / whatever in the Body ECU unit effective with the 2003 model year.
     
  12. Jan 31, 2009 at 11:01 AM
    #12
    Delmarva

    Delmarva Mayor of TW

    Joined:
    Oct 22, 2008
    Member:
    #10148
    Messages:
    35,848
    Gender:
    Male
    First Name:
    Mike
    Tucson, AZ
    Vehicle:
    12 Tundra TRDRW
    Nada, Zip, Zilch, Nothing
    hmmm... only 1.5 years old. :thumbsup:
     
To Top