1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Dome Light Won't Turn Off

Discussion in '2nd Gen. Tacomas (2005-2015)' started by jshaw, Apr 30, 2009.

  1. Apr 30, 2009 at 11:34 AM
    #1
    jshaw

    jshaw [OP] Active Member

    Joined:
    Jan 21, 2009
    Member:
    #12830
    Messages:
    26
    Gender:
    Male
    First Name:
    Jeff
    S.C.
    Vehicle:
    06 TRD Sport White
    UWS black tool box, ScanGuage with Blend Mount, Rear AAL with 5100's all around,Total Chaos UCA's, Firestone air bags, BHLM with HID's
    I found a couple threads on this topic but never found an answer. My dome light does not cut off after shutting doors or locking truck. I checked the door switches and they seem to be fine. The "door ajar light" is not lit up on the dash. I assume there is a time delay relay somewhere. Is it built into the ECU? Does anyone have any ideas? I installed LED bed lights about 3 months ago wired into the dome light. They have worked fine until now. I hope they have not caused the problem. I am going to unhook them and see what happens. Anyone with any ideas please chime in. Thanks
     
  2. Apr 30, 2009 at 11:35 AM
    #2
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    have you checked the dome switch? The switch options are "On" "Off" and "Door" You want the "Door" option.
     
  3. Apr 30, 2009 at 12:35 PM
    #3
    jshaw

    jshaw [OP] Active Member

    Joined:
    Jan 21, 2009
    Member:
    #12830
    Messages:
    26
    Gender:
    Male
    First Name:
    Jeff
    S.C.
    Vehicle:
    06 TRD Sport White
    UWS black tool box, ScanGuage with Blend Mount, Rear AAL with 5100's all around,Total Chaos UCA's, Firestone air bags, BHLM with HID's
    Sorry, I should of done some more investigating before posting. The wire running from my bed LEDs to my dome light got behind the emergency brake somehow and got cut which was causing it to ground out. All fixed now.
     
  4. Apr 30, 2009 at 12:39 PM
    #4
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    good.
     
  5. Apr 30, 2009 at 12:51 PM
    #5
    Navigator

    Navigator Well-Known Member

    Joined:
    Mar 21, 2008
    Member:
    #5420
    Messages:
    275
    Gender:
    Male
    Ontario, Canada
    Vehicle:
    05 DC Sport 6spd
    17" American Racing Assaults on 265/70/17 Goodyear AT/S, TRD Exhaust, TRD CAI, Toyota Roof Rack, XM install with antenna out 3rd brake light, Red LED Map Lights, AUX Amber LED rocker switch for LED footwell lights, LUND Bug Screen, EXTANG Tri-Fold Tonneau, Hertz Component Speakers w/ TacoTunes Mounts, Infinity Kappa 4 amp, Image Dynamics 10" sub in TacoTunes enclosure, Pop n' Lock, Toyota Aluminum Wedge Running Boards, BHLM, Self Performed '05 Cowl Leak TSB, E-Z Cool Insulation/Sound Deadener applied to floorboard, headliner, and cab bulkhead, 896 Foglight bulbs as backup lights, Weathertechs, Pioneer Double Din, Scan Gauge, AutoSoft Remote Start, 2010 4Runner Heated/Signal/Puddle Mirrors.
    "Here's your sign!":D

    I should hope he wasn't that stupid.
     
  6. Apr 30, 2009 at 12:55 PM
    #6
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    it's the stupid things that stump people.

    I don't know how many people come in complaining that something isn't lit up, we all say "check the fuses" then he says "I did" then we say "do it again" and eventually he finds the bad fuse.
     
To Top