1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Downshifting while Moving

Discussion in '1st Gen. Tacomas (1995-2004)' started by bigpappa160, Dec 10, 2010.

  1. Dec 10, 2010 at 6:50 AM
    #1
    bigpappa160

    bigpappa160 [OP] Member

    Joined:
    Dec 9, 2010
    Member:
    #47400
    Messages:
    9
    Gender:
    Male
    Slocomb, Al
    Vehicle:
    04 tacoma TRD off road
    I had this downshifting problem the other night. I was at a trafffic light light turned green gave it some gass got up around 20-25mph at the truck downshifted and then up shifted and it happen around 35mph also after I gave it some more gas it work fine. Then last night same thing happened downshifted around 20-25mph then upshifted but then the check engine light came on. Has anyone experienced this problem and if so what is the remedy? the truck is a 04 tacoma with 159k on it
     
  2. Dec 10, 2010 at 8:03 AM
    #2
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,256
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    Have the CEL codes checked. You should be able to have it checked at Autozone or other national chain where they check codes for free.

    Could be anything.... If I had to guess, throttle position sensor?
     
  3. Dec 10, 2010 at 10:19 AM
    #3
    bigpappa160

    bigpappa160 [OP] Member

    Joined:
    Dec 9, 2010
    Member:
    #47400
    Messages:
    9
    Gender:
    Male
    Slocomb, Al
    Vehicle:
    04 tacoma TRD off road
  4. Dec 15, 2010 at 5:27 AM
    #4
    bigpappa160

    bigpappa160 [OP] Member

    Joined:
    Dec 9, 2010
    Member:
    #47400
    Messages:
    9
    Gender:
    Male
    Slocomb, Al
    Vehicle:
    04 tacoma TRD off road
    I just wanted to give everyone a update on the downshifting and the check engine light that came on after. I check the owners manual and went to the troubleshooting section and it said if the check engine light comes on while driving check gas cap, it might not be on or gas cap isn't tight. Unscrewed cap which when I did I noticed alot of pressure that was released and screwed cap back in and about the 2nd day of driving the light went out. So my guess is that the gas cap got screwed in wrong but tight enough wjere it built some pressure up to cause the downshifting in the gears kind of like a hiccup. But all is good no light for the last 3-4 days and no light and no down shifting
     
  5. Dec 15, 2010 at 11:15 AM
    #5
    BoostingMS6

    BoostingMS6 Well-Known Member

    Joined:
    Sep 21, 2010
    Member:
    #43565
    Messages:
    780
    Gender:
    Male
    First Name:
    Alex
    El Paso, TX
    Vehicle:
    1995.5 Tacoma Xtra Cab V6
    My '95.5 always releases some pressure (a noticeable hiss) when I unscrew the gas cap. So does our '87 RX-7, and our previous '86 Bronco did, too. I wouldn't think this is your problem.

    I hope the CEL stays off. Keep us updated! :)
     
  6. Dec 16, 2010 at 7:02 AM
    #6
    bigpappa160

    bigpappa160 [OP] Member

    Joined:
    Dec 9, 2010
    Member:
    #47400
    Messages:
    9
    Gender:
    Male
    Slocomb, Al
    Vehicle:
    04 tacoma TRD off road
    I understand most vehicles when you take gas cap off it has some pressure in it, but never noticed the amount of pressure coming out. I had this same problem with my infiniti G35, cel came on and I was like I bought a dud. Read manual and it had the same thing in the troubleshooting page, if cel comes 1st check gas cap to make sure it is on and it is fitted right, I went ou to the car and unscrewed the cap and then screwed it back in, in about 2 days the light went out. Now the manual said it would probably take a couple of time startng and driving for the light to go off. Now the 2nd step of the troubleshooting said if the light doesn't go out after a driving a couple of times take the dealer. But Like i said, unscrewed the cap screwed it back on in about 2 days well about lunch time the 2nd day the cel went out and for about 5 days now it hasn't came back on and no downshifting. For everyone that replied with information I Thank You and I Hope Everyone Has a Merry Christmas and a Happy New Year.
     
To Top