1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Drive line/tranny questions 2007 Tacoma

Discussion in 'Technical Chat' started by mlspence, Jun 23, 2010.

  1. Jun 23, 2010 at 8:29 AM
    #1
    mlspence

    mlspence [OP] Member

    Joined:
    May 23, 2007
    Member:
    #1651
    Messages:
    6
    Saint Joseph, Missouri, USA
    Vehicle:
    07 blue crew cab
    Retractible tonneau, running boards, tailgate lock,
    On my 2007 Tacoma with 4.0, 4x4 auto, I have begun to notice a slight roar sound at about 35-38 mph maybe coming from the tranny or drive line? (about 36,000 miles on truck.) It hasn't caused any problems but I'm wondering if I need to lube something that I haven't? It isn't the brakes as it does it without touching the brakes. I guess it could be tires but I'd be surprised if it stayed in this narrow range of mph.

    On a separate issue, I'm getting a slight "clunk" sound when stopping at a stop sign. I think it is the slip yoke shaft in the drive line between the transfer case and tranny but there is no grease fitting on it. Any ideas?

    A third issue. I notice when slowing for a stop sign, the tranny downshifts agressively decreasing the smooth "coast" that I'd get in the full-sized trucks I used to drive. Is this something others have noticed? Is there any way to change it?

    I still love the truck. It is still the only truck I've ever had that made it through the warranty period without going back to the dealer. :)
     
To Top