1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

E-Brake lever under cab not attached and missing parts uh-oh...

Discussion in '1st Gen. Tacomas (1995-2004)' started by awp101, Oct 4, 2011.

  1. Oct 4, 2011 at 7:41 AM

    awp101 [OP] New Member

    Oct 4, 2011
    Hello all! Over the weekend my stepson got an 01 standard cab SR5, 2.4L, 5 spd. He said the e-brake was not hooked up so I looked and the right cable is broken along with the lever that hooks to the splitter being zip tied to the frame. Now I've never fooled with the Toyotas but I'm pretty sure that's not right...:D

    I've done some digging around here and around the net with my friend Mr Google and I've got a couple of quetions I can't find an answer to:

    What is the big spring in this picture called and where can I find one?

    Searching for e-brake parts turns up plenty of cables, but no other parts like that spring or the lever itself.

    My short term goal is to at least get the lever put back together and installed and the left cable back into the splitter. I figure half an e-brake is better than none. Later we'll get both cables done unless having only one side hooked up is going to cause an issue. In that case we'll enlist additional help and do them both.

To Top