1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Electrical Lighting Help

Discussion in 'Lighting' started by MrGrimm, May 19, 2011.

  1. May 19, 2011 at 7:45 PM
    #1
    MrGrimm

    MrGrimm [OP] Mall Crawler

    Joined:
    Oct 19, 2009
    Member:
    #24568
    Messages:
    2,732
    Gender:
    Male
    First Name:
    Dean
    Wisconsin
    Vehicle:
    2006 Toyota Tacoma 4WD w/TRD Sport Package
    See build page
    Ok so I re-did all of the wiring for my running lights and my foglights. Running lights work but I am having trouble with the foglights.

    I have this wiring harness for my PIAA's

    [​IMG]

    I have this rocker switch in the cabin

    [​IMG]

    So here is my problem. I keep blowing a fuse in the cabin. The rocker switch that I have has 4 pins, only the bottom 4. My positive from the relay is going to the #1 position. The ground is going to the #4 position. Now the wire that goes from the switch to an add-a-fuse into a blank spot onto the fuse box inside on the #5 position.

    Should there now be a ground going to the #2 position? When I had this wired up before, I only had 3 wires on the back. Any help here?

    It saids in the picture that "4 pin switches are configured the same and use pins 2(-) and 5(+) as inputs. Outputs are 1(-) and 4(+)." Are my outputs wired up backwards?
     
  2. May 20, 2011 at 4:20 PM
    #2
    MrGrimm

    MrGrimm [OP] Mall Crawler

    Joined:
    Oct 19, 2009
    Member:
    #24568
    Messages:
    2,732
    Gender:
    Male
    First Name:
    Dean
    Wisconsin
    Vehicle:
    2006 Toyota Tacoma 4WD w/TRD Sport Package
    See build page
    bump...anybody?
     
  3. May 20, 2011 at 7:31 PM
    #3
    MrGrimm

    MrGrimm [OP] Mall Crawler

    Joined:
    Oct 19, 2009
    Member:
    #24568
    Messages:
    2,732
    Gender:
    Male
    First Name:
    Dean
    Wisconsin
    Vehicle:
    2006 Toyota Tacoma 4WD w/TRD Sport Package
    See build page
    fixed it. thanks!
     
To Top