1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine Clicking Noise 07 taco

Discussion in '2nd Gen. Tacomas (2005-2015)' started by datovits07, Aug 20, 2007.

  1. Aug 20, 2007 at 10:19 AM
    #1
    datovits07

    datovits07 [OP] Member

    Joined:
    Aug 20, 2007
    Member:
    #2486
    Messages:
    14
    Vehicle:
    07 BLACK TRD SPORT DOUBLE CAB 4X2
    Hey does anybody know if this is normal? I bought my truck a week ago and i just noticed clicking noises coming from the engine. Its sounds like an old typewriter clicking, standing in front of the hood it seems like the noise is coming from the right side of the engine. Can anyone tell me if you hear this on your engine too. i have an 07 taco SR5 prerunner trd sport double cab 2wd automatic with only 700 miles. went to the dealer to ask about it and they say its normal just fuel injectors doing their jobs, but i dont know sound like valves to me. Help Appreciate your help! Thanks
     
  2. Aug 20, 2007 at 10:49 AM
    #2
    gdawg25

    gdawg25 Zoom-Zoom

    Joined:
    Oct 25, 2006
    Member:
    #136
    Messages:
    1,024
    Gender:
    Male
    Victoria, BC
    Vehicle:
    '08 Mazdaspeed 3
  3. Aug 20, 2007 at 10:57 AM
    #3
    datovits07

    datovits07 [OP] Member

    Joined:
    Aug 20, 2007
    Member:
    #2486
    Messages:
    14
    Vehicle:
    07 BLACK TRD SPORT DOUBLE CAB 4X2
  4. Aug 20, 2007 at 11:04 AM
    #4
    gdawg25

    gdawg25 Zoom-Zoom

    Joined:
    Oct 25, 2006
    Member:
    #136
    Messages:
    1,024
    Gender:
    Male
    Victoria, BC
    Vehicle:
    '08 Mazdaspeed 3
    Yes my 07 does the same thing. Lots of people experience the same thing. Toyota claims it is normal. My truck runs great, so I don't think it is anything to worry about.
     
  5. Aug 20, 2007 at 1:17 PM
    #5
    datovits07

    datovits07 [OP] Member

    Joined:
    Aug 20, 2007
    Member:
    #2486
    Messages:
    14
    Vehicle:
    07 BLACK TRD SPORT DOUBLE CAB 4X2
    anyone else been to the dealers and said it was injectors and its normal?
     
To Top