1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

engine light

Discussion in '2nd Gen. Tacomas (2005-2015)' started by 96fido96, Apr 21, 2011.

  1. Apr 21, 2011 at 7:50 PM
    #1
    96fido96

    96fido96 [OP] Active Member

    Joined:
    Apr 13, 2011
    Member:
    #54872
    Messages:
    42
    Gender:
    Male
    First Name:
    ESQ
    ONTARIO CA
    Vehicle:
    PRERUNNER 4CYL
    I have an 06 PRE RUNNER 4cl manual, my engine light came on I took it to the
    shop, put it in the computer they told me it was just a loose gas cap. I bought a new locking gas cap from local auto parts but light won't go off.

    Is their a reset for the engine light.

    Also how do you reset the maintance light to turn off :p:burnrubber:
     
  2. Apr 21, 2011 at 7:58 PM
    #2
    clarkie152

    clarkie152 Well-Known Member

    Joined:
    Dec 25, 2009
    Member:
    #28146
    Messages:
    531
    Gender:
    Male
    MA
    Vehicle:
    13 MGM Tacoma DCSB
    None, yet
    To reset the engine light, you can disconnect your battery for 5 minutes? (I think) and the light will go away.

    Idk about maintenance lights, my 03 let's me decide when I service it.
     
  3. Feb 3, 2012 at 3:22 PM
    #3
    ges

    ges Member

    Joined:
    Aug 4, 2009
    Member:
    #20630
    Messages:
    7
    Gender:
    Male
    First Name:
    Greg
    Michigan
    Vehicle:
    06 Prerunner sport
    I called the shop about the check engine light. They suggested checking the gas cap which turned out to be completely loose. I tightened it but the light is still on. Will it reset by itself? The repair shop suggested it would after it ran an emissions test (and might take 25 starts). Does anyone have experience with this?
     
  4. Feb 3, 2012 at 3:45 PM
    #4
    Tacoma Mike

    Tacoma Mike 42 Year Toyota Master/ASE Master Tech.

    Joined:
    Aug 6, 2011
    Member:
    #61230
    Messages:
    6,178
    Gender:
    Male
    First Name:
    Mike
    Southern Maine
    Vehicle:
    2011 Double Cab V6
    Large Storage Box, 02610 intermittent switch swap, "Hot Wire" Power Outlets, DRL Shut Off, Disable Fob Beep, Disable Seat Belt Buzzers, Parking Light Mod, Battery Tender, 4 Leaf Spring Pack, Rear Headrest Removal, Custom Ultragauge Mount, Factory Tow Package (7 Pin) Rear Diff Mod, Taco Lean Mod
    It needs to see 3 good global trips.
    That being a certain run schedule 3 times with no problems. could take a few days. Needs a combo of city and highway constant speeds for a few miles while completely warming up and cooling off to a cold condition.

    Should go off if the cap was loose. AND also never fill up with the engine running or key on.
     
  5. Feb 3, 2012 at 6:06 PM
    #5
    ges

    ges Member

    Joined:
    Aug 4, 2009
    Member:
    #20630
    Messages:
    7
    Gender:
    Male
    First Name:
    Greg
    Michigan
    Vehicle:
    06 Prerunner sport
    Hey, Thats great news! I'll let you (all) know in a couple a days. Thanks for the quick reply.
     
  6. Feb 3, 2012 at 8:02 PM
    #6
    AlaskanTaco

    AlaskanTaco Well-Known Member

    Joined:
    Sep 18, 2011
    Member:
    #63749
    Messages:
    231
    Gender:
    Male
    Anchorage Alaska
    Vehicle:
    09 sr5 acc cab tacoma
    It is a small evap leak. That doesn't mean it is a gas cap. Anything more then a .80 is excessive for your year. .20 07+. Reset the light, and you need to drive it on the highway for at least 20 min in order for the computer to do all of the tests and determine specs. :)
     
  7. Feb 3, 2012 at 8:04 PM
    #7
    AlaskanTaco

    AlaskanTaco Well-Known Member

    Joined:
    Sep 18, 2011
    Member:
    #63749
    Messages:
    231
    Gender:
    Male
    Anchorage Alaska
    Vehicle:
    09 sr5 acc cab tacoma
    Emission standards say that evap tests can not be performed unless at engine temp, and above 45 mph. You can fill up with the car on ad running and it won't do anything.
     
  8. Feb 4, 2012 at 4:01 AM
    #8
    Tacoma Mike

    Tacoma Mike 42 Year Toyota Master/ASE Master Tech.

    Joined:
    Aug 6, 2011
    Member:
    #61230
    Messages:
    6,178
    Gender:
    Male
    First Name:
    Mike
    Southern Maine
    Vehicle:
    2011 Double Cab V6
    Large Storage Box, 02610 intermittent switch swap, "Hot Wire" Power Outlets, DRL Shut Off, Disable Fob Beep, Disable Seat Belt Buzzers, Parking Light Mod, Battery Tender, 4 Leaf Spring Pack, Rear Headrest Removal, Custom Ultragauge Mount, Factory Tow Package (7 Pin) Rear Diff Mod, Taco Lean Mod
    And your point in quoting me is ???????
     
  9. Feb 4, 2012 at 9:55 AM
    #9
    AlaskanTaco

    AlaskanTaco Well-Known Member

    Joined:
    Sep 18, 2011
    Member:
    #63749
    Messages:
    231
    Gender:
    Male
    Anchorage Alaska
    Vehicle:
    09 sr5 acc cab tacoma
    You can fill up with the car running or key on and the SES light will not come on
     
  10. Feb 4, 2012 at 10:41 AM
    #10
    Tacoma Mike

    Tacoma Mike 42 Year Toyota Master/ASE Master Tech.

    Joined:
    Aug 6, 2011
    Member:
    #61230
    Messages:
    6,178
    Gender:
    Male
    First Name:
    Mike
    Southern Maine
    Vehicle:
    2011 Double Cab V6
    Large Storage Box, 02610 intermittent switch swap, "Hot Wire" Power Outlets, DRL Shut Off, Disable Fob Beep, Disable Seat Belt Buzzers, Parking Light Mod, Battery Tender, 4 Leaf Spring Pack, Rear Headrest Removal, Custom Ultragauge Mount, Factory Tow Package (7 Pin) Rear Diff Mod, Taco Lean Mod
    HEHEHE. yea it has when the conditions are right. but that's ok. Was just checking what you were questioning.
     
  11. Feb 6, 2012 at 6:25 AM
    #11
    ges

    ges Member

    Joined:
    Aug 4, 2009
    Member:
    #20630
    Messages:
    7
    Gender:
    Male
    First Name:
    Greg
    Michigan
    Vehicle:
    06 Prerunner sport

    I drove about 50 miles over the weekend (highway and city). The check engine light did not come on Monday morning when I started her up.

    Thanks.
     
  12. Feb 6, 2012 at 4:56 PM
    #12
    Tacoma Mike

    Tacoma Mike 42 Year Toyota Master/ASE Master Tech.

    Joined:
    Aug 6, 2011
    Member:
    #61230
    Messages:
    6,178
    Gender:
    Male
    First Name:
    Mike
    Southern Maine
    Vehicle:
    2011 Double Cab V6
    Large Storage Box, 02610 intermittent switch swap, "Hot Wire" Power Outlets, DRL Shut Off, Disable Fob Beep, Disable Seat Belt Buzzers, Parking Light Mod, Battery Tender, 4 Leaf Spring Pack, Rear Headrest Removal, Custom Ultragauge Mount, Factory Tow Package (7 Pin) Rear Diff Mod, Taco Lean Mod
    :thumbsup: Good for you..
     
  13. Feb 6, 2012 at 5:42 PM
    #13
    dustin19d

    dustin19d Well-Known Member

    Joined:
    Apr 19, 2008
    Member:
    #6076
    Messages:
    161
    Gender:
    Male
    Oregon
    Vehicle:
    06 Sport, 4X4, 6-Speed
    AllPro, Armorology, PrInSu, Armor Tech
    With the ignition off press and hold the Odometer reset button. Turn the key to Acc(don't start). The Odometer will show 5 flashing zeros that will count down to 4 flashing zeros- 3 flashing zeros, 2 , 1 , none. Then it will show 5 zeros again, at that point release the Odometer reset button. You just reset the Maint Req light for another 5k miles.
     
To Top