1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine stops for no reason

Discussion in '1st Gen. Tacomas' started by rbbaldwin2, Nov 2, 2011.

  1. Nov 2, 2011 at 9:04 AM
    #1
    rbbaldwin2

    rbbaldwin2 [OP] New Member

    Joined:
    Nov 2, 2011
    Member:
    #66303
    Messages:
    2
    Gender:
    Male
    First Name:
    Ryan
    California
    Vehicle:
    2000 Tacoma SR5, 3.4l 4x4
    In the past month, I have had a couple of instances where my truck will just turn off when I come to a stop. I have noticed that my RPM's can be a little erratic at times (revs up and down around 100 -200 rpm). After it shuts off, I just turn the key and it starts right back up. I have cleaned the battery terminals, air cleaner, new injectors ... not too sure what else might cause this. Any help?
     
  2. Nov 2, 2011 at 9:12 AM
    #2
    scocar

    scocar being weird again....still

    Joined:
    Nov 11, 2009
    Member:
    #25814
    Messages:
    22,305
    Gender:
    Male
    First Name:
    Glitterdick
    In close proximity to an undisclosed location
    Vehicle:
    01 Xcab TRD 4x4 V6 Man. SR5
    OME 881s, Dakars, greasable shackles, Nitrocharger sports, extended exhaust hanger, BAMF BPV relocate, Wheeler's extended brake line, rear diff breather mod, swaybar removed, Pilot backup lights, Redline hood struts, 4Runner 5-stars, Hidden Hitch Class III, 7-pin marine-grade wiring
    Are you getting any codes?

    Sounds like an idle problem. When correct, it should be at 750 RPM. What is yours?

    Once you restart it, does it idle OK, or do you have to give it gas to keep it going?

    It could be as simple as cleaning the MAF sensor inside the intake (after the air cleaner).

    Oh, and welcome to the site!
     
  3. Nov 2, 2011 at 9:17 AM
    #3
    Madjik_Man

    Madjik_Man The Rembrandt of Rattle Can

    Joined:
    Dec 2, 2009
    Member:
    #26893
    Messages:
    10,407
    Gender:
    Male
    Boulder, CO
    Vehicle:
    1998 Ext Cab TRD 5MT sunfire red pearl
    About 25 pounds of spray paint and vinyl dye
    Might want to look into the throttle position sensor too.
     
  4. Nov 2, 2011 at 9:28 AM
    #4
    scocar

    scocar being weird again....still

    Joined:
    Nov 11, 2009
    Member:
    #25814
    Messages:
    22,305
    Gender:
    Male
    First Name:
    Glitterdick
    In close proximity to an undisclosed location
    Vehicle:
    01 Xcab TRD 4x4 V6 Man. SR5
    OME 881s, Dakars, greasable shackles, Nitrocharger sports, extended exhaust hanger, BAMF BPV relocate, Wheeler's extended brake line, rear diff breather mod, swaybar removed, Pilot backup lights, Redline hood struts, 4Runner 5-stars, Hidden Hitch Class III, 7-pin marine-grade wiring
  5. Nov 2, 2011 at 11:10 AM
    #5
    rbbaldwin2

    rbbaldwin2 [OP] New Member

    Joined:
    Nov 2, 2011
    Member:
    #66303
    Messages:
    2
    Gender:
    Male
    First Name:
    Ryan
    California
    Vehicle:
    2000 Tacoma SR5, 3.4l 4x4
    I just realized that it may be my MAF ... I recently cleaned and oiled my air filter. I will check the MAF and TPS... Thanks for the help!
     
  6. Nov 2, 2011 at 1:34 PM
    #6
    dark tangent

    dark tangent Well-Known Member

    Joined:
    Oct 13, 2011
    Member:
    #65140
    Messages:
    206
    Gender:
    Male
    Madison, WI
    Rigid Dually D2 Amber Driving LEDs mounted on CBI Offroad ditch light brackets.
    Fuel pump perhaps?
     
  7. Nov 2, 2011 at 1:46 PM
    #7
    scocar

    scocar being weird again....still

    Joined:
    Nov 11, 2009
    Member:
    #25814
    Messages:
    22,305
    Gender:
    Male
    First Name:
    Glitterdick
    In close proximity to an undisclosed location
    Vehicle:
    01 Xcab TRD 4x4 V6 Man. SR5
    OME 881s, Dakars, greasable shackles, Nitrocharger sports, extended exhaust hanger, BAMF BPV relocate, Wheeler's extended brake line, rear diff breather mod, swaybar removed, Pilot backup lights, Redline hood struts, 4Runner 5-stars, Hidden Hitch Class III, 7-pin marine-grade wiring
    Ah! The dreaded oiled air filter. MAF. You should clean your throttle body, too.
     
  8. Nov 2, 2011 at 1:53 PM
    #8
    Toyota Tech31

    Toyota Tech31 Sometimes when I close my eyes, I can't see.

    Joined:
    Sep 2, 2011
    Member:
    #62769
    Messages:
    10,074
    Gender:
    Male
    First Name:
    Jason
    Debary, Florida
    Vehicle:
    '08 SWB Bad ass SPORT
    Air Raid air intake, 40 Series Flowmaster Muffler, Front Turn Signals Now Turn And Park, KENWOOD HEAD UNIT W/ ALL KENWOOD SPEAKER UPGRADES AND 2-10" KENWOOD SUBS BEHIND BACK SEAT, Bilstein 5125'S In Rear W/ 1.5 AAL'S, Bilstein 5100 W/ Eibachs Up Front, LR Upper control arms, NFAB steps, Bruteforce Fab Hybrid front bumper, LP10000 SuperWinch, 2 Rigid Industries SRM-2's, OKLedlightbars 6 CREE LED lights as fogs, AVID RBG, 2 4" red ring HIDs mounted behind the grille.
    I would have thought IAC valve before he mentioned the recent oiling he's done.
     
To Top