1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine turns on then dies

Discussion in '2nd Gen. Tacomas' started by rondog, Feb 18, 2013.

  1. Feb 18, 2013 at 8:48 AM
    #1
    rondog

    rondog [OP] your TW web developer!

    Joined:
    Nov 2, 2010
    Member:
    #45618
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Ronnie
    Escondido/San Diego
    Vehicle:
    pewp
    Total Chaos LT, 2.5x8" Fox coilover, 2.5x8" Fox triple bypass, GIANT SUA rear LT, 2.5x18" Fox triple bypass, 285/70/17 Toyo AT2, Glassworks all around, 4x Eagle Eye HIDs
    So I go to leave this morning, truck turns on for about 5 seconds and then goes off. I start it again, same thing except shorter. It dies after about 2 seconds.

    Now all I can do is start it and it dies almost right away. What is this sounding like? Fuel filter? pump? My truck hasn't done this before.
     
  2. Feb 18, 2013 at 8:55 AM
    #2
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,197
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Havent heard of this issue before. :eek:
     
  3. Feb 18, 2013 at 8:58 AM
    #3
    ViperJay

    ViperJay These are the voyages...

    Joined:
    Oct 29, 2010
    Member:
    #45416
    Messages:
    314
    Gender:
    Male
    First Name:
    Chris
    El Paso, TX
    Vehicle:
    05 Radiant Red DCLB Sport 4x4
    URD CAI, DTLT Headers, Vibrant Ultra Quiet Resonator, Aero 2540i muffler, NST Pulleys, URD MAF Calibrator, Icon 2.5 Coilovers , Bilstein 5100s in rear with All Pro 3" Leaf pack, Total Chaos UCAs, 2 Kicker 12" CVT Subwoofers w/Kicker ZX350.2 Amp, JVC KD-AVX77 stereo, ARE Camper Shell, 1 20" LED bar and 2 7" LED bars in front, 4 KC 6" HID Slimlites mounted on Bajarack roof rack, sliders, Cobra 29 XLR CB Radio, Icom IC-207H UHF/VHF Radio, Bed Lighting, Fog light mod, Projector Retrofit Headlights HID 5000k, HID fog lights 4300k, BHLM, LED taillights and turn signals, Glassworks front fenders, Blue Sea Fuse Box, Mil-Spec Battery Terminals, Odyssey PC2150 battery, Satoshi Grill, All-Pro Front Bumper
    Mine did that when I had problems with the MAF sensor. Also check for vacuum leaks.
     
  4. Feb 18, 2013 at 9:00 AM
    #4
    rondog

    rondog [OP] your TW web developer!

    Joined:
    Nov 2, 2010
    Member:
    #45618
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Ronnie
    Escondido/San Diego
    Vehicle:
    pewp
    Total Chaos LT, 2.5x8" Fox coilover, 2.5x8" Fox triple bypass, GIANT SUA rear LT, 2.5x18" Fox triple bypass, 285/70/17 Toyo AT2, Glassworks all around, 4x Eagle Eye HIDs
    I read in a few places about the MAF...I guess I could start there since that is the easiest
     
  5. Feb 18, 2013 at 9:20 AM
    #5
    rondog

    rondog [OP] your TW web developer!

    Joined:
    Nov 2, 2010
    Member:
    #45618
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Ronnie
    Escondido/San Diego
    Vehicle:
    pewp
    Total Chaos LT, 2.5x8" Fox coilover, 2.5x8" Fox triple bypass, GIANT SUA rear LT, 2.5x18" Fox triple bypass, 285/70/17 Toyo AT2, Glassworks all around, 4x Eagle Eye HIDs
    MAF was fine..also reading, people with a bad transponder key has this behavior
     
  6. Feb 18, 2013 at 9:35 AM
    #6
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,197
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    I guess you can always try your spare keys.
     
  7. Feb 18, 2013 at 9:53 AM
    #7
    scottw1

    scottw1 Well-Known Member

    Joined:
    Jan 7, 2013
    Member:
    #94652
    Messages:
    386
    Gender:
    Male
    First Name:
    Scott
    Norfolk, VA
    Vehicle:
    2010 SR5 Tacoma 4x4
    Lighted 4wd dial, Sirus XM radio
    Clean the Throttle Body as well. Shouldn't die that quick, should just be a bad idle and then possibly die.
     
  8. Feb 18, 2013 at 9:58 AM
    #8
    rondog

    rondog [OP] your TW web developer!

    Joined:
    Nov 2, 2010
    Member:
    #45618
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Ronnie
    Escondido/San Diego
    Vehicle:
    pewp
    Total Chaos LT, 2.5x8" Fox coilover, 2.5x8" Fox triple bypass, GIANT SUA rear LT, 2.5x18" Fox triple bypass, 285/70/17 Toyo AT2, Glassworks all around, 4x Eagle Eye HIDs
    I'll see if I can find my spare :eek: edit::found the spare, still no workie

    I have an extra throttle body so rather than cleaning it, I just replaced it just now and still no luck. Doing the same behavior
     
  9. Feb 18, 2013 at 10:13 AM
    #9
    08TacoTrD

    08TacoTrD Well-Known Member

    Joined:
    Oct 30, 2008
    Member:
    #10385
    Messages:
    741
    Gender:
    Male
    Vehicle:
    08 TRD Offroad
    Rear Differential Breather Extension, 4WD Light, Tailgate Pipe clamp, Fog lights on while High Beams on,2" Custom Rear Lift, Carrier Bearing flip 5100's and 883 OME Coils
    How's voltage on the battery?
     
  10. Feb 18, 2013 at 10:17 AM
    #10
    rondog

    rondog [OP] your TW web developer!

    Joined:
    Nov 2, 2010
    Member:
    #45618
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Ronnie
    Escondido/San Diego
    Vehicle:
    pewp
    Total Chaos LT, 2.5x8" Fox coilover, 2.5x8" Fox triple bypass, GIANT SUA rear LT, 2.5x18" Fox triple bypass, 285/70/17 Toyo AT2, Glassworks all around, 4x Eagle Eye HIDs
    11.8 when off, cant really test when its on since i'm the only one here and it dies too quickly. Does anyone know where I can find the fuel filter? I've been searching and cant find how to replace it
     
  11. Feb 18, 2013 at 10:18 AM
    #11
    rondog

    rondog [OP] your TW web developer!

    Joined:
    Nov 2, 2010
    Member:
    #45618
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Ronnie
    Escondido/San Diego
    Vehicle:
    pewp
    Total Chaos LT, 2.5x8" Fox coilover, 2.5x8" Fox triple bypass, GIANT SUA rear LT, 2.5x18" Fox triple bypass, 285/70/17 Toyo AT2, Glassworks all around, 4x Eagle Eye HIDs
    oh one thing to note about the battery, a few weeks ago, I was tightening the negative onto the battery and the terminal slipped out about an inch..I pounded it back in with a rubber mallet and all has been good since then. If it was a bad battery, it wouldn't turn over at all though right?
     
  12. Feb 18, 2013 at 10:20 AM
    #12
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,197
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Its a possibility it can be the battery but you would think after enough engine turn-overs it would completely die on you.
     
  13. Feb 18, 2013 at 10:20 AM
    #13
    veet skeet

    veet skeet Well-Known Member

    Joined:
    Aug 17, 2011
    Member:
    #61876
    Messages:
    1,009
    Gender:
    Male
    Cali
    Vehicle:
    14 4Runner Trail Edition MGM
    Bilstein 5100s, 17' Method NV Race Wheels, Goodyear Duratrac 265/70/17, Demello Sliders, Xenon/LEDs All Around, Dark Window Tint, Gobi Roof Rack (In the Mail), JL Audio Subs, Alpine Speakers and Amps
    maybe the key isn't being recognized for some reason?
     
  14. Feb 18, 2013 at 10:21 AM
    #14
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,197
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Thats what I would assume. Just to be sure though do you have another battery you can get from another vehicle and try swapping it?
     
  15. Feb 18, 2013 at 10:37 AM
    #15
    rondog

    rondog [OP] your TW web developer!

    Joined:
    Nov 2, 2010
    Member:
    #45618
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Ronnie
    Escondido/San Diego
    Vehicle:
    pewp
    Total Chaos LT, 2.5x8" Fox coilover, 2.5x8" Fox triple bypass, GIANT SUA rear LT, 2.5x18" Fox triple bypass, 285/70/17 Toyo AT2, Glassworks all around, 4x Eagle Eye HIDs
    ok just had the truck sitting for about 30 mins, started it up again and, bam! its on! Its been on for a few minutes now.

    Check engine light is on and the idle is sitting right above 1000 RPMs.. I still dont trust it..

    maybe it took a little while to recognize the new throttle body?
     
  16. Feb 18, 2013 at 10:38 AM
    #16
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,197
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Hmmm....thats really weird.
     
  17. Feb 18, 2013 at 10:40 AM
    #17
    rondog

    rondog [OP] your TW web developer!

    Joined:
    Nov 2, 2010
    Member:
    #45618
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Ronnie
    Escondido/San Diego
    Vehicle:
    pewp
    Total Chaos LT, 2.5x8" Fox coilover, 2.5x8" Fox triple bypass, GIANT SUA rear LT, 2.5x18" Fox triple bypass, 285/70/17 Toyo AT2, Glassworks all around, 4x Eagle Eye HIDs
    Ok idle is normal now..probably just took a little while to warm up..engine light still on
     
  18. Feb 18, 2013 at 10:41 AM
    #18
    BamaToy1997

    BamaToy1997 ASE Master Tech Vendor

    Joined:
    Jan 31, 2012
    Member:
    #71846
    Messages:
    9,388
    Gender:
    Male
    First Name:
    Bill
    Navarre, FL
    Vehicle:
    1997 Tacoma 4X4 AKA "Blue Beast"
    Multi-point tow hooks, new bored 2.7L engine, custom paint. 3 inch adjustable Fabtech front coils, 2.5 inch rear AAL. Front Aussie locker. LED bed lights. Full LED conversion interior and exterior. Relentless Fabrication front and rear bumpers. 4X4innovation sliders. BAMF bed rack. CVT rooftop tent.
    I would get the code scanned ASAP. Hard to really diagnose something like that without having all the information. There are so many sensors and such that could cause that condition. Let us know what the code is and we can help you from there! Good luck!
     
  19. Feb 18, 2013 at 10:42 AM
    #19
    BDJ

    BDJ Well-Known Member

    Joined:
    Jul 13, 2012
    Member:
    #82512
    Messages:
    150
    Gender:
    Male
    First Name:
    Brandon
    West Monroe
    Vehicle:
    2012 TRD OR 4x4 DBL Cab MGM
    I had this problem with an 09 I had, turns out the key wasn't being recognized so the truck thought it was being stolen and shut itself down. But to fix it the dealership told me I had to replace the computer because something was wrong with the current one and it wouldn't reprogram to the keys.
     
  20. Feb 18, 2013 at 10:43 AM
    #20
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,197
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Did you end up replacing your computer? If so how much did that run you?
     
To Top