1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Exhaust Problem

Discussion in 'Technical Chat' started by trdude10, Oct 27, 2009.

  1. Oct 27, 2009 at 11:54 PM

    trdude10 [OP] if it aint broke... make it better

    Aug 30, 2009
    First Name:
    Santa Rosa, Ca
    06 TRD Offroad
    Icon 2.5" coil over total chaos uca all pro 3 inch leaf pack bilstein 5100 rear shocks all pro front bumper smitty bilt xrc 8 winch
    I have a 2006 trd offroad 4x4 with a banks monster exhaust. Every time i get on the gas somewhat sound there is a terrible rattling noise coming from somewhere from the back of the truck and im pretty sure its from the exhaust. Does anyone have anything i can check for? It was rubbing up against where the leaf spring is bolted to the truck but i adjusted it so it wasnt doing that anymore, but it didnt fix the problem. I've checked that everything's tight. Also my airbag light just came on and i was wondering if there was anything i could do aabout that or if i should just take it into the shop. Thanks for the help.
  2. Oct 28, 2009 at 1:00 AM

    SLOH Well-Known Member

    Jul 17, 2008
    First Name:
    Los Angeles
    07 SR5, dc long bed speedway blue
    2.5 Icon c/o's and 3" AllPro rear suspension kit, 17" XD Series Addict w/ 285/70/R17 BFG KM2's, K&N 63 Series CAI, 12'' Rockford Fosgate sub and 500w amp, limo tint all around, cat back banks exhaust with no muffler or tip, shorty antenna, Kenwood DNX5120, blue dash light mod, "taco" 3rd brake light mod, blue dome-light mod, cb radio and 4' firestik antenna, blacked out hoodscoop(thanks randy), Total Chaos UCA's
    hahah yeah i used to have something like that, did you check to make sure there is no lateral play in the 3rd pipe, (one that bends over the rear axle) the rubber mounts that the exhaust mounts into are really flimsy, mine had play in it and that 3rd segment was rattling agianst the actual frame and would get tweaked downward from off roading and rub/hit my spare tire...get under there and try to shake it to see where it hits...worst comes to worst you could just remove that last segment, which is what i did and i like it alot better. The mufler is still supported perfectly fine cause the muffler alone has two mounts for it and that'll hold up fine off roading cause i've done alot with that set up and its fine, way better than before...and i think it looks better with no tail pipe showing

    yeah mine would rattle like crazy whenever i was at low RPMs or in reverse to park, its loud as hell, makes it sound like your cars about to fall apart at any second and is embarassing as hell
To Top