1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

fabtech 205 aal toomuch lift?

Discussion in 'Suspension' started by brelandt, Nov 8, 2009.

  1. Nov 8, 2009 at 6:27 AM
    #1
    brelandt

    brelandt [OP] Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    Hey guys, i bought a set of aal from amazon $53.40 shipped. They are the fabtech 205 that measure out to be 31-3/4 long. has a lot of arch.
    I installed them yesterday on my 2004 reg cab prerunner with 2.7 engine. I took my measurement before I started at 36" from ground to lip of the wheel opening. after the install i drove it about 50 miles and the measurement is a little 39-1/2"!!!!
    The aal kit stated 1-1/2" lift.
    Where my stock leafs sagging that much? Didnt seem to be?
    Has anyone else experience this.
    The ride is great, better than stock and no squeaks.
     
  2. Nov 8, 2009 at 7:01 AM
    #2
    pataco

    pataco Well-Known Member

    Joined:
    Jan 1, 2009
    Member:
    #12092
    Messages:
    2,071
    Gender:
    Male
    Down by the lake
    Vehicle:
    05 4x4 trd dc white
    FOX 2.0 RESIS,LRUCAS,BILLY 5100S ON THE REAR.MAGNAFLOW 11264,COLOR MATCHED GRILL,YELLOW FOG MOD.OVER HEAD DVD,FEDERAL COURAGIA M/T
    check your shock travel as well.u might not have any.and if u do it might make brake lines REALLY tight.
     
  3. Nov 8, 2009 at 7:15 AM
    #3
    brelandt

    brelandt [OP] Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    forgot to add that I had a set of 3.5" blocks installed years back, but removed them a year or more ago. Also had 3" lift on front which was removed as well. I also had longer brake line and shocks as well. But my ranchos maybe shot as they did not seem to extend on their own like when new.
     
  4. Nov 8, 2009 at 4:53 PM
    #4
    brelandt

    brelandt [OP] Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    something very unexpected happened today. I applied my brakes at a traffic light when however, the truck would not slow. I paniced! I was real close to hitting the back of the car in front of me then the pedal felt as if it broke free from under my foot and went down a couple of inches and the brakes kicked in.
    I never had that happen when I had my blocks installed.
    Later I tried to repeat what happened and it will, but not everytime.
    I adjusted my brakes by moving the bar up about an inch. The section over rear axle that adjusts how much fluid goes to the rear brakes. I havent driven yet but if I do not hit someone on my way to work in the morning than all will be good.
     
To Top