1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

finally debadged everything

Discussion in '2nd Gen. Tacomas (2005-2015)' started by l_prettyman, Mar 11, 2010.

  1. Mar 11, 2010 at 6:25 PM
    #1
    l_prettyman

    l_prettyman [OP] Well-Known Member

    Joined:
    Feb 5, 2010
    Member:
    #30789
    Messages:
    515
    Gender:
    Male
    First Name:
    Logan
    Easton Shore Maryland
    Vehicle:
    06 4x4 SR5
    12% tint, Leer cap, Pioneer Avh3100DVD headunit, Kinetik 2000 battery, Memphis pr1.1000 amp, Pioneer subwoofer(not sure what kind), Back-up Camera, PA/CB system
    what are some tips or tricks on getting the rest of the outline from around the old letters to go away? i have an 06 so i guess the sun has faded around the stickers and emblems. also there is a black ring almost as a template around the old letters on my pant. i used soapy water and goo-gone, but still black outline. help please
     
  2. Mar 11, 2010 at 6:26 PM
    #2
    JM76

    JM76 Ride On

    Joined:
    Dec 3, 2007
    Member:
    #3695
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Jon
    SC
    Vehicle:
    06 silver double cab 4x4
    seconday air filter removal, tw sticker afe pro dry s filter , black rims , cb radio with four foot firestik antenna,black nasta nerf bars,5100's in the rear,mp3 player hookup,led overhead light,5100's up front @ 1.75, rear AAL,custom dent package,blacked out rear bumper, blacking out front grille,camo gt seat covers , 6k HIDs, 6k fogs coming, devil horns grille mod,elite offroad aluminum bumper,Canadoshi grille mod.light bar behind the grille with bright lights coming sooner or later
    I used turtle wax cleaner/polish, worked for me.
     
  3. Mar 11, 2010 at 6:28 PM
    #3
    topgun155

    topgun155 Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11728
    Messages:
    2,774
    Gender:
    Male
    First Name:
    Zack
    Richmond, TX or College Station, TX
    Vehicle:
    08 Prerunner V6 Black
    Viper Alarm, In Pro Car Wear L.E.D. Tail Lights, Fog Lights, ScanGuageII, AvidOffroad Light Bar, Ammo Box Mod, Tailgate Theft Prevention Mod, Satoshi Grill, Hella 500ff behind the grill, blendmount, Cruise Control Mod, Fog Light Mod, 5100's @1.75, Toytec TSB AAL 1.5".
    I don't think there is a way to make that go away. Try some rubbing compound. Other than that I can only think of repainting it.
     
  4. Mar 11, 2010 at 6:31 PM
    #4
    l_prettyman

    l_prettyman [OP] Well-Known Member

    Joined:
    Feb 5, 2010
    Member:
    #30789
    Messages:
    515
    Gender:
    Male
    First Name:
    Logan
    Easton Shore Maryland
    Vehicle:
    06 4x4 SR5
    12% tint, Leer cap, Pioneer Avh3100DVD headunit, Kinetik 2000 battery, Memphis pr1.1000 amp, Pioneer subwoofer(not sure what kind), Back-up Camera, PA/CB system

    recommended wax? and should i use a buffer or by hand?
     
  5. Mar 11, 2010 at 6:33 PM
    #5
    l_prettyman

    l_prettyman [OP] Well-Known Member

    Joined:
    Feb 5, 2010
    Member:
    #30789
    Messages:
    515
    Gender:
    Male
    First Name:
    Logan
    Easton Shore Maryland
    Vehicle:
    06 4x4 SR5
    12% tint, Leer cap, Pioneer Avh3100DVD headunit, Kinetik 2000 battery, Memphis pr1.1000 amp, Pioneer subwoofer(not sure what kind), Back-up Camera, PA/CB system
    i also took off the "trd off road" side stickers and think it looks pretty BA. anyone else done this without replacing them?
     
  6. Mar 11, 2010 at 6:34 PM
    #6
    NWtacoma

    NWtacoma Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18142
    Messages:
    1,685
    Gender:
    Male
    Kent,WA
    Vehicle:
    2011 TRD Sport 4x4
    265/70/17 bfg AT
    works wonders

    [​IMG]
     
  7. Mar 11, 2010 at 6:35 PM
    #7
    eskamo23

    eskamo23 Well-Known Member

    Joined:
    Oct 17, 2009
    Member:
    #24463
    Messages:
    389
    Gender:
    Male
    Pasadena, CA
    Vehicle:
    trd sport
    TRD cai with (AFE dry flow filter), de-flapped, tint, weathertech floor liners,coverking neoprene seat covers, rear TSB, Billy 5100's set at 1.75'', Pro Comp 7005's 17x8 BS4.5, any time fogs, tailgate theft mod, led lights in the int., slim cubby HID headlights and fogs, TRD skid plate, bed mat
    try using 3M rubbing compound with a good high speed buffer, then wax it up. should help it out
     
  8. Mar 11, 2010 at 6:36 PM
    #8
    NWtacoma

    NWtacoma Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18142
    Messages:
    1,685
    Gender:
    Male
    Kent,WA
    Vehicle:
    2011 TRD Sport 4x4
    265/70/17 bfg AT
    go you!
     
  9. Mar 11, 2010 at 6:37 PM
    #9
    l_prettyman

    l_prettyman [OP] Well-Known Member

    Joined:
    Feb 5, 2010
    Member:
    #30789
    Messages:
    515
    Gender:
    Male
    First Name:
    Logan
    Easton Shore Maryland
    Vehicle:
    06 4x4 SR5
    12% tint, Leer cap, Pioneer Avh3100DVD headunit, Kinetik 2000 battery, Memphis pr1.1000 amp, Pioneer subwoofer(not sure what kind), Back-up Camera, PA/CB system
    my dad was talking about some kind of thing you put on a drill and it erased it. im guessing its like a buffer but for a drill?
     
  10. Mar 11, 2010 at 6:41 PM
    #10
    l_prettyman

    l_prettyman [OP] Well-Known Member

    Joined:
    Feb 5, 2010
    Member:
    #30789
    Messages:
    515
    Gender:
    Male
    First Name:
    Logan
    Easton Shore Maryland
    Vehicle:
    06 4x4 SR5
    12% tint, Leer cap, Pioneer Avh3100DVD headunit, Kinetik 2000 battery, Memphis pr1.1000 amp, Pioneer subwoofer(not sure what kind), Back-up Camera, PA/CB system

    indeed it was an eraser wheel. i couldnt remember what he called it. do those work well?
     
  11. Mar 11, 2010 at 6:41 PM
    #11
    DeathBound

    DeathBound Well-Known Member

    Joined:
    Jan 1, 2010
    Member:
    #28571
    Messages:
    117
    Gender:
    Male
    First Name:
    Jay
    Mississippi Gulf Coast
    Vehicle:
    2010 Tacoma SR5 4X4
    He's talking about making the unfaded paint match the rest of the truck.
     
  12. Mar 11, 2010 at 6:42 PM
    #12
    l_prettyman

    l_prettyman [OP] Well-Known Member

    Joined:
    Feb 5, 2010
    Member:
    #30789
    Messages:
    515
    Gender:
    Male
    First Name:
    Logan
    Easton Shore Maryland
    Vehicle:
    06 4x4 SR5
    12% tint, Leer cap, Pioneer Avh3100DVD headunit, Kinetik 2000 battery, Memphis pr1.1000 amp, Pioneer subwoofer(not sure what kind), Back-up Camera, PA/CB system

    correct
     
  13. Mar 11, 2010 at 6:43 PM
    #13
    747

    747 function > form

    Joined:
    Jan 27, 2008
    Member:
    #4465
    Messages:
    3,000
    Gender:
    Male
    Vehicle:
    1st Gen.
    I've heard good things about these...action pic is scary though.:eek:
     
  14. Mar 11, 2010 at 6:44 PM
    #14
    Cars0n`

    Cars0n` Well-Known Member

    Joined:
    Sep 8, 2008
    Member:
    #9091
    Messages:
    1,430
    Gender:
    Male
    First Name:
    Carson
    Edmonton AB
    Vehicle:
    07 2wd access cab base.
    Kenwood DDX-512 Deck, Boston Acoustics G5 Sub in Ported Bassworx Box, Kenwood eXcelon KAC-X10D Amp, Sirius Satellite Radio, Magellan GPS, DDM 55w bi-xenon headlights, 2 HID Hella 500ff's mounted behind grill, 4 pc ebay Billet grill, Fog Lights (my truck didnt have them stock), Pioneer Speakers 6x9's(front) 6.5's(rear) AFE Cold Air Intake, Hose Clamp Mod, Tailgate Strengthen Mod, Removed Gay Mud Flaps, De-Badged, BHLM, 245/45/20 on velocity wheels. VW865a, Extra D Rings In Box, OEM Cruise Added Optima Red Top Battery
    mines an 07 and i just debadged mine. i just used the heat gun and fishing line method, after that i used goo gone and let it sit for about five mins then scrubbed the shit outta the glue/adhesive that was there. i had no fading.
     
  15. Mar 11, 2010 at 6:45 PM
    #15
    DeathBound

    DeathBound Well-Known Member

    Joined:
    Jan 1, 2010
    Member:
    #28571
    Messages:
    117
    Gender:
    Male
    First Name:
    Jay
    Mississippi Gulf Coast
    Vehicle:
    2010 Tacoma SR5 4X4
    He has already removed all the tape and glue, needs a suggestion on getting the none faded paint to match the rest of the truck. Read before you post....it helps.
     
  16. Mar 11, 2010 at 6:47 PM
    #16
    l_prettyman

    l_prettyman [OP] Well-Known Member

    Joined:
    Feb 5, 2010
    Member:
    #30789
    Messages:
    515
    Gender:
    Male
    First Name:
    Logan
    Easton Shore Maryland
    Vehicle:
    06 4x4 SR5
    12% tint, Leer cap, Pioneer Avh3100DVD headunit, Kinetik 2000 battery, Memphis pr1.1000 amp, Pioneer subwoofer(not sure what kind), Back-up Camera, PA/CB system

    yea i used a heat gun, then took a screw driver (didn't touch the paint of course) and used my other hand to pull away from the truck. heated it some more and then pulled the extra adhesive off. soap and water to clean the dirt and then goo-gone. and :( fading
     
  17. Mar 11, 2010 at 6:49 PM
    #17
    747

    747 function > form

    Joined:
    Jan 27, 2008
    Member:
    #4465
    Messages:
    3,000
    Gender:
    Male
    Vehicle:
    1st Gen.
    Everyone watch out...DeathBound is on thread patrol. ONLY RESPOND TO WHAT'S BEING ASKED, MOFOS!:D
     
  18. Mar 11, 2010 at 6:49 PM
    #18
    surfrat

    surfrat Well-Known Member

    Joined:
    Feb 18, 2010
    Member:
    #31635
    Messages:
    403
    Gender:
    Male
    LI, NY
    icon coilover, total chaos UCA, allpr expo, icon 2.0 rear,wet okole
    3m rubbing compound
     
  19. Mar 11, 2010 at 6:50 PM
    #19
    DeathBound

    DeathBound Well-Known Member

    Joined:
    Jan 1, 2010
    Member:
    #28571
    Messages:
    117
    Gender:
    Male
    First Name:
    Jay
    Mississippi Gulf Coast
    Vehicle:
    2010 Tacoma SR5 4X4
    Sorry didn't mean to sound like I did, just trying to help.
     
  20. Mar 11, 2010 at 6:52 PM
    #20
    747

    747 function > form

    Joined:
    Jan 27, 2008
    Member:
    #4465
    Messages:
    3,000
    Gender:
    Male
    Vehicle:
    1st Gen.
    Just jokin' man...;)
     
To Top