1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Fixed fan blower motor clicking

Discussion in '2nd Gen. Tacomas (2005-2015)' started by little red, Jun 25, 2011.

  1. Jun 25, 2011 at 9:20 AM
    #1
    little red

    little red [OP] Well-Known Member

    Joined:
    May 30, 2011
    Member:
    #57460
    Messages:
    135
    Gender:
    Male
    Central GA
    Vehicle:
    PreRunner SR5
    Mine never did the squeeking bit however the loud clicking has been driving me crazy. I took it apart and cleaned it like the sticky post talked about but that didn't help. Then I noticed the brushes had sharp edges when I took it back apart. Where they are worn up against the motor. I took a small jewelers file (flat on one side and half round on the other) and gently filed down the rough edges and smoothed out the part that contacts the motor. Put it back together and NO MORE CLICKING. Hurrah....at least until it wears down again :D
     
  2. Jun 25, 2011 at 3:32 PM
    #2
    knayrb

    knayrb Well-Known Member

    Joined:
    Mar 3, 2010
    Member:
    #32473
    Messages:
    972
    Gender:
    Male
    Somewhere in the square states
    Vehicle:
    2010 Dbl-Cab Off-Road
    Pure stock
To Top