1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Frame Rust on your second gen

Discussion in '2nd Gen. Tacomas (2005-2015)' started by macgyver, Nov 6, 2009.

  1. Nov 6, 2009 at 6:43 AM
    #1
    macgyver

    macgyver [OP] Well-Known Member

    Joined:
    Aug 14, 2009
    Member:
    #21173
    Messages:
    3,590
    Gender:
    Male
    First Name:
    Brad
    Canton, GA
    Vehicle:
    '13 Tundra double cab SR5 4x4
    Has anyone else had any frame rust on their 2nd gen?

    I noticed a little bit on my 07 DC recently on the backside of the frame where it attaches to the body right behind the front wheel. fortunately they were small spots. I'm assuming this is from the previous owner parking the vehicle outside in the elements. But it still seems weird because I live in GA and cars take a long time to rust here. I inspected the rest of the frame and didnt see anything else.

    It was just surface rust so I sanded it off, shot it with some primer sealer, then coated it with some spray on bedliner along with the rest of the frame rails so it wont rust again. I park it in the garage and keep it extremely clean so I dont think it will pop back up.

    I am paranoid about rust so this bothered me. My last car was a 97 accord with 210,000 miles without a single spot of rust anywhere.
     
To Top