1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Front end squeak

Discussion in '2nd Gen. Tacomas' started by 08_TACO_offroad, Jul 13, 2009.

  1. Jul 13, 2009 at 5:33 PM
    #1
    08_TACO_offroad

    08_TACO_offroad [OP] Well-Known Member

    Joined:
    Feb 19, 2008
    Member:
    #4820
    Messages:
    79
    Gender:
    Male
    First Name:
    Jacob
    Greenville, NC
    Vehicle:
    08 Tacoma SR5 V6 Automatic
    265/70/17 Mickey Thompson Baja ATZ, 17 inch Mickey Thomson Classic II Wheels. UWS tool box. TRD CAI. 3" suspension lift.
    i have a 08 tacoma 4x4, and there is this horrible squeak in the front driver side. I can hear it when i go over bumps, drive slow, and even getting in and out of the truck. It is really really annoying. I figured out where the squeak is coming from. I'm pretty sure it is coming from the bushing at the bottom of the strut. I was just wondering if anyone else has had this problem as well. Also, how did you go about fixing it so that it doesn't squeak for more that a few days?
     
  2. Jul 14, 2009 at 3:41 AM
    #2
    TRDKenE

    TRDKenE DAMN GOOD DEAL!!

    Joined:
    Jul 6, 2009
    Member:
    #19348
    Messages:
    706
    Gender:
    Male
    First Name:
    Kenny
    Richmond, Virginia
    Vehicle:
    '10 D-CAB OFF-ROAD 4X4
    TRD CAI, GrillCraft.
    Dealership:notsure:.....not busting your balls just sayin.
     
  3. Jul 14, 2009 at 6:18 AM
    #3
    easttexascat

    easttexascat Christ died for you...

    Joined:
    Apr 20, 2009
    Member:
    #16194
    Messages:
    31
    Gender:
    Male
    East Texas
    Vehicle:
    2009 DCLB TRD Sport - Silver Streak Mica
    Toytec 3" Spacer/Rear AAL Lift with Diff-Drop, OME N182 Rear Shocks, TRD All-Weather Floor Mats, Sway Bar removed, TRD CIA
    Look and see if the top of the Sway Bar is rubbing on the bottom of the strut. Seems to be a common problem with a 3" lift. Mine was doing it, so I finally just took my sway bar off. You can also buy drop-kits for the sway bar that is supposed to move it out of the way.
     
  4. Jul 14, 2009 at 11:50 PM
    #4
    sincitytaco

    sincitytaco Well-Known Member

    Joined:
    Oct 16, 2008
    Member:
    #10011
    Messages:
    868
    Gender:
    Male
    Las Vegas
    Icons, Bilstein 5100, Rear Leaf TSB, 17x9 American Racing Chamber Teflon, 275/70/17 Goodyear
    Mine did do it horribly for a couple weeks, but then went away. I do have Icons though and figured it was a bushing. I just sprayed the bushing with WD40 and after a few days it quit. I am not even sure that is what squeaked because I figure the WD40 should have worked immediately in that case.
     
  5. May 26, 2010 at 5:44 PM
    #5
    nickbroaddus

    nickbroaddus Active Member

    Joined:
    Feb 21, 2009
    Member:
    #13888
    Messages:
    34
    Gender:
    Male
    Boston
    Vehicle:
    06 trd sport acc cab prerunner
    new headlights, 3" lift, K&N CAI, URD shortshifter, 2 10"mtx subs,
    i have the same problem. have a friend bounce the drivers side and push and pull on the sway bar- thats how i isolated it, im not sure how to fix it though, maybe grease the bushings- i dont see any zerk fitting tho.
     
To Top