1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Front Vibe after Lift

Discussion in '2nd Gen. Tacomas (2005-2015)' started by fatsac, Nov 12, 2010.

  1. Nov 12, 2010 at 4:05 PM

    fatsac [OP] Well-Known Member

    Oct 18, 2010
    First Name:
    Millbury, MA
    07 Tacoma DC Offroad
    Katz Leather, heated seats, Tint, KN Filter, OME 887, Camburg UCA, Dakar packs, 17x9 XD, 295/70 Toyo MT w cab mount chop, fender massage, Weathertechs, Black PC steps, skidplate, 2012 grill, Bushwacker painted flares, Nearly every TSB you can think of, TRD quickshift, All-Pro front w/ Skids, 9k winch, Tonneau cover, voodoo tailgate cap...
    Well, I opted for a Truxxx spacer lift for now and am actually very pleased with the ride and alignment. Everything is exactly as before accept one issue: Front end vibration from 25 to 45 or so. It goes away in 4 wheel drive but comes back once back in 4x2.
    Could this be a bad bearing? I am only at 34k and thankfully within warranty still.
    Will they repair or claim void due to lift? The truck has maybe 30 miles with the kit in place.
    Thanks in advance for the advice. I've learned a ton from this site!
To Top