1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Front view of the motor with out timing belt cover

Discussion in '1st Gen. Tacomas (1995-2004)' started by 1999tacotrd, May 25, 2009.

  1. May 25, 2009 at 11:06 PM
    #1
    1999tacotrd

    1999tacotrd [OP] 1999 Taco TRD xtracab 3.4 V6 4x4

    Joined:
    Apr 19, 2009
    Member:
    #16160
    Messages:
    145
    Gender:
    Male
    Hi dose any one have any pics of the front of the motor on a 1999 V6 tacoma with the timming belt cover complety off? I can seem to find any, I got something rubbing behind the cover and im trying to figer out what all is behind it so i can tell what i need to replace. It sounds like its comeing from the top of the motor not the bottom so im thinking its a pully
     
  2. May 25, 2009 at 11:08 PM
    #2
    wildjerseyfirefighter

    wildjerseyfirefighter I sell fishing and fishing accessories

    Joined:
    Dec 17, 2008
    Member:
    #11677
    Messages:
    7,958
    Gender:
    Male
    First Name:
    Joe
    NJ
    Vehicle:
    05 Tacoma TRD Sport
    stock, for now
    how many miles?
     
  3. May 26, 2009 at 3:24 AM
    #3
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,256
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
  4. May 26, 2009 at 9:07 AM
    #4
    1999tacotrd

    1999tacotrd [OP] 1999 Taco TRD xtracab 3.4 V6 4x4

    Joined:
    Apr 19, 2009
    Member:
    #16160
    Messages:
    145
    Gender:
    Male
    From what i can tell from the picture theres 2 pullys water pump to cam gears and main shaft. Do u think it could be the water pump? it is hella loud but there is no water leaking.

    i might replace it as well as the 2 pullys just in case

    the motor has 194k miles on it
     
To Top