1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Frustrated

Discussion in 'Technical Chat' started by newby95, Nov 9, 2010.

  1. Nov 9, 2010 at 1:33 PM
    #1
    newby95

    newby95 [OP] New Member

    Joined:
    Jun 15, 2010
    Member:
    #38994
    Messages:
    4
    Gender:
    Male
    I just registered my 07 prerunner on the toyota website. I was looking through the maintenance that my truck had before I bought it. As I was looking through I found where the dealer replaced the valve cover gasket at like 34,000 miles. I am so frustrated with toyota right now. They put the wrong fluid in my differential the last time I took it and now this. I guess this is what I get for depending on a brand that used to be dependable.

    Anybody have information on if this is serious or what should I do. The truck runs great and doesnt smoke at all. Also, can someone tell with a direct answer if I need to have my transmission serviced. It has 49,000 miles on it and I never tow or drive truck hard.

    Thank you guys and girls for your help. Sorry for the rant:mad:
     
  2. Nov 9, 2010 at 1:54 PM
    #2
    Chachie

    Chachie Well-Known Member

    Joined:
    Dec 23, 2009
    Member:
    #28047
    Messages:
    1,849
    Gender:
    Male
    First Name:
    Justin
    Nor Cal
    Vehicle:
    '06 TRD OR, 4x4, Auto, 6" Fabtech, 35's
    Locker mod, Anytime fog mod, always 400w mod.
    A valve cover gasket is not a big deal at all. Could have needed to be replaced because there was a defect in the gasket that caused it to leak. We seeit about 1 in every 10-20 we put on our race car.
     
  3. Nov 9, 2010 at 1:59 PM
    #3
    Pingo

    Pingo Well-Known Member

    Joined:
    Jul 8, 2008
    Member:
    #7826
    Messages:
    460
    Gender:
    Male
    North Pole, AK
    Vehicle:
    2014 S/C TRD Offroad A/C
    "I guess this is what I get for depending on a brand that used to be dependable."
    "The truck runs great and doesn't smoke at all"

    Sounds like your fine.
     
  4. Nov 9, 2010 at 2:02 PM
    #4
    BakoTruck

    BakoTruck Well-Known Member

    Joined:
    May 1, 2009
    Member:
    #16674
    Messages:
    2,823
    Gender:
    Male
    First Name:
    Herbie Hancock
    Bakersfield, CA
    Vehicle:
    05 PreRunner TRD
    Mostly stock for now, I have added a cb radio, various cheap mods and I plan on adding aftermarket wheels and other items in the future.
    OH NO! A valve cover gasket! :goingcrazy:

    It's not a big deal, it's just a bad gasket. It didn't or will not cause any problems down the road to any part of your engine.

    Sometimes things like this happen, they fixed it, it's all good to go......enjoy your truck.
     
To Top