1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

ghetto body lift

Discussion in 'Suspension' started by mountainwolfpup, Nov 19, 2011.

  1. Nov 19, 2011 at 10:24 PM
    #1
    mountainwolfpup

    mountainwolfpup [OP] Ford Guy (Formerly known as a Toyota Guy)

    Joined:
    Jan 1, 2009
    Member:
    #12116
    Messages:
    979
    Gender:
    Male
    Vancouver, WA
    Vehicle:
    2015 Ford F150 Lariat FX4 3.5l Eco
    First month of ownership... This month I'm removing front air dam, and also Rhino lining the bed.
    My story.

    Put an ARB bumper and Warn winch up front, with appropriate OME shocks/springs. With use bumper seems to have sagged slightly. R&R bumper to no avail, so noticed two bolts in engine compartment that attach front body to frame. Pulled those bolts and took a pet bar to lift body from frame, inserted several washers on each side between frame and body and reinserted bolts. Probably got a 1/4in lift. Enough to raise front quarter panels from rubbing on bumper.

    Anyone see anything wrong with this?

    BTW, damn thing is now settling back and soon problem will return. Might have to cut away at my quarter panels just aft of the wheel Wells? Any suggestions?
     
  2. Nov 20, 2011 at 10:27 AM
    #2
    KPT

    KPT sees what you did there.

    Joined:
    Sep 3, 2009
    Member:
    #22227
    Messages:
    32,340
    Gender:
    Male
    Vehicle:
    09 Prerunner
    Katskin leather interior, Satoshi grille, Bilstein 5100's @ 1.75, rear leaf TSB, magnaflow exhaust, 18x9 BBS RW's, 275/65/18 Nitto TG's, black headlights, black taillights, Hella Supertones, weathertechs, EFX tri-fold tonneau, n-Fab steps
    Free bump
     
To Top