1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Got the TSB today

Discussion in 'Suspension' started by raswank, Sep 23, 2010.

  1. Sep 23, 2010 at 12:21 PM

    raswank [OP] Well-Known Member

    Aug 1, 2010
    First Name:
    2010 Tacoma Double Cab 4x4 6 speed
    Grillcraft, Rear leaf TSB, 5100's at .85, with Eibachs, 265/70/17 BF Goodrich AT/S Tires, Hella 500's behind Grill, Kenwood KDC X995 H/U all Boston Acoustic speakers, JL Audio subs, Kenwood XR5 S amp, ATX Chrome 17x8 wheels
    Nice ride, didn't lift the back up that much. So I will let it settle before I do the Billie's. The Service Manager told me they have known since 2005 when they made the second gen. They would need to replace the rear leafs. They also did the gas pedal recall. And some type of brake pedal, gas pedal recall. He said if you press the brake and gas at the same time, they would both work. So they reprogrammed the computer. I asked him if he knew anything about the 6 speed manuals having throw out baring problems. He had no clue. Anyway nice ride, but they did not set the steering wheel straight on the alignment, even though I asked him if they did. So now I have to take the hour trip there, and back. And I am going to make them fill my tank.
To Top