1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Half my speedometer is lit up; other half not

Discussion in 'Lighting' started by FullaSheet, May 26, 2011.

  1. May 26, 2011 at 5:35 AM
    #1
    FullaSheet

    FullaSheet [OP] Member

    Joined:
    Jan 20, 2011
    Member:
    #49610
    Messages:
    6
    Gender:
    Male
    First Name:
    Dave
    Swanton, OH
    Vehicle:
    '04 Tacoma 4X2 4cyl 5spd
    My '04 Tacoma. I rarely drive after dark but, last night I had to. I've never seen this before: I turn the lights on and the left side of the dash lights seems to have been burnt out. I can see the speedometer but, the left portion is burnt out or simply not functioning. It's kinda weird. Is there any way I can get a new bulb for this light? It seems a bit strange driving with only half of the speedometer lit up. Anyone have any suggestions? Thank you! All my other lights; headlights, taillights are working fine. :confused:
     
  2. May 26, 2011 at 6:05 AM
    #2
    medic2230

    medic2230 Ditch Doctor

    Joined:
    Oct 13, 2008
    Member:
    #9942
    Messages:
    26,541
    Gender:
    Male
    First Name:
    Murph
    Bama! Roll Tide
    Vehicle:
    2011 Taco 4x4 DCLB
    20% Tint, OME 3"complete lift with Dakar's, Light Racing UCA's, 285/75/16 Nitto Terra Grapplers, 10 HP TW sticker, Ultraguage, B.A.M.F. Rock Sliders, MedicFab Bed Rack, Relentless front bumper
  3. May 26, 2011 at 2:15 PM
    #3
    FullaSheet

    FullaSheet [OP] Member

    Joined:
    Jan 20, 2011
    Member:
    #49610
    Messages:
    6
    Gender:
    Male
    First Name:
    Dave
    Swanton, OH
    Vehicle:
    '04 Tacoma 4X2 4cyl 5spd
    that's real nice but, I was trying to find out how much of a job it would be to change one (or, both if there are two) of the speedometer light-up bulbs. thanks
     
  4. May 26, 2011 at 2:17 PM
    #4
    ckeeton

    ckeeton Bazinga

    Joined:
    Sep 7, 2010
    Member:
    #42853
    Messages:
    1,550
    Gender:
    Male
    First Name:
    Chris
    Duluth, GA
    Vehicle:
    2011 DC Trd Sport Gray
    trd sport with avid off road light bar, avid rock sliders. OEM roof rack, 12' LED light bar, and Sock monkey decals.
  5. May 27, 2011 at 1:56 AM
    #5
    FullaSheet

    FullaSheet [OP] Member

    Joined:
    Jan 20, 2011
    Member:
    #49610
    Messages:
    6
    Gender:
    Male
    First Name:
    Dave
    Swanton, OH
    Vehicle:
    '04 Tacoma 4X2 4cyl 5spd
    thank you very much! you did an excellent job of explaining things!
     
  6. May 27, 2011 at 2:00 AM
    #6
    '02TRD

    '02TRD Well-Known Member

    Joined:
    Jul 20, 2010
    Member:
    #40475
    Messages:
    375
    Gender:
    Male
    First Name:
    Jason
    Portland, OR
    Vehicle:
    2002 Tacoma Xtra Cab 4x4 SR5 TRD
    Billstein 5100's & AAL, 285/75R16 Toyo Open Country M/Ts on Black 16x8 Raceline Renegades, Pro-Tech Toolbox, Wet Okole covers, K&N air filter, Tow package, Alpine digital media receiver, Kenwood Amp, Rockford Fosgate 10" sub, Cobra 75 hand held CB, front differential drop
    there are four red lights that illuminate the the dash when the lights are on. they cost around 8 dollars each from toyota. very simple to change but does take some time. Just tear down the dash starting with the center stereo location, working your way toward the drivers side.
     
  7. May 28, 2011 at 5:17 AM
    #7
    FullaSheet

    FullaSheet [OP] Member

    Joined:
    Jan 20, 2011
    Member:
    #49610
    Messages:
    6
    Gender:
    Male
    First Name:
    Dave
    Swanton, OH
    Vehicle:
    '04 Tacoma 4X2 4cyl 5spd
    thanks for all the pointers! I really appreciate it. fortunately, it's not an emergency because I have way too many of those going right now. will attempt when I get squared away..thanks again
     
  8. Jun 1, 2011 at 4:48 PM
    #8
    NegroTundra

    NegroTundra Well-Known Member

    Joined:
    Oct 25, 2010
    Member:
    #45227
    Messages:
    652
    Gender:
    Male
    Land of Enchantment
    Vehicle:
    03 Tacoma TRD 4WD 5 spd
    You know...i had this same problem right after I did the steering shaft mod (which requires you to dissamble the whole steering column area, steering wheel off and all). When I would beat the dash it would come back on but only for the duration of the drive; soon as I turned vehicle off then back on I'd have a halfy-dash again. Found a wire, IIRC a green with white stripe wire, behind the guages that had fallen off. Its attached by a quite pathetic connector, soon as I reattached and crimped so it wouldnt fall off again I've had no problems. However, I still ponder that my truck has gremlins given that the wire was completely loose, no where near the connection, why would they come on when I'd slam the dash. Weird. But true story. Good luck.
     
To Top