1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Headlight Wiring Diagram Needed

Discussion in '1st Gen. Tacomas (1995-2004)' started by LoriB01, Oct 12, 2018.

  1. Oct 12, 2018 at 4:03 PM
    #1
    LoriB01

    LoriB01 [OP] Member

    Joined:
    Apr 30, 2013
    Member:
    #103211
    Messages:
    23
    Gender:
    Female
    First Name:
    Lori
    Atlanta
    Vehicle:
    99 Tacoma 4 cyl, 2.7, 4x4, manual
    Does anyone have a headlight diagram for '99 Tacoma?

    My headlights don't work except when I pull back the stalk (flash). I have replaced the bulbs, relay, and controller. The fuses are good, the relay clicks, no headlights.

    Thanks
     
  2. Oct 12, 2018 at 4:09 PM
    #2
    jbrandt

    jbrandt ......LOADING

    Joined:
    Feb 12, 2011
    Member:
    #51038
    Messages:
    14,082
    Gender:
    Male
    First Name:
    Justin
    Sacramento, CA
    Vehicle:
    '04 TRD Tacoma 4x4 DC
    Kings, J59's Total Chaos UCAs Custom skids Sticker mod
    might be your switch
     
  3. Oct 12, 2018 at 4:12 PM
    #3
    LoriB01

    LoriB01 [OP] Member

    Joined:
    Apr 30, 2013
    Member:
    #103211
    Messages:
    23
    Gender:
    Female
    First Name:
    Lori
    Atlanta
    Vehicle:
    99 Tacoma 4 cyl, 2.7, 4x4, manual
    I changed that out, the part was called a controller so that's what I called it but, yes, it's a switch. Sorry to be confusing.
     
  4. Oct 12, 2018 at 4:33 PM
    #4
    Mulepadre

    Mulepadre Mulepadre

    Joined:
    Jan 2, 2014
    Member:
    #119686
    Messages:
    664
    Gender:
    Male
    Central Arkansas
    Vehicle:
    2003 Std Cab 2.7L 4x4
    Bilstein 5100s, Deaver Leaf Springs, JBA UCAs
  5. Oct 12, 2018 at 5:33 PM
    #5
    LoriB01

    LoriB01 [OP] Member

    Joined:
    Apr 30, 2013
    Member:
    #103211
    Messages:
    23
    Gender:
    Female
    First Name:
    Lori
    Atlanta
    Vehicle:
    99 Tacoma 4 cyl, 2.7, 4x4, manual
    Thank you very much. No DRL, I should have specified. I'll get to troubleshooting this weekend.
     
  6. Oct 12, 2018 at 5:44 PM
    #6
    LoriB01

    LoriB01 [OP] Member

    Joined:
    Apr 30, 2013
    Member:
    #103211
    Messages:
    23
    Gender:
    Female
    First Name:
    Lori
    Atlanta
    Vehicle:
    99 Tacoma 4 cyl, 2.7, 4x4, manual
    If I'm reading this correctly the Red with White wire should be hot. I borrowed a multimeter from a neighbor and checked the wires at the switch. They all show ground with little resistance (assuming I'm using the tool correctly). The red with white stripe goes hard to the right on the meter (analog). So, to be clear, I can't get the meter to read 0 on the ohms scale, it stops at 3.5 when I've got the probes touching. Most of the wires that show anything are between 3.5 and 4 on the ohm meter, the red/white wire pegs to 0.

    So would I be correcting in looking for a short on that wire?

    It seems wrong to me that the relay would sound like it's working if that wire was shorted.
     
  7. Oct 12, 2018 at 7:00 PM
    #7
    Mulepadre

    Mulepadre Mulepadre

    Joined:
    Jan 2, 2014
    Member:
    #119686
    Messages:
    664
    Gender:
    Male
    Central Arkansas
    Vehicle:
    2003 Std Cab 2.7L 4x4
    Bilstein 5100s, Deaver Leaf Springs, JBA UCAs
    Dont ask me LOL! Keep bumping...
     

Products Discussed in

To Top