1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

HELP!! 06 taco .. Piss poor mpg on 2.7L

Discussion in '4 Cylinder' started by SilverTac, Mar 12, 2011.

  1. Mar 12, 2011 at 7:29 PM
    #1
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    Please help me out Guys...
    I have a 06 tacoma prerunner 2.7L ,4 x 2, manual trans. 38,000 miles on it factory size tires.. all stock truck. I get 15 mpg or less on I-10 doing 70 - 75 mph and no a/c on either. It also idles at 2,400 rpms in the morning for 30 sec or so. I live in new orleans and it aint cold here. When doing 70 its running 2,700 rpms in 5th gear, is that too high? Is ALL this normal for this truck?????


    Thanks

    Jason
     
  2. Mar 12, 2011 at 7:43 PM
    #2
    brow

    brow Well-Known Member

    Joined:
    Apr 4, 2010
    Member:
    #34580
    Messages:
    376
    Gender:
    Male
    First Name:
    Andy
    Minnesota
    Vehicle:
    '10 silver access 4x4, that'll never be done
    switched rear-view camera, custom access cab bench, tonneau cover, custom bike rack in bed, extra d-rings, de-badged, mag lite mount, weathertechs, bed lights with 3-way switches, rear spring TSB, ultra gauge, after market hitch, cab/hitch mounted canoe rack
    2700 at 70 is pretty normal for my truck in 5th. The rest I'm worthless on, hopefully someone else will chime in
     
  3. Mar 12, 2011 at 7:59 PM
    #3
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    I hope so.. :)
     
  4. Mar 12, 2011 at 8:04 PM
    #4
    Yoytoda

    Yoytoda The Little Truck That Could

    Joined:
    Oct 2, 2009
    Member:
    #23690
    Messages:
    4,949
    Gender:
    Male
    First Name:
    Roland
    Big Bear,CA / Upstate NY(Saratoga)
    Vehicle:
    2010 Tacoma Regular Cab 4x4
    completely stock
    i dont think 15mpg is reasonable at all...


    OP what maintenance have you done?
     
  5. Mar 12, 2011 at 8:07 PM
    #5
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    My foot aint the problem.. Ive read several threads with the same idle problem and same poor gas mileage and no one on here has a decent answer.. obviously theres a problem and its not the drivers.
     
  6. Mar 12, 2011 at 8:09 PM
    #6
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    Just a oil change and air filter every 3500 miles
     
  7. Mar 12, 2011 at 8:10 PM
    #7
    Yoytoda

    Yoytoda The Little Truck That Could

    Joined:
    Oct 2, 2009
    Member:
    #23690
    Messages:
    4,949
    Gender:
    Male
    First Name:
    Roland
    Big Bear,CA / Upstate NY(Saratoga)
    Vehicle:
    2010 Tacoma Regular Cab 4x4
    completely stock
    heres a decent answer. Ive been on the forum for a while and my truck has the same engine as yours. high idle in the morning when the engine is cold is normal. even if you think its warm outside its cold to your engine. i get 21mpg and i have about 400# of extra weight and oversize tires...
     
  8. Mar 12, 2011 at 8:12 PM
    #8
    Yoytoda

    Yoytoda The Little Truck That Could

    Joined:
    Oct 2, 2009
    Member:
    #23690
    Messages:
    4,949
    Gender:
    Male
    First Name:
    Roland
    Big Bear,CA / Upstate NY(Saratoga)
    Vehicle:
    2010 Tacoma Regular Cab 4x4
    completely stock
    maybe try changing the plugs?

    something doesnt seem right with your mpgs
     
  9. Mar 12, 2011 at 8:12 PM
    #9
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    Im sorry... what else should i be doing besides oil and air filter?
     
  10. Mar 12, 2011 at 8:14 PM
    #10
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    any suggestions on what type plugs
     
  11. Mar 12, 2011 at 8:17 PM
    #11
    Yoytoda

    Yoytoda The Little Truck That Could

    Joined:
    Oct 2, 2009
    Member:
    #23690
    Messages:
    4,949
    Gender:
    Male
    First Name:
    Roland
    Big Bear,CA / Upstate NY(Saratoga)
    Vehicle:
    2010 Tacoma Regular Cab 4x4
    completely stock
    its hard to say. it all depends. oil and air filter are good. most forget about the air filter...

    without driving it itd be hard to say. maybe alignment off? do you have odd tire wear?

    tire pressure

    change the rear gear oil too
     
  12. Mar 12, 2011 at 8:22 PM
    #12
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    I just bought new tires dunlop duelers same size as factory, I didnt see any odd wear on the old tires. Should i change the gear oil with only 38000 miles on engine? Tire pressure is normal or my light would go on.
     
  13. Mar 12, 2011 at 8:23 PM
    #13
    norcal4banger

    norcal4banger 11-98 MUD

    Joined:
    Jan 13, 2011
    Member:
    #49206
    Messages:
    718
    Gender:
    Male
    First Name:
    Jack
    Far Northern California
    Vehicle:
    2005 4 Cylinder 2WD 5 Lug RC Tacoma
    1900 - 2000 at 68/69mph. Thats the sweet spot on my truck and my scangauge tells me I get 23mpg at that speed/rpm ratio
     
  14. Mar 12, 2011 at 8:24 PM
    #14
    Yoytoda

    Yoytoda The Little Truck That Could

    Joined:
    Oct 2, 2009
    Member:
    #23690
    Messages:
    4,949
    Gender:
    Male
    First Name:
    Roland
    Big Bear,CA / Upstate NY(Saratoga)
    Vehicle:
    2010 Tacoma Regular Cab 4x4
    completely stock
    changing gear oil is never too soon.
     
  15. Mar 12, 2011 at 8:25 PM
    #15
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    this truck was hardly driven its a 06 and i bought it 6 months ago with only 28000 miles its imaculate.. I thought I was getting a good deal I paid 12000 for it at a dealer.
     
  16. Mar 12, 2011 at 8:28 PM
    #16
    Yoytoda

    Yoytoda The Little Truck That Could

    Joined:
    Oct 2, 2009
    Member:
    #23690
    Messages:
    4,949
    Gender:
    Male
    First Name:
    Roland
    Big Bear,CA / Upstate NY(Saratoga)
    Vehicle:
    2010 Tacoma Regular Cab 4x4
    completely stock
    your a 5lug though... gearing is different
     
  17. Mar 12, 2011 at 8:44 PM
    #17
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    this when i first got it had orginal tires on it...lol [​IMG]
     
  18. Mar 12, 2011 at 8:50 PM
    #18
    SilverTac

    SilverTac [OP] Member

    Joined:
    Oct 24, 2010
    Member:
    #45174
    Messages:
    11
    Gender:
    Male
    First Name:
    Jason
    Lousiana
    Vehicle:
    tacoma prerunner
    Should i cut out my cat converter ? Cause they dont check for that stuff in Louisana ...hahaa
     
  19. Mar 12, 2011 at 9:02 PM
    #19
    Yoytoda

    Yoytoda The Little Truck That Could

    Joined:
    Oct 2, 2009
    Member:
    #23690
    Messages:
    4,949
    Gender:
    Male
    First Name:
    Roland
    Big Bear,CA / Upstate NY(Saratoga)
    Vehicle:
    2010 Tacoma Regular Cab 4x4
    completely stock
    something sounds strange of a 2006 with 38k... especially since they sold it to you for so cheap... Maybe do a compression check. maybe the previous owner never maintained it and there is sludge buildup?
     
  20. Feb 8, 2014 at 12:37 PM
    #20
    lsg

    lsg New Member

    Joined:
    Feb 3, 2014
    Member:
    #122204
    Messages:
    2
    Gender:
    Male
    First Name:
    lsg
    Florida
    Vehicle:
    2003 Tacoma,6803 miles
    2006 Tacoma with 38,000 miles is strange? I just bought a 2003 Tacoma reg. cab with.......6803 miles! Verified; has had an oil change every year even though it didn't need it. 4 cyl. auto but was rated at 23 highway on the web site I was on. Can that be correct for a 4 cylinder?
     
To Top