1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

HELP 3.4 V6 Engine cranks but no spark or fuel....

Discussion in 'Technical Chat' started by Top That Taco, Dec 21, 2011.

  1. Dec 21, 2011 at 2:49 PM
    Top That Taco

    Top That Taco [OP] New Member

    May 26, 2011
    First Name:
    Corpus Christi, TX
    03 3.4 Supercharged Tacoma
    3" lift, 33" Mud Terrains, Fast
    Hello everyone, I have a 2003 Toyota Tacoma 3.4 V6 Supercharged with a major problem so let me cut to the chase my truck will start and somethimes it wont and now a few thousand into it I am about to give up on it. I don't even know where to begin. It started about 2 years ago I would get into it on a hot day and start it and it would sputter, chug, backfire, idling real rough to the point that it hurt me to listen to it run. I could give it about half gas and it would clear up but as soon as I let off it would slip back to the same super rough idle (shaking me and entire truck). I would then turn the truck off and wait 20-30 minutes go back and it would start fine like nothing was wrong. Now it is to the point to where I can go outside and sometimes it will start and sometimes it won't it just cranks and cranks. I can turn the truck to the on position and go open the hood and hear a sound coming from the TPS sensor reach up and roll throttle and the sound coming from TPS gets 2-3 times as lond I disconnect the wires to it and get a sound like the throttle plate dropping as if the TPS was holding it open. Plug it back in and sometimes the sounds go away and sometimes it sounds like the TPS is trying to move throttle plate then I just wait a little while (30mins. to 2 Hours) and then it will fire up no prob. ocasianally when it does finally start I lose my gas pedal meaning pressing the gas does nothing until it is to the floor so that i have a half inch from no throttle to full throttle when floored. Turn it off and then start it and it runs fine like nothing ever happened. It usually does the throttle thing after it won't start then finally does. So I took it to the dealers and had them scan it they came back with no spark no fuel also telling me it could or could not be the computer a expensive guess on their part. So new comp. and still nothing now thinking TPS so I bought a throttle body and it is doing same thing and toyota just gave me a shrug and a "don't know what to tell you". Now I am stuck with a truck that runs when it wants too not when I need it to. It has died on several ocasions just driving, wait a while and it will start. Should i look into scrapping it or can somebody help me I will not sell a burden like this to anyone and I am almost out of options. Any help would help Thank you
To Top