1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help. I can't fill gas tank.

Discussion in '1st Gen. Tacomas' started by Paulie, Aug 31, 2011.

  1. Aug 31, 2011 at 11:37 AM
    #1
    Paulie

    Paulie [OP] Well-Known Member

    Joined:
    Mar 25, 2011
    Member:
    #53682
    Messages:
    67
    Gender:
    Male
    First Name:
    Paulie
    USA
    Vehicle:
    Tacoma
    The gas pump shuts off every 1/10 gallon. The truck is an '02 w/ 49k miles. It has never been off roaded so there is no mud blocking tank breather. All vacuum lines are hooked up. I would be thankfull if any knows how to fix this.
     
  2. Aug 31, 2011 at 11:44 AM
    #2
    Sport11

    Sport11 Well-Known Member

    Joined:
    Feb 15, 2011
    Member:
    #51187
    Messages:
    619
    Gender:
    Male
    First Name:
    Matt
    Kingsport, TN
    Vehicle:
    Dodge Ram 1500
    Try a new gas station :notsure: I have had to move to another pump before over some similar experience.
     
  3. Aug 31, 2011 at 11:49 AM
    #3
    KPT

    KPT sees what you did there.

    Joined:
    Sep 3, 2009
    Member:
    #22227
    Messages:
    32,400
    Gender:
    Male
    Vehicle:
    09 Prerunner
    Katskin leather interior, Satoshi grille, Bilstein 5100's @ 1.75, rear leaf TSB, magnaflow exhaust, 18x9 BBS RW's, 275/65/18 Nitto TG's, black headlights, black taillights, Hella Supertones, weathertechs, EFX tri-fold tonneau, n-Fab steps
    Mine does that sometimes. If I hold the nozzle so it's only 3/4 as far as it will go into the tank then it fixes it.
     
  4. Aug 31, 2011 at 11:51 AM
    #4
    okboatie1

    okboatie1 Well-Known Member

    Joined:
    Jul 27, 2011
    Member:
    #60622
    Messages:
    215
    Gender:
    Male
    First Name:
    Darrell
    Chula Vista, CA.
    Vehicle:
    03 PreRunner TRD SR5 DCSB
    OME 881's w/Dakar's, Deckplate mod, Debadged, door chime mod, 12V outlets always on,
    Have problems all the time on base. Just try another pump/station before you start looking at your ride IMHO...Good luck
     
  5. Aug 31, 2011 at 12:04 PM
    #5
    jbrandt

    jbrandt Well-Known Member

    Joined:
    Feb 12, 2011
    Member:
    #51038
    Messages:
    420
    Gender:
    Male
    Sacramento, CA
    Vehicle:
    '04 TRD Tacoma 4x4
    K&N intake
    yeah, it's a pump issue, not a truck issue!

    Sometimes I have to hold the handle down for the entire tank, instead of flipping the little lever that holds the handle down, because the auto shut-off keeps tripping.

    Just fiddle with the position of the hose (pull it out a little bit, or push it in a little further), or just hold the handle. Or go to a different pump.
     
  6. Aug 31, 2011 at 6:22 PM
    #6
    Tacomadude89

    Tacomadude89 Well-Known Member

    Joined:
    Feb 6, 2010
    Member:
    #30859
    Messages:
    1,515
    Gender:
    Male
    First Name:
    Austen
    California
    Vehicle:
    2002 Tacoma TRD SR5, 3.4, 5spd
    -Bilstein 5100 Series shocks on all 4 corners -Rancho HD lift coils -1/4" Toytec driverside top plate spacer -Toytec 1" diff drop -Wheelers 1.5" AAL's -Toytec 1" lift shackles -Revtek extended length BPV bracket -285/75/16 BFG KO T/A's -Pro Comp rims -ET Conical tyle lug nuts -Spidertrax 1.5" wheel Spacers -CV Boot slide mod -TRD skid plate -Magnaflow 14" round muffler -Shortened tailpipe hidden behind framerail -Toyota bug deflector -Weathertech floormats -Black leather seat covers -Valentine 1 Radar Detector
    ;)
     
  7. Aug 31, 2011 at 6:23 PM
    #7
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,266
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    Actually it is probably the truck.
     
  8. Aug 31, 2011 at 6:25 PM
    #8
    derekabraham

    derekabraham Living vicariously through everybody

    Joined:
    Jul 8, 2008
    Member:
    #7822
    Messages:
    29,448
    Gender:
    Male
    First Name:
    TW'S Hippy Liberal
    Portland, OR
    Vehicle:
    2002 4x4 4Runner
    Stick on hood scoop from Autozone.
    Sometimes I have to hold the nozzle upside down at some stations... :confused:
     
  9. Aug 31, 2011 at 6:28 PM
    #9
    fletch aka

    fletch aka www.BeLikeBrit.org

    Joined:
    Jan 4, 2009
    Member:
    #12223
    Messages:
    7,156
    Gender:
    Male
    First Name:
    Gary
    Left Coast
    Vehicle:
    09 Magnetic Gray TRD OffRoad
    TRD cat back exhaust, TRD Cold Air Intake, differential breather mod' Hellwig rear sway bar, 16x8 TRD Ivan Stewart's, Michelin LTX A/T2, DTRL Stealth Mode Mod, custom "Texas Edition" shift knob, Sock's "Classic" bedside decals, MetalMiller custom grill emblem, 20% front tinted windows, tinted taillights, Viper alarm, ScanGauge II, Flyzeye Designs V2W Tacoma Interior LED lighting, de-mud flapped, de-badged, extra D-rings under bed bolts, WeatherTech ED floor mats, G4 Elite Fold a Cover ,Toyota bed mat, tailgate theft deterrent device and absolutely no plasti-dip!
    X1
     
  10. Aug 31, 2011 at 6:32 PM
    #10
    Gieser

    Gieser Official Flatlander

    Joined:
    Jun 17, 2010
    Member:
    #39110
    Messages:
    874
    Gender:
    Male
    MB, Canada
    Vehicle:
    06 tundra yamaha edition
    scion Head Unit and magnaflow muffler...so far
    my moms camry did this but it was alot worse. it ended up being the charcol canister. something to do with the fuel filler neck. maybe the same thing?
     
  11. Aug 31, 2011 at 6:43 PM
    #11
    98tacoma27

    98tacoma27 :POOPCORN: Thor

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,249
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    ^those^
    The fill tube design cuts off the venturi (see below)
     
  12. Aug 31, 2011 at 6:47 PM
    #12
    Urban Redneck

    Urban Redneck Well-Known Member

    Joined:
    Apr 23, 2011
    Member:
    #55408
    Messages:
    166
    Gender:
    Male
    Vehicle:
    2004 3.4L V6
    Same here. It sucks that you can't walk away from it, but this still works. It's only at some stations that it happens, tho.
     
  13. Sep 1, 2011 at 4:38 PM
    #13
    Paulie

    Paulie [OP] Well-Known Member

    Joined:
    Mar 25, 2011
    Member:
    #53682
    Messages:
    67
    Gender:
    Male
    First Name:
    Paulie
    USA
    Vehicle:
    Tacoma
    I'm going to chect out the canister. It's a truck issue. It worked fine then one day was unable to fill tank
     
  14. Jun 6, 2014 at 3:26 PM
    #14
    REvans2001

    REvans2001 New Member

    Joined:
    Jun 6, 2014
    Member:
    #131405
    Messages:
    1
    Gender:
    Male
    First Name:
    Russell
    San Marcos, CA
    Vehicle:
    2002 Taco SR5
    I had this problem after Mr. GoodWrench did oil change and air filter on my 2002 Taco. Turned out that the mech pinched a hose under the air filter cover. Took off the cover, moved the hose and replaced the cover: fixed!

    Good luck!
     
To Top