1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

HELP! level lift gone wrong!

Discussion in 'Suspension' started by gacandido2010, Oct 19, 2011.

  1. Oct 19, 2011 at 10:49 PM
    #1
    gacandido2010

    gacandido2010 [OP] Well-Known Member

    Joined:
    Nov 8, 2010
    Member:
    #45890
    Messages:
    632
    Gender:
    Male
    First Name:
    Gabriel
    Inland Empire CA
    Vehicle:
    01 Prerunner TRD
    Bilstein 5100s, Eibach Coils, All Pro Baja Leaf Pack, Fox 2.5x16", All Pro 1.5 spacers, Deckplate Mod, K&N Filter, Magna-Flow Exhaust System, Cobra Ultra Cb with 3" Firestick, 2 Hella 500 HIDs, custom mesh grill, blacked out lettering, Limo Tint, Fog Light Mod
    just installed a 3 in level lift which looks amazing but i must have fucked up installation. First off, one wheel points straight well the other points way off, like ones at 90 degress and the others at 80. Second the steering is all over the place, like if i let go of it i swings right like crazy. i seriously need some help here my fellow tw users!:confused:
     
  2. Oct 19, 2011 at 10:54 PM
    #2
    stephen11ty7

    stephen11ty7 Well-Known Member

    Joined:
    Jun 5, 2011
    Member:
    #57798
    Messages:
    493
    Gender:
    Male
    First Name:
    Stephen
    Villa Park
    Vehicle:
    07 white taco
    Total Chaos 2" LT, Icon coilovers
    did you bolt everything back up?
    sounds like a steering rack issue to me. or something not bolted up
     
  3. Oct 19, 2011 at 10:58 PM
    #3
    gacandido2010

    gacandido2010 [OP] Well-Known Member

    Joined:
    Nov 8, 2010
    Member:
    #45890
    Messages:
    632
    Gender:
    Male
    First Name:
    Gabriel
    Inland Empire CA
    Vehicle:
    01 Prerunner TRD
    Bilstein 5100s, Eibach Coils, All Pro Baja Leaf Pack, Fox 2.5x16", All Pro 1.5 spacers, Deckplate Mod, K&N Filter, Magna-Flow Exhaust System, Cobra Ultra Cb with 3" Firestick, 2 Hella 500 HIDs, custom mesh grill, blacked out lettering, Limo Tint, Fog Light Mod
    im pretty i sure didnt miss any bolts, but i did loosen the uca's during installation
     
  4. Oct 19, 2011 at 11:01 PM
    #4
    stephen11ty7

    stephen11ty7 Well-Known Member

    Joined:
    Jun 5, 2011
    Member:
    #57798
    Messages:
    493
    Gender:
    Male
    First Name:
    Stephen
    Villa Park
    Vehicle:
    07 white taco
    Total Chaos 2" LT, Icon coilovers
    I don't think those will really effect it unless the uca isn't attached back to the spindle
     
  5. Oct 19, 2011 at 11:06 PM
    #5
    kinkrider101

    kinkrider101 Well-Known Member

    Joined:
    Sep 29, 2009
    Member:
    #23497
    Messages:
    2,696
    Gender:
    Male
    santa barbara
    Vehicle:
    2007 cummins/2007 tacoma
    wheels and tires
    You need a alignment
     
  6. Oct 19, 2011 at 11:07 PM
    #6
    stephen11ty7

    stephen11ty7 Well-Known Member

    Joined:
    Jun 5, 2011
    Member:
    #57798
    Messages:
    493
    Gender:
    Male
    First Name:
    Stephen
    Villa Park
    Vehicle:
    07 white taco
    Total Chaos 2" LT, Icon coilovers
    That could be a simple fix, plus the alignment shop should be able to diagnose the problem
     
  7. Oct 19, 2011 at 11:10 PM
    #7
    MY50cal

    MY50cal I think I'm getting the Fear.

    Joined:
    Apr 5, 2009
    Member:
    #15613
    Messages:
    2,743
    Gender:
    Male
    First Name:
    Mojo
    Parkesburg, PA
    Vehicle:
    05 SWB TRD 4x4
    Yes.
    anytime you change suspension components you need to get an alignment... have you done this?
     
  8. Oct 19, 2011 at 11:18 PM
    #8
    gacandido2010

    gacandido2010 [OP] Well-Known Member

    Joined:
    Nov 8, 2010
    Member:
    #45890
    Messages:
    632
    Gender:
    Male
    First Name:
    Gabriel
    Inland Empire CA
    Vehicle:
    01 Prerunner TRD
    Bilstein 5100s, Eibach Coils, All Pro Baja Leaf Pack, Fox 2.5x16", All Pro 1.5 spacers, Deckplate Mod, K&N Filter, Magna-Flow Exhaust System, Cobra Ultra Cb with 3" Firestick, 2 Hella 500 HIDs, custom mesh grill, blacked out lettering, Limo Tint, Fog Light Mod
    na but this seems more then just a alignment you think?
    im planning on getting it aligned after i fix it into driving conditions but theres no way i could drive my truck to a shop
     
  9. Oct 19, 2011 at 11:31 PM
    #9
    MY50cal

    MY50cal I think I'm getting the Fear.

    Joined:
    Apr 5, 2009
    Member:
    #15613
    Messages:
    2,743
    Gender:
    Male
    First Name:
    Mojo
    Parkesburg, PA
    Vehicle:
    05 SWB TRD 4x4
    Yes.
    If you have checked over your work and there is nothing drastically wrong, (ie loose or missing bolts, shocks upside down, missing tie rod or the wheel is backwards :p) then yes you need an alignment.
     
  10. Oct 19, 2011 at 11:40 PM
    #10
    gacandido2010

    gacandido2010 [OP] Well-Known Member

    Joined:
    Nov 8, 2010
    Member:
    #45890
    Messages:
    632
    Gender:
    Male
    First Name:
    Gabriel
    Inland Empire CA
    Vehicle:
    01 Prerunner TRD
    Bilstein 5100s, Eibach Coils, All Pro Baja Leaf Pack, Fox 2.5x16", All Pro 1.5 spacers, Deckplate Mod, K&N Filter, Magna-Flow Exhaust System, Cobra Ultra Cb with 3" Firestick, 2 Hella 500 HIDs, custom mesh grill, blacked out lettering, Limo Tint, Fog Light Mod
    wut about the steeriing?
     
  11. Oct 19, 2011 at 11:44 PM
    #11
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,558
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    Alignment, plus they will notice is something is wrong.
     
  12. Oct 19, 2011 at 11:49 PM
    #12
    MY50cal

    MY50cal I think I'm getting the Fear.

    Joined:
    Apr 5, 2009
    Member:
    #15613
    Messages:
    2,743
    Gender:
    Male
    First Name:
    Mojo
    Parkesburg, PA
    Vehicle:
    05 SWB TRD 4x4
    Yes.
    The steering issue is being caused by your truck being out of alignment. Unless there is actually something wrong, (highly unlikely) in which case the shop will be able to tell. Based on what information you have given us, get an alignment.
     
  13. Oct 20, 2011 at 12:11 AM
    #13
    Tigahshark

    Tigahshark Senior NEWBIE

    Joined:
    Aug 14, 2011
    Member:
    #61688
    Messages:
    8,285
    Gender:
    Male
    First Name:
    Isaac
    On a volcano, literally!
    Vehicle:
    2011 DC TRD off road 4X4
    Tint Weathertech floor liner, weathertech window visor Roll n lock tonneau cover Rubber bed mat Smoked license plate covers
    Steering is all over the place cause one tire wants to go the direction its facing and the other tire wants to go the direction its facing.:eek:
     
  14. Oct 20, 2011 at 12:13 AM
    #14
    G scott04

    G scott04 ...

    Joined:
    Jan 17, 2011
    Member:
    #49443
    Messages:
    4,996
    Gender:
    Male
    First Name:
    Garrett
    Mesa
    Vehicle:
    04 PreRunner
    I have to see a pic of this
     
  15. Oct 20, 2011 at 12:16 AM
    #15
    gacandido2010

    gacandido2010 [OP] Well-Known Member

    Joined:
    Nov 8, 2010
    Member:
    #45890
    Messages:
    632
    Gender:
    Male
    First Name:
    Gabriel
    Inland Empire CA
    Vehicle:
    01 Prerunner TRD
    Bilstein 5100s, Eibach Coils, All Pro Baja Leaf Pack, Fox 2.5x16", All Pro 1.5 spacers, Deckplate Mod, K&N Filter, Magna-Flow Exhaust System, Cobra Ultra Cb with 3" Firestick, 2 Hella 500 HIDs, custom mesh grill, blacked out lettering, Limo Tint, Fog Light Mod
    ill get one in the morning but picture like one tire going straight (90 degrees) and the other pointing inward at like 75-80 degrees
     
  16. Oct 20, 2011 at 12:19 AM
    #16
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    22,316
    Gender:
    Male
    First Name:
    Doug
    Gardnerville, Nevada
    Vehicle:
    No Truck
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now
    A pic would help alot, from the way you describe it sounds like tie rod is missing (no reason to mess with them ) or someone has already jacked the alignment on their own, or ????:notsure:

    really need a pic...:cool:
     
  17. Oct 20, 2011 at 12:53 PM
    #17
    pataco

    pataco Well-Known Member

    Joined:
    Jan 1, 2009
    Member:
    #12092
    Messages:
    2,071
    Gender:
    Male
    Down by the lake
    Vehicle:
    05 4x4 trd dc white
    FOX 2.0 RESIS,LRUCAS,BILLY 5100S ON THE REAR.MAGNAFLOW 11264,COLOR MATCHED GRILL,YELLOW FOG MOD.OVER HEAD DVD,FEDERAL COURAGIA M/T
    wow this sounds screwed up.:popcorn:
     
  18. Oct 20, 2011 at 12:58 PM
    #18
    pataco

    pataco Well-Known Member

    Joined:
    Jan 1, 2009
    Member:
    #12092
    Messages:
    2,071
    Gender:
    Male
    Down by the lake
    Vehicle:
    05 4x4 trd dc white
    FOX 2.0 RESIS,LRUCAS,BILLY 5100S ON THE REAR.MAGNAFLOW 11264,COLOR MATCHED GRILL,YELLOW FOG MOD.OVER HEAD DVD,FEDERAL COURAGIA M/T
    and......................:worthless:
     
  19. Oct 20, 2011 at 1:01 PM
    #19
    TACOMABOSS

    TACOMABOSS Well-Known Member

    Joined:
    Jul 7, 2011
    Member:
    #59499
    Messages:
    4,310
    Gender:
    Male
    Vehicle:
    96 SR5 4x4
    Bilstein 5100s, Toytec AAL, Deck plate mod, Hella 500ff's, Sportsman Camo seat covers, Total Chaos 1" diff drop, JVC stereo, Painted bumpers and grille, Custom grille insert, HID projectors, Black spray paint
    X2
     
  20. Oct 20, 2011 at 9:15 PM
    #20
    gacandido2010

    gacandido2010 [OP] Well-Known Member

    Joined:
    Nov 8, 2010
    Member:
    #45890
    Messages:
    632
    Gender:
    Male
    First Name:
    Gabriel
    Inland Empire CA
    Vehicle:
    01 Prerunner TRD
    Bilstein 5100s, Eibach Coils, All Pro Baja Leaf Pack, Fox 2.5x16", All Pro 1.5 spacers, Deckplate Mod, K&N Filter, Magna-Flow Exhaust System, Cobra Ultra Cb with 3" Firestick, 2 Hella 500 HIDs, custom mesh grill, blacked out lettering, Limo Tint, Fog Light Mod
    haha soo i fixed the problem, idk how tho.....i just re did the installation and the angle wasnt as bad, but sterring was fucked up. just got AAA to tow it to firestone got got the lifetime warranty plan for 150 so i can get alignments whnever i want. but after the alignment all my problems went away :D
     
To Top