1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help Needed with 7 Pin Adaptor

Discussion in 'Towing' started by Nola TSS, Apr 1, 2013.

  1. Apr 1, 2013 at 3:09 PM
    #1
    Nola TSS

    Nola TSS [OP] Well-Known Member

    Joined:
    Mar 26, 2013
    Member:
    #100632
    Messages:
    60
    Gender:
    Male
    S Louisiana
    Vehicle:
    '13 Prerunner SR5 TSS v6
    I bought an adaptor from Auto Zone and I could not get the adaptor to insert into the plug all the way. I returned it thinking it was the wrong one. So I went to the Toyota dealership and bought an OEM part and I'm having the same problem. I can insert the adaptor into the plug and it feels like everything is lining up but when I apply pressure to make a snug fit nothing happens. The adaptor is very loose so I know it is not in the plug correctly.
    For those of you who have the adaptor, was it difficult to get a snug fit? I don't want to push too hard and damage the plug.
    Here's the part# from Toyota.
    PT791-89040.
     
  2. Apr 1, 2013 at 3:16 PM
    #2
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,196
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    I have used several different brand of adapters on my truck and none of them went on very tightly....it was more of a snug fit but they all had plastic lips on them for when the cover comes back down, it locks the adapter into place so it doesnt vibrate its way out.
     
  3. Apr 1, 2013 at 3:20 PM
    #3
    Nola TSS

    Nola TSS [OP] Well-Known Member

    Joined:
    Mar 26, 2013
    Member:
    #100632
    Messages:
    60
    Gender:
    Male
    S Louisiana
    Vehicle:
    '13 Prerunner SR5 TSS v6
    The way this one fits as did the other one I returned is still loose. It's like the flat pins are barely inserted into the adaptor. If that's the way it's supposed to fit then I can't see that the adaptor would stay in the plug.
     
  4. Apr 1, 2013 at 3:23 PM
    #4
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,196
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Does it have that plastic lip I talked about to keep it into place? Have you tested it and checked to see if its all functional?
     
  5. Apr 1, 2013 at 3:29 PM
    #5
    Nola TSS

    Nola TSS [OP] Well-Known Member

    Joined:
    Mar 26, 2013
    Member:
    #100632
    Messages:
    60
    Gender:
    Male
    S Louisiana
    Vehicle:
    '13 Prerunner SR5 TSS v6
    Yes. i'll try it again.
    [​IMG]
     
  6. Apr 1, 2013 at 3:32 PM
    #6
    teamamerica

    teamamerica Get off your horse and drink your milk.

    Joined:
    Oct 19, 2012
    Member:
    #89345
    Messages:
    728
    Gender:
    Male
    az
    Vehicle:
    2012 tundra rockwarrior
    none yet
    7pin is universal and should fit no matter what. Are any of the pins bent on the truck part, or the plug? Or is it blocked by a small rock? Most importantly, have you tried spinning it around to make sure you're matching up the pins right?
     
  7. Apr 1, 2013 at 3:33 PM
    #7
    Nola TSS

    Nola TSS [OP] Well-Known Member

    Joined:
    Mar 26, 2013
    Member:
    #100632
    Messages:
    60
    Gender:
    Male
    S Louisiana
    Vehicle:
    '13 Prerunner SR5 TSS v6
    It can only go in one way. Going give it another try.
     
  8. Apr 1, 2013 at 3:33 PM
    #8
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,196
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Yeah like I said mine was only snug and you could still move the adapter around a little bit when it was installed but every time I towed they never had any issues.
     
  9. Apr 1, 2013 at 3:37 PM
    #9
    Nola TSS

    Nola TSS [OP] Well-Known Member

    Joined:
    Mar 26, 2013
    Member:
    #100632
    Messages:
    60
    Gender:
    Male
    S Louisiana
    Vehicle:
    '13 Prerunner SR5 TSS v6
    Went back and I now see how it connects. It does appear to connect properly and when the flap is closed, it does hold the adaptor in place.
    Not the same type of design I had on my F150 10 yrs ago.
    But it does appear to work.
    Thanks to everyone for the help.
    Crawfish on me!
     
  10. Apr 1, 2013 at 3:37 PM
    #10
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,196
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Good to hear!! ;)
     
To Top