1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help! Sudden Issue with 2011 TRD Off-Road

Discussion in '2nd Gen. Tacomas (2005-2015)' started by ryansoup, Nov 12, 2018.

  1. Nov 12, 2018 at 5:39 PM
    #1
    ryansoup

    ryansoup [OP] Active Member

    Joined:
    Jan 6, 2014
    Member:
    #120054
    Messages:
    30
    Gender:
    Male
    Wyo
    Vehicle:
    2011 TRD Off-Road DC
    Bone Stock
    I have a 2011 TRD Offroad 4door. This truck has run like a top for the 5 years I've owned it, right up until this morning when I tried to go to work.

    This last weekend I moved from North Dakota to Wyoming, pretty high up in the mountains. Thing drove fine getting here, drove fine Saturday and drove fine yesterday. Just this morning it had a VERY hard time starting and would not stay running. I finally got it to stay running but only if I kept giving it gas, otherwise it would idle at about 400 rpms until it would die. I managed to get it over to a shop about a block away for them to look at in the morning.

    What could this be? It literally ran fine the same as it always had every day until this morning. The only thing I can think of that changed overnight was the weather, it got down to about 0 degrees. Could I have a fuel restriction from frozen water in the fuel? Any thoughts would be greatly appreciated.
     
  2. Nov 12, 2018 at 5:41 PM
    #2
    bigaltrif

    bigaltrif Well-Known Member

    Joined:
    Mar 30, 2011
    Member:
    #54041
    Messages:
    93
    Gender:
    Male
    First Name:
    Alex
    syracuse, ny
    Maf sensor might need cleaning or replacement
     

Products Discussed in

To Top