1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help TPS for supercharged v6

Discussion in '1st Gen. Tacomas' started by break8012, Jun 19, 2012.

  1. break8012

    break8012 [OP] New Member

    Joined:
    Jun 12, 2012
    Member:
    #80537
    Messages:
    1
    Gender:
    Male
    Supercharger
    Hello Everybody I have a supercharged 2003 tacoma. The Throttle positioning sensor needs replaced. I went and got the stock part but thar didnt work. Toyota is saying i need a whole new throttle body at 1500.00 because that part isnt available separately. TRD wont sell the stand alone TPS. Has anyone had this problem?
     
  2. ScienceofSpeed

    ScienceofSpeed Member

    Joined:
    Mar 18, 2009
    Member:
    #14864
    Messages:
    24
    Gender:
    Male
    First Name:
    FFEJ
    Mesa, Arizona
    Vehicle:
    01 double cab 4x4 trd limited
    grey wire mod, disable drl, diff breather relocation, transmission cooler, deckplate mod, powerslot rotors, hawk HPS brake pads, steel braided brake lines, NGK Iridium plugs & wires, TRD headers, snugtop camper, husky floormats, OME 881, OME HD leafs, OME nitro sport shocks, TRD supercharger, non-turbo supra injectors, Walbro 255 fuel pump, URD 2.2 S/C pulley, AEM fic, One off all stainless 2 1/2 inch custom exhaust
    Most auto makers wont sell them seperate because they calibrate them to the throttle body. I would look for a good used one from a wrecking yard, just make sure you measure the output voltage to the ecu of the old one so you can match it with the replacement. Welcome to TW by the way, great bunch of people and info on here!
     
  3. RacerP

    RacerP Well-Known Member

    Joined:
    Oct 4, 2008
    Member:
    #9677
    Messages:
    434
    Gender:
    Male
    Chicago
    Vehicle:
    2003 4x4
    7th Injector kit, Trans Cooler, Donohoe c/o's, Billy's in the rear, FJ Cruiser Trail Team SE wheels.
    I had this EXACT same problem on my '03 with a S/C. Had this awful stutter at around 60mph. Yes, it was the TPS and I had to replace the whole throttle body.
     
To Top