1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help wiring up a new O2 sensor.

Discussion in 'Technical Chat' started by cvriv.charles, Jun 10, 2009.

  1. Jun 10, 2009 at 5:57 PM
    #1
    cvriv.charles

    cvriv.charles [OP] Member

    Joined:
    Jun 2, 2009
    Member:
    #17961
    Messages:
    7
    Gender:
    Male
    I have 2000 Tacoma 4x4 2.7 reg cab. I bought a new rear denso sensor from ThePartsBin. First,... The wires for my rear O2 sensor is very long. 30 something inches. It starts after the last cat and then up up into the cab and connects under the passenger seat. None of the sensors I online for the rear of my truck came with wires that long. 17.9" was the longest I had found.

    So I bought one with wires at about 11" or so without a connector. I just got it today and within the instructions there wasn't any wiring guide for a toyota tacoma or even toyota at that. I went back online to check to make sure I got the right one and I did.

    There are 4 wires. A white, blue, and two blacks. Assuming the old has a white and blue,... im fine there but what about the two blacks?!? Does it matter if get the blacks from the connector and the sensor connected wrong?!?! Or is it just a matter of following the wires to see whats where? I dont know if the wires are int eh same order on the old as the new.
     
To Top