1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help with 87 4runner charge light keeps coming on!

Discussion in 'Toyota Trucks & SUVs' started by 1999tacotrd, May 6, 2010.

  1. 1999tacotrd

    1999tacotrd [OP] 1999 Taco TRD xtracab 3.4 V6 4x4

    Joined:
    Apr 19, 2009
    Member:
    #16160
    Messages:
    145
    Gender:
    Male
    Hi i have a 87 4runner and last week i was driveing it then the Charge light and brake light both come on so i took it to advance auto they tested it fine so i drove it awhile after that then it started smoking under the hood and smelt like burnt wries so i got it home and pulled the hot wire off the bat while it was running and it died so i went and bought a used altanator which i was sure was the problem cause the old one smelt burnt up so i got the other one on and it worked fine then the next day the dam lights come on again and they come and go and what i notice when they come on the volts meter shoots up to 18 volts then when the lights go off its back down to 14 so is this mean i have a bad volt regaltor or something in the wireing? cause i know 2 altanators doing the same thing is highly unlikely.

    any ideas?
     
To Top