1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

hesitation of the rev up when stabbing the gas.

Discussion in '1st Gen. Tacomas (1995-2004)' started by K-2ombs, Jun 15, 2009.

  1. Jun 15, 2009 at 6:28 PM
    #1
    K-2ombs

    K-2ombs [OP] New Member

    Joined:
    Jun 15, 2009
    Member:
    #18484
    Messages:
    3
    Gender:
    Male
    Binghamton,NY
    Vehicle:
    95', 2.7, 4x4
    Does anyone know what may be causing the hesitation to rev? Both oxygen sensors were just replaced, but that hasn't seemed to change things enough. Also with the frame rust issue............Are there some years worse than others........? Where does the 95 rate? Can vin #'s tell any tale? Like has there been a correlation found about this rusting issue?
     
  2. Jun 15, 2009 at 6:35 PM
    #2
    tacomaman06

    tacomaman06 Carolina Alliance: Lead, follow, or get the hell o Staff Member

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,305
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '13 Silverado ext cab
    welcome to tw.

    couple of things maybe.....whens the last time the plugs were changed.....last time throttle body was cleaned/fuel filter replaced??
     
  3. Jun 15, 2009 at 6:37 PM
    #3
    Burgman

    Burgman I KEEEEEL YOU

    Joined:
    Apr 16, 2009
    Member:
    #16072
    Messages:
    26,725
    Gender:
    Male
    First Name:
    Stephen
    Ric VA
    Vehicle:
    08 PreRunner TRD sport Silver
    K&N intake, Boston Acoustic SL 60 6.5 components up front, Rockford Power T16 6.5 in rear, Pioneer P4100 HU, Soon to be Pioneer Prs 4200f
  4. Jun 15, 2009 at 6:38 PM
    #4
    K-2ombs

    K-2ombs [OP] New Member

    Joined:
    Jun 15, 2009
    Member:
    #18484
    Messages:
    3
    Gender:
    Male
    Binghamton,NY
    Vehicle:
    95', 2.7, 4x4
    I don't know about the throttle body, but the plugs were changed about 39k ago.........I don't know a lot because I am in the process of buying this truck.
     
To Top