1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

hesitation upon acceleration??

Discussion in '2nd Gen. Tacomas (2005-2015)' started by skweezal, Nov 16, 2007.

  1. Nov 16, 2007 at 2:19 PM
    #1
    skweezal

    skweezal [OP] Well-Known Member

    Joined:
    May 4, 2007
    Member:
    #1504
    Messages:
    45
    Gender:
    Female
    Today my 2007 Taco (14K miles) started hesitating upon acceleration, especially around 2000 RPM. Then I give it some gas, it goes, then slows, then goes then slows. I wasnt sure I was gonna make it over a hill!! Just cruising along seems ok, but when I hit the acceleration it heaves!! THe check engine light just came on as well.

    THis is my first problem with it....any suggestions??
    sk
     
  2. Nov 16, 2007 at 3:19 PM
    #2
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    definitely under warranty....take it back to the dealer. check your gas cap first, it may have triggered the cel. it may end up being a faulty sensor from the factory, or maybe even a vacuum line that came unplugged.
     
  3. Nov 16, 2007 at 3:30 PM
    #3
    skweezal

    skweezal [OP] Well-Known Member

    Joined:
    May 4, 2007
    Member:
    #1504
    Messages:
    45
    Gender:
    Female
    thanks! I checked the gas cap first thing...no problem. I am headed to the dealer right now...will let you know what they say. many thanks for taking the time to help :)
     
  4. Nov 16, 2007 at 3:34 PM
    #4
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    its what im here for!! well, that and beer!!!:D
     
  5. Nov 17, 2007 at 1:35 PM
    #5
    skweezal

    skweezal [OP] Well-Known Member

    Joined:
    May 4, 2007
    Member:
    #1504
    Messages:
    45
    Gender:
    Female
    Get this!! The toyota mechanic took it for the test drive and it broke down on him on the freeway....had to tow it back. Certainly under warrantee, but also certainly not good!! Yikes!!!!
     
  6. Nov 17, 2007 at 2:21 PM
    #6
    WilsonTheDog

    WilsonTheDog Kylie's dad

    Joined:
    Nov 17, 2007
    Member:
    #3496
    Messages:
    4,837
    Gender:
    Male
    First Name:
    Eric
    Myrtle Beach SC
    Vehicle:
    07 Prerunner SR5 DC/SB V6
    Magnaflow 12576 muffler & chrome tip, Westin step bars, 27% tint, Pop N Lock, AFE ProdryS, bed mat, Husky liners, D-rings added, Access Literider tonneau, Pioneer 4-ways all around, GY Wrangler Duratracs 265/75/16, 5100's @ 1.75", 1.5" AAL
    That sounds like MAF failure. Let us know.
     
  7. Nov 17, 2007 at 3:08 PM
    #7
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....

    yes,definitely let us know what it turns out to be!!!
     
  8. Nov 20, 2007 at 1:55 PM
    #8
    skweezal

    skweezal [OP] Well-Known Member

    Joined:
    May 4, 2007
    Member:
    #1504
    Messages:
    45
    Gender:
    Female
    ok....the dealer says it is the fuel pump....new one to be installed. Hopefully this will fix the problem!!!
     
  9. Nov 20, 2007 at 2:23 PM
    #9
    jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Moderator

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    28,120
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    wow...craziness
     
  10. Nov 20, 2007 at 6:54 PM
    #10
    WilsonTheDog

    WilsonTheDog Kylie's dad

    Joined:
    Nov 17, 2007
    Member:
    #3496
    Messages:
    4,837
    Gender:
    Male
    First Name:
    Eric
    Myrtle Beach SC
    Vehicle:
    07 Prerunner SR5 DC/SB V6
    Magnaflow 12576 muffler & chrome tip, Westin step bars, 27% tint, Pop N Lock, AFE ProdryS, bed mat, Husky liners, D-rings added, Access Literider tonneau, Pioneer 4-ways all around, GY Wrangler Duratracs 265/75/16, 5100's @ 1.75", 1.5" AAL
    Glad it worked. Scary that it's on a new truck, though. Things happen.
     
  11. Nov 20, 2007 at 7:14 PM
    #11
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....

    very true......but better now, then when its outta warranty!!
     
  12. Nov 20, 2007 at 8:35 PM
    #12
    Viper-2

    Viper-2 Secret Agent

    Joined:
    Jul 12, 2007
    Member:
    #2073
    Messages:
    503
    Gender:
    Male
    First Name:
    Keith
    Charleston, SC
    Vehicle:
    Prerunner with many mods
    That sucks.
     
  13. Nov 21, 2007 at 11:29 AM
    #13
    skweezal

    skweezal [OP] Well-Known Member

    Joined:
    May 4, 2007
    Member:
    #1504
    Messages:
    45
    Gender:
    Female
    AND I was glad it broke down on the mechanic and not me!!! Hopefully all will be fixed and I will once again love my truck!!
    cheers!
    sk
     
  14. Nov 22, 2007 at 7:04 AM
    #14
    concrete jedi

    concrete jedi Well-Known Member

    Joined:
    Oct 20, 2007
    Member:
    #3142
    Messages:
    2,741
    Rochester N.Y
    Vehicle:
    06 Tacoma 4 door indigo blue
    Broken and scratched tailgate, cracked rear tail light lens, coffee stain in driver seat.
    Tell you what, I am a lucky S.O.B ( OK just an S.O.B. ) but I have had nothing but complete JOY from my truck. I broke the tailgate latching mechanism, by slamming the gate closed with the area between the gate and the bed full of gravel ( bad, very bad ), cracked the tail light lens ( loading firewood ) I have scatched the living hell out of it ( too many things to mention ) but all these things were generated by said owner. I'll be out of warranty by spring so I better slow down. Good luck with your fuel pump and your truck. Drive on. :D
     
  15. Nov 27, 2012 at 8:16 PM
    #15
    Toyotamudbogs

    Toyotamudbogs Well-Known Member

    Joined:
    Mar 20, 2012
    Member:
    #75239
    Messages:
    161
    Gender:
    Male
    First Name:
    Devin
    White Springs , FL
    Vehicle:
    06 Tacoma 4x4, 4 door sr5
    Tintedwindows,Rockforfosgate amp 2 10" sub , fire dept radio,Rock sliders, Body Armer front Bumper, CB, 3'' EZ leveling kit, fog light mod, beep on lock mod, front duallys rigid led lights, rigid led flasher kit
    I have a 06 v6 Taco. when I bought it used 123,000 it has a hesitation when I get on the gas to pass someone. it runs good other than that . what could this be ?
     
  16. Apr 22, 2013 at 7:47 AM
    #16
    cbe513

    cbe513 Active Member

    Joined:
    Feb 20, 2013
    Member:
    #97988
    Messages:
    43
    Gender:
    Male
    First Name:
    Cory
    Pottstown PA
    Vehicle:
    06 Sport
    3in pro comp lift Halo 17" Rims 285x70x17 Nitto Terra Grapplers KN Air Access Literider AVS bug and window visors GTA Radio Adapter
    bump for answer, did you get this solved?
     
  17. Apr 22, 2013 at 1:55 PM
    #17
    skweezal

    skweezal [OP] Well-Known Member

    Joined:
    May 4, 2007
    Member:
    #1504
    Messages:
    45
    Gender:
    Female
    Yes...can't remember the problem as it was a while ago ( might have been clogged fuel line). Just sold that truck and got a 2013 TRD sport...love it!
     
  18. Apr 23, 2013 at 5:58 AM
    #18
    Toyotamudbogs

    Toyotamudbogs Well-Known Member

    Joined:
    Mar 20, 2012
    Member:
    #75239
    Messages:
    161
    Gender:
    Male
    First Name:
    Devin
    White Springs , FL
    Vehicle:
    06 Tacoma 4x4, 4 door sr5
    Tintedwindows,Rockforfosgate amp 2 10" sub , fire dept radio,Rock sliders, Body Armer front Bumper, CB, 3'' EZ leveling kit, fog light mod, beep on lock mod, front duallys rigid led lights, rigid led flasher kit
    I was thinken it was normal since its a electric gas peddle.
     
  19. Apr 23, 2013 at 11:11 AM
    #19
    miniceptor86

    miniceptor86 Well-Known Member

    Joined:
    Feb 18, 2008
    Member:
    #4799
    Messages:
    572
    Gender:
    Male
    First Name:
    Jim
    McGregor,IA
    Vehicle:
    07 Speedway Blue Prerunner Dbl cab
    TRD sport exhaust and cold air intake, nerf and bull bar, RideRide, ProEFX towing mirrors, BakFlip F1 trifold tonneau
    I think your fuel pump problem was also self inflicted. 2007 with 14K miles, get out and use it. The fuel pump atrophied from lack of pumping action.
     
  20. Apr 23, 2013 at 12:13 PM
    #20
    miniceptor86

    miniceptor86 Well-Known Member

    Joined:
    Feb 18, 2008
    Member:
    #4799
    Messages:
    572
    Gender:
    Male
    First Name:
    Jim
    McGregor,IA
    Vehicle:
    07 Speedway Blue Prerunner Dbl cab
    TRD sport exhaust and cold air intake, nerf and bull bar, RideRide, ProEFX towing mirrors, BakFlip F1 trifold tonneau
    Well than that's better!
     
To Top