1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

High Idle

Discussion in 'X-Runners' started by xrunner143, Mar 16, 2011.

  1. Mar 16, 2011 at 7:53 PM
    #1
    xrunner143

    xrunner143 [OP] New Member

    Joined:
    Mar 16, 2011
    Member:
    #53165
    Messages:
    1
    Gender:
    Male
    Mt. Dora, Fl.
    Vehicle:
    06 XRUNNER 4.0L
    Does everyone else seem to have their xrunner maintain a high idle when shifting gears while getting into the revs. Almost like it has a vacuum leak but I can not seem to find one. Just bought the truck a couple weeks ago and love it. Engine seems to be very "ticky". Is this something to be worried about or are these normal traits for the 4.0L.
     
  2. Mar 16, 2011 at 8:35 PM
    #2
    98_Mud_bug

    98_Mud_bug 98_mud_bug

    Joined:
    Aug 9, 2008
    Member:
    #8431
    Messages:
    3,194
    Gender:
    Male
    lucedale Ms.
    Vehicle:
    98 tacoma sr5/ 06 x-runner
    3 inch suspension lift, night shades corner and blinkers projector headlights with halos and 3 led's 18 inch kmc xd rockstar wheels,275/65/18 kelly safari tsr's, bush whacker fender flares 7 inch touch screen, 2 kenwood 12's, Magnaflow exaust single in dual out,
    completely normal. my xrunner does the same thing. i can slowly shift and the rpm's dont change at all, I normally shift about 2500 rpm's and it might drop to 2400 before i catch the next gear. and the tick is completely normal.
     
To Top